aboutsummaryrefslogtreecommitdiff
path: root/graphics/geos/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-02-04 00:16:36 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-02-04 00:16:36 +0000
commit66bff4597690aa7465de13e8b07ee12c132470c6 (patch)
treec0fea1f9268a51d74c1d026f583d84e7ec6e94b5 /graphics/geos/Makefile
parentb3331d7390abdbf73742c0c82012c92a76334496 (diff)
downloadports-66bff4597690aa7465de13e8b07ee12c132470c6.tar.gz
ports-66bff4597690aa7465de13e8b07ee12c132470c6.zip
Update to 3.7.1
Notes
Notes: svn path=/head/; revision=492094
Diffstat (limited to 'graphics/geos/Makefile')
-rw-r--r--graphics/geos/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/graphics/geos/Makefile b/graphics/geos/Makefile
index c466a46846cd..1667181fe95f 100644
--- a/graphics/geos/Makefile
+++ b/graphics/geos/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= geos
-PORTVERSION= 3.6.3
-PORTREVISION= 1
+PORTVERSION= 3.7.1
CATEGORIES= graphics geography
MASTER_SITES= https://download.osgeo.org/geos/ \
LOCAL/sunpoet
@@ -17,12 +16,13 @@ LICENSE_FILE= ${WRKSRC}/COPYING
OPTIONS_DEFINE= RUBY
OPTIONS_SUB= yes
+USES= compiler:c++11-lang gmake libtool tar:bzip2
+
CONFIGURE_ARGS= ac_cv_path_SWIG=${LOCALBASE}/bin/swig3.0
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
TEST_TARGET= check
USE_LDCONFIG= yes
-USES= gmake libtool tar:bzip2
PLIST_SUB= PORTVERSION=${PORTVERSION}
@@ -35,6 +35,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|-lstdc++||' ${WRKSRC}/tests/geostest/Makefile.in ${WRKSRC}/tests/thread/Makefile.in
post-configure:
- @${FIND} ${WRKSRC} -name Makefile -exec ${REINPLACE_CMD} -e '/CXXFLAGS = / s| -O2||' {} \;
+ @${FIND} ${WRKSRC} -name Makefile -exec ${REINPLACE_CMD} -e '/CXXFLAGS = / s| -O2||' {} +
.include <bsd.port.mk>