aboutsummaryrefslogtreecommitdiff
path: root/graphics/geos/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-10-04 15:13:06 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-10-04 15:13:06 +0000
commit7ba51f0e05e61e206515653323888aefca8beaa1 (patch)
treeb99fd94d900f17e073ca9e949422006c3bdae315 /graphics/geos/Makefile
parent0b7dc78ac0e89d7b189e9e344c6a1fa7a5805228 (diff)
downloadports-7ba51f0e05e61e206515653323888aefca8beaa1.tar.gz
ports-7ba51f0e05e61e206515653323888aefca8beaa1.zip
- Use INSTALL_TARGET=install-strip
Notes
Notes: svn path=/head/; revision=369972
Diffstat (limited to 'graphics/geos/Makefile')
-rw-r--r--graphics/geos/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/graphics/geos/Makefile b/graphics/geos/Makefile
index 1c670234e0e0..14315d459dcc 100644
--- a/graphics/geos/Makefile
+++ b/graphics/geos/Makefile
@@ -14,9 +14,11 @@ COMMENT= GEOS implements all the OpenGIS "Simple Features for SQL"
LICENSE= LGPL21
OPTIONS_DEFINE= PHP PYTHON RUBY
+OPTIONS_DEFAULT=PHP PYTHON RUBY
OPTIONS_SUB= yes
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
USES= gmake libtool tar:bzip2
@@ -33,8 +35,4 @@ RUBY_CONFIGURE_ENABLE= ruby
RUBY_CONFIGURE_ENV= RUBY="${RUBY}"
RUBY_USE= RUBY=yes
-post-install:
- ${LN} -s ${PREFIX}/lib/libgeos-${PORTVERSION}.so ${STAGEDIR}${PREFIX}/lib/libgeos.so.0
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgeos-${PORTVERSION}.so ${STAGEDIR}${PREFIX}/lib/libgeos_c.so.1.8.2
-
.include <bsd.port.mk>