aboutsummaryrefslogtreecommitdiff
path: root/graphics/geos/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-09-07 17:51:24 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-09-07 17:51:24 +0000
commit8f187f74fdc9f614a3b75e04e5cb32e271f05d4d (patch)
tree6934cbfb209392c330f3055220a67d8852642fff /graphics/geos/Makefile
parent5d059778c90830b4276569b69145f9963a466f1b (diff)
downloadports-8f187f74fdc9f614a3b75e04e5cb32e271f05d4d.tar.gz
ports-8f187f74fdc9f614a3b75e04e5cb32e271f05d4d.zip
- Update to 3.5.0
Notes
Notes: svn path=/head/; revision=396303
Diffstat (limited to 'graphics/geos/Makefile')
-rw-r--r--graphics/geos/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/graphics/geos/Makefile b/graphics/geos/Makefile
index 468a1c3f9a7d..5d0e4f47e3d9 100644
--- a/graphics/geos/Makefile
+++ b/graphics/geos/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= geos
-PORTVERSION= 3.4.2
-PORTREVISION= 3
+PORTVERSION= 3.5.0
CATEGORIES= graphics geography
MASTER_SITES= http://download.osgeo.org/geos/ \
LOCAL/sunpoet
@@ -17,6 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
OPTIONS_DEFINE= PHP PYTHON RUBY
OPTIONS_SUB= yes
+CONFIGURE_ARGS= ac_cv_path_SWIG=${LOCALBASE}/bin/swig3.0
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
@@ -24,18 +24,18 @@ USES= gmake libtool tar:bzip2
PLIST_SUB= PORTVERSION=${PORTVERSION}
-PHP_BUILD_DEPENDS= ${LOCALBASE}/bin/swig1.3:${PORTSDIR}/devel/swig13
+PHP_BUILD_DEPENDS= ${LOCALBASE}/bin/swig3.0:${PORTSDIR}/devel/swig30
PHP_CONFIGURE_ENABLE= php
PHP_USE= PHP=yes PHP_BUILD=yes
-PYTHON_BUILD_DEPENDS= ${LOCALBASE}/bin/swig1.3:${PORTSDIR}/devel/swig13
+PYTHON_BUILD_DEPENDS= ${LOCALBASE}/bin/swig3.0:${PORTSDIR}/devel/swig30
PYTHON_CONFIGURE_ENABLE=python
PYTHON_USES= python:2
-RUBY_BUILD_DEPENDS= ${LOCALBASE}/bin/swig1.3:${PORTSDIR}/devel/swig13
+RUBY_BUILD_DEPENDS= ${LOCALBASE}/bin/swig3.0:${PORTSDIR}/devel/swig30
RUBY_CONFIGURE_ENABLE= ruby
RUBY_CONFIGURE_ENV= RUBY="${RUBY}"
RUBY_USE= RUBY=yes
post-patch:
- @${REINPLACE_CMD} -e 's|-lstdc++||' ${WRKSRC}/configure ${WRKSRC}/tests/geostest/Makefile.in ${WRKSRC}/tests/thread/Makefile.in
+ @${REINPLACE_CMD} -e 's|-lstdc++||' ${WRKSRC}/tests/geostest/Makefile.in ${WRKSRC}/tests/thread/Makefile.in
.include <bsd.port.mk>