aboutsummaryrefslogtreecommitdiff
path: root/graphics/geos/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-02-16 22:43:35 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-02-16 22:43:35 +0000
commited5433b37827c1b98d15e49d17e84ce799c86f69 (patch)
treeefb114079c65e3bde3a844bc59f7c6a35a612730 /graphics/geos/Makefile
parent54caf18b8b1b29fed5634a703d6627bffa2b3138 (diff)
downloadports-ed5433b37827c1b98d15e49d17e84ce799c86f69.tar.gz
ports-ed5433b37827c1b98d15e49d17e84ce799c86f69.zip
- Update to version 3.3.7 [1]
- Convert to OptionsNG PR: ports/175623 [1] Submitted by: Rainer Hurling <rhurlin@gwdg.de> Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=312389
Diffstat (limited to 'graphics/geos/Makefile')
-rw-r--r--graphics/geos/Makefile22
1 files changed, 8 insertions, 14 deletions
diff --git a/graphics/geos/Makefile b/graphics/geos/Makefile
index 40b052ae9e17..033bb0a1d7b2 100644
--- a/graphics/geos/Makefile
+++ b/graphics/geos/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: geos
-# Date created: 19 December 2003
-# Whom: Leonardo Martins <lmartins@nepe.eee.ufg.br>
-#
+# Created by: Leonardo Martins <lmartins@nepe.eee.ufg.br>
# $FreeBSD$
-#
PORTNAME= geos
-PORTVERSION= 3.3.3
+PORTVERSION= 3.3.7
CATEGORIES= graphics geography
MASTER_SITES= http://download.osgeo.org/geos/
@@ -21,17 +17,15 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-OPTIONS= PYTHON "Enable python bindings" off \
- PHP "Enable php bindings" off \
- RUBY "Enable ruby bindings" off
+OPTIONS_DEFINE= PHP PYTHON RUBY
.include <bsd.port.options.mk>
-.if defined(WITH_PHP) || defined(WITH_PYTHON) || defined(WITH_RUBY)
+.if ${PORT_OPTIONS:MPHP} || ${PORT_OPTIONS:MPYTHON} || ${PORT_OPTIONS:MRUBY}
BUILD_DEPENDS+= swig1.3:${PORTSDIR}/devel/swig13
.endif
-.if defined(WITH_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= yes
CONFIGURE_ARGS+= --enable-python
PLIST_SUB+= WITH_PYTHON=""
@@ -39,7 +33,7 @@ PLIST_SUB+= WITH_PYTHON=""
PLIST_SUB+= WITH_PYTHON="@comment "
.endif
-.if defined(WITH_PHP)
+.if ${PORT_OPTIONS:MPHP}
BUILD_DEPENDS+= ${LOCALBASE}/bin/php-config:${PORTSDIR}/lang/php5
CONFIGURE_ARGS+= --enable-php
PLIST_SUB+= WITH_PHP=""
@@ -47,7 +41,7 @@ PLIST_SUB+= WITH_PHP=""
PLIST_SUB+= WITH_PHP="@comment "
.endif
-.if defined(WITH_RUBY)
+.if ${PORT_OPTIONS:MRUBY}
USE_RUBY= yes
CONFIGURE_ARGS+= --enable-ruby
CONFIGURE_ENV+= RUBY="${RUBY}"
@@ -57,6 +51,6 @@ PLIST_SUB+= WITH_RUBY="@comment "
.endif
post-install:
- @${LN} -s ${PREFIX}/lib/libgeos-${PORTVERSION}.so ${PREFIX}/lib/libgeos.so.0
+ @${LN} -s ${PREFIX}/lib/libgeos-${PORTVERSION}.so ${PREFIX}/lib/libgeos.so.0
.include <bsd.port.mk>