aboutsummaryrefslogtreecommitdiff
path: root/graphics/gexiv2
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2018-12-06 14:52:15 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2018-12-06 14:52:15 +0000
commit384f24e25f39f737438071bad9c39d8d013b6e0c (patch)
tree5de8d823bdf92027284a73c3294bac199c9e6894 /graphics/gexiv2
parent673831fd58af98ea9e9e1e8d5b20384167679ad6 (diff)
downloadports-384f24e25f39f737438071bad9c39d8d013b6e0c.tar.gz
ports-384f24e25f39f737438071bad9c39d8d013b6e0c.zip
gexiv2: fix build with non-clang compilers
clang silently ignores empty arguments, others do complain. Set up conditional arguments like the meson documentation recommends. PR: 233668 Reported by: Piotr Kubaj, jhibbits@
Notes
Notes: svn path=/head/; revision=486763
Diffstat (limited to 'graphics/gexiv2')
-rw-r--r--graphics/gexiv2/files/patch-gexiv2_meson.build15
1 files changed, 10 insertions, 5 deletions
diff --git a/graphics/gexiv2/files/patch-gexiv2_meson.build b/graphics/gexiv2/files/patch-gexiv2_meson.build
index c967491f8a30..af4e439075d6 100644
--- a/graphics/gexiv2/files/patch-gexiv2_meson.build
+++ b/graphics/gexiv2/files/patch-gexiv2_meson.build
@@ -1,11 +1,16 @@
---- gexiv2/meson.build.orig 2018-11-23 19:55:20 UTC
-+++ gexiv2/meson.build
-@@ -35,7 +35,7 @@ install_headers(gexiv2_headers, subdir :
+--- gexiv2/meson.build.orig 2018-12-01 18:58:21.005598000 +0100
++++ gexiv2/meson.build 2018-12-01 19:01:56.566055000 +0100
+@@ -35,10 +35,10 @@
# Static map file
mapfile = 'gexiv2.map'
-if host_machine.system() == 'darwin'
+- vflag = ''
+if host_machine.system() == 'darwin' or host_machine.system() == 'freebsd'
- vflag = ''
++ vflag = []
else
- vflag = '-Wl,--version-script,@0@/@1@'.format(meson.current_source_dir(), mapfile)
+- vflag = '-Wl,--version-script,@0@/@1@'.format(meson.current_source_dir(), mapfile)
++ vflag = ['-Wl,--version-script,@0@/@1@'.format(meson.current_source_dir(), mapfile)]
+ endif
+
+ gexiv2 = library('gexiv2',