aboutsummaryrefslogtreecommitdiff
path: root/graphics/gexiv2
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-03-08 19:49:59 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-03-08 19:49:59 +0000
commit4a078bc39b56f067a1e666ddf983364d39bd17d2 (patch)
tree58d3e3bf653975e8fb3f7b8bf662a077bb2702ed /graphics/gexiv2
parent2d470a9af740a8f273a932a5517d44b8186e33cb (diff)
downloadports-4a078bc39b56f067a1e666ddf983364d39bd17d2.tar.gz
ports-4a078bc39b56f067a1e666ddf983364d39bd17d2.zip
graphics/gexiv2: prepare for exiv2-0.27
Import upstream patch to fix build against graphcis/exiv2-0.27: https://github.com/Exiv2/exiv2/issues/555#issuecomment-440023260 PR: 235943
Notes
Notes: svn path=/head/; revision=495064
Diffstat (limited to 'graphics/gexiv2')
-rw-r--r--graphics/gexiv2/Makefile2
-rw-r--r--graphics/gexiv2/files/patch-git_d8f966181
2 files changed, 182 insertions, 1 deletions
diff --git a/graphics/gexiv2/Makefile b/graphics/gexiv2/Makefile
index c59d145bfae7..7b6a17c8787a 100644
--- a/graphics/gexiv2/Makefile
+++ b/graphics/gexiv2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gexiv2
PORTVERSION= 0.10.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= GNOME
diff --git a/graphics/gexiv2/files/patch-git_d8f966 b/graphics/gexiv2/files/patch-git_d8f966
new file mode 100644
index 000000000000..d4a5d6f78ea9
--- /dev/null
+++ b/graphics/gexiv2/files/patch-git_d8f966
@@ -0,0 +1,181 @@
+From d8f96634e1df693eb0393cf82893a86dd2a92d2b Mon Sep 17 00:00:00 2001
+From: Jens Georg <mail@jensge.org>
+Date: Tue, 20 Nov 2018 12:43:21 +0100
+Subject: [PATCH] Replace single-file includes
+
+To improve compatibility with exiv2 0.27 as recommended in
+
+Fixes #34
+
+https://github.com/Exiv2/exiv2/issues/555#issuecomment-440023260
+---
+ gexiv2/gexiv2-metadata-exif.cpp | 2 +-
+ gexiv2/gexiv2-metadata-gps.cpp | 2 +-
+ gexiv2/gexiv2-metadata-iptc.cpp | 2 +-
+ gexiv2/gexiv2-metadata-private.h | 6 +-----
+ gexiv2/gexiv2-metadata-xmp.cpp | 2 +-
+ gexiv2/gexiv2-metadata.cpp | 9 ++-------
+ gexiv2/gexiv2-preview-image-private.h | 2 +-
+ gexiv2/gexiv2-preview-properties-private.h | 2 +-
+ gexiv2/gexiv2-startup.cpp | 2 +-
+ gexiv2/gexiv2-stream-io.cpp | 2 +-
+ gexiv2/gexiv2-stream-io.h | 2 +-
+ 11 files changed, 12 insertions(+), 21 deletions(-)
+
+diff --git gexiv2/gexiv2-metadata-exif.cpp gexiv2/gexiv2-metadata-exif.cpp
+index c87a460..f931b95 100644
+--- gexiv2/gexiv2-metadata-exif.cpp
++++ gexiv2/gexiv2-metadata-exif.cpp
+@@ -12,7 +12,7 @@
+ #include "gexiv2-metadata-private.h"
+ #include <string>
+ #include <glib-object.h>
+-#include <exiv2/exif.hpp>
++#include <exiv2/exiv2.hpp>
+
+ G_BEGIN_DECLS
+
+diff --git gexiv2/gexiv2-metadata-gps.cpp gexiv2/gexiv2-metadata-gps.cpp
+index d49d97c..47592ec 100644
+--- gexiv2/gexiv2-metadata-gps.cpp
++++ gexiv2/gexiv2-metadata-gps.cpp
+@@ -15,7 +15,7 @@
+ #include <stdexcept>
+ #include <stdio.h>
+ #include <glib-object.h>
+-#include <exiv2/exif.hpp>
++#include <exiv2/exiv2.hpp>
+
+ #include <limits>
+
+diff --git gexiv2/gexiv2-metadata-iptc.cpp gexiv2/gexiv2-metadata-iptc.cpp
+index 2371708..aeac1c7 100644
+--- gexiv2/gexiv2-metadata-iptc.cpp
++++ gexiv2/gexiv2-metadata-iptc.cpp
+@@ -12,7 +12,7 @@
+ #include "gexiv2-metadata-private.h"
+ #include <string>
+ #include <glib-object.h>
+-#include <exiv2/iptc.hpp>
++#include <exiv2/exiv2.hpp>
+
+ G_BEGIN_DECLS
+
+diff --git gexiv2/gexiv2-metadata-private.h gexiv2/gexiv2-metadata-private.h
+index d85453c..8818c22 100644
+--- gexiv2/gexiv2-metadata-private.h
++++ gexiv2/gexiv2-metadata-private.h
+@@ -11,11 +11,7 @@
+ #define GEXIV2_METADATA_PRIVATE_H
+
+ #include <gexiv2/gexiv2-metadata.h>
+-#include <exiv2/image.hpp>
+-#include <exiv2/exif.hpp>
+-#include <exiv2/iptc.hpp>
+-#include <exiv2/xmp.hpp>
+-#include <exiv2/preview.hpp>
++#include <exiv2/exiv2.hpp>
+
+ G_BEGIN_DECLS
+
+diff --git gexiv2/gexiv2-metadata-xmp.cpp gexiv2/gexiv2-metadata-xmp.cpp
+index e4900f2..6f60cd0 100644
+--- gexiv2/gexiv2-metadata-xmp.cpp
++++ gexiv2/gexiv2-metadata-xmp.cpp
+@@ -12,7 +12,7 @@
+ #include "gexiv2-metadata-private.h"
+ #include <string>
+ #include <glib-object.h>
+-#include <exiv2/xmp.hpp>
++#include <exiv2/exiv2.hpp>
+
+ G_BEGIN_DECLS
+
+diff --git gexiv2/gexiv2-metadata.cpp gexiv2/gexiv2-metadata.cpp
+index 98ded9d..9c791ef 100644
+--- gexiv2/gexiv2-metadata.cpp
++++ gexiv2/gexiv2-metadata.cpp
+@@ -22,13 +22,8 @@
+ #include <cmath>
+ #include <glib-object.h>
+ #include <gio/gio.h>
+-#include <exiv2/image.hpp>
+-#include <exiv2/xmpsidecar.hpp>
+-#include <exiv2/exif.hpp>
+-#include <exiv2/iptc.hpp>
+-#include <exiv2/xmp.hpp>
+-#include <exiv2/preview.hpp>
+-#include <exiv2/jpgimage.hpp>
++
++#include <exiv2/exiv2.hpp>
+
+
+ G_BEGIN_DECLS
+diff --git gexiv2/gexiv2-preview-image-private.h gexiv2/gexiv2-preview-image-private.h
+index 810304c..b52a84f 100644
+--- gexiv2/gexiv2-preview-image-private.h
++++ gexiv2/gexiv2-preview-image-private.h
+@@ -11,7 +11,7 @@
+ #define GEXIV2_PREVIEW_IMAGE_PRIVATE_H
+
+ #include <gexiv2/gexiv2-preview-image.h>
+-#include <exiv2/preview.hpp>
++#include <exiv2/exiv2.hpp>
+
+ G_BEGIN_DECLS
+
+diff --git gexiv2/gexiv2-preview-properties-private.h gexiv2/gexiv2-preview-properties-private.h
+index bacb392..b057604 100644
+--- gexiv2/gexiv2-preview-properties-private.h
++++ gexiv2/gexiv2-preview-properties-private.h
+@@ -11,7 +11,7 @@
+ #define GEXIV2_PREVIEW_PROPERTIES_PRIVATE_H
+
+ #include <gexiv2/gexiv2-preview-properties.h>
+-#include <exiv2/preview.hpp>
++#include <exiv2/exiv2.hpp>
+
+ G_BEGIN_DECLS
+
+diff --git gexiv2/gexiv2-startup.cpp gexiv2/gexiv2-startup.cpp
+index 179b6c7..de438de 100644
+--- gexiv2/gexiv2-startup.cpp
++++ gexiv2/gexiv2-startup.cpp
+@@ -7,7 +7,7 @@
+ * This is free software. See COPYING for details.
+ */
+
+-#include <exiv2/xmp.hpp>
++#include <exiv2/exiv2.hpp>
+ #include "gexiv2-startup.h"
+ #include "gexiv2-version.h"
+
+diff --git gexiv2/gexiv2-stream-io.cpp gexiv2/gexiv2-stream-io.cpp
+index b772b74..454305d 100644
+--- gexiv2/gexiv2-stream-io.cpp
++++ gexiv2/gexiv2-stream-io.cpp
+@@ -13,7 +13,7 @@
+ #include "gexiv2-stream-io.h"
+ #include "gexiv2-managed-stream.h"
+
+-#include <exiv2/basicio.hpp>
++#include <exiv2/exiv2.hpp>
+ #include <gio/gio.h>
+ #include <glib.h>
+ #include <stdio.h>
+diff --git gexiv2/gexiv2-stream-io.h gexiv2/gexiv2-stream-io.h
+index 430ac01..8d1fe76 100644
+--- gexiv2/gexiv2-stream-io.h
++++ gexiv2/gexiv2-stream-io.h
+@@ -16,7 +16,7 @@
+ #define GEXIV2_STREAM_IO_H
+
+ #include <gexiv2/gexiv2-managed-stream.h>
+-#include <exiv2/basicio.hpp>
++#include <exiv2/exiv2.hpp>
+ #include <gio/gio.h>
+
+
+--
+2.18.1
+