aboutsummaryrefslogtreecommitdiff
path: root/graphics/gexiv2
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-07-09 23:43:56 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-07-09 23:49:06 +0000
commita3a68eda0484fbbc23a313b5e338e281662b40f1 (patch)
tree6c15fb36bef826b36badcb6e508a26487259a588 /graphics/gexiv2
parent9382e1983615b9bd30bb1d499e94571da74b6bbe (diff)
downloadports-a3a68eda0484fbbc23a313b5e338e281662b40f1.tar.gz
ports-a3a68eda0484fbbc23a313b5e338e281662b40f1.zip
graphics/gexiv2: mark BROKEN on i386 after ce4a214fb709
In file included from ../gexiv2/gexiv2-metadata.cpp:21: ../gexiv2/gexiv2-stream-io.h:49:39: error: non-virtual member function marked 'override' hides virtual member function int seek (long offset, Position pos) override; ^ /usr/local/include/exiv2/basicio.hpp:165:15: note: hidden overloaded virtual function 'Exiv2::BasicIo::seek' declared here: type mismatch at 1st parameter ('int64_t' (aka 'long long') vs 'long') virtual int seek(int64_t offset, Position pos) = 0; ^ ../gexiv2/gexiv2-metadata.cpp:152:71: error: non-virtual member function marked 'override' hides virtual member function int seek(seek_offset_t offset, Exiv2::BasicIo::Position position) override { ^ /usr/local/include/exiv2/basicio.hpp:165:15: note: hidden overloaded virtual function 'Exiv2::BasicIo::seek' declared here: type mismatch at 1st parameter ('int64_t' (aka 'long long') vs '(anonymous namespace)::GioIo::seek_offset_t' (aka 'long')) virtual int seek(int64_t offset, Position pos) = 0; ^ ../gexiv2/gexiv2-metadata.cpp:533:43: error: allocating an object of abstract class type 'StreamIo' StreamIo::ptr_type stream_ptr{new StreamIo (cb)}; ^ /usr/local/include/exiv2/basicio.hpp:165:15: note: unimplemented pure virtual method 'seek' in 'StreamIo' virtual int seek(int64_t offset, Position pos) = 0; ^ ../gexiv2/gexiv2-metadata.cpp:552:37: error: allocating an object of abstract class type '(anonymous namespace)::GioIo' GioIo::ptr_type gio_ptr{new GioIo (stream)}; ^ /usr/local/include/exiv2/basicio.hpp:165:15: note: unimplemented pure virtual method 'seek' in 'GioIo' virtual int seek(int64_t offset, Position pos) = 0; ^ ../gexiv2/gexiv2-metadata.cpp:744:43: error: allocating an object of abstract class type 'StreamIo' StreamIo::ptr_type stream_ptr{new StreamIo (cb)}; ^ In file included from ../gexiv2/gexiv2-stream-io.cpp:13: ../gexiv2/gexiv2-stream-io.h:49:39: error: non-virtual member function marked 'override' hides virtual member function int seek (long offset, Position pos) override; ^ /usr/local/include/exiv2/basicio.hpp:165:15: note: hidden overloaded virtual function 'Exiv2::BasicIo::seek' declared here: type mismatch at 1st parameter ('int64_t' (aka 'long long') vs 'long') virtual int seek(int64_t offset, Position pos) = 0; ^ PR: 272311
Diffstat (limited to 'graphics/gexiv2')
-rw-r--r--graphics/gexiv2/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/graphics/gexiv2/Makefile b/graphics/gexiv2/Makefile
index 70f0dce5f012..6dbce9dc4408 100644
--- a/graphics/gexiv2/Makefile
+++ b/graphics/gexiv2/Makefile
@@ -14,6 +14,8 @@ WWW= https://wiki.gnome.org/Projects/gexiv2
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_i386= fails to build with exiv2 0.28
+
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gobject3>=0:devel/py-gobject3@${PY_FLAVOR}
LIB_DEPENDS= libexiv2.so:graphics/exiv2
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gobject3>=0:devel/py-gobject3@${PY_FLAVOR}