aboutsummaryrefslogtreecommitdiff
path: root/graphics/giflib
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-12-10 15:52:21 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-12-10 15:52:21 +0000
commit397f3fae0834f2fa7721cee158e50ed873e6beca (patch)
tree8f8861c465650f3370278dc2d4d48e7aeec9861d /graphics/giflib
parent2ff6de7ee9df7257463fcccb9cc62815f7971552 (diff)
downloadports-397f3fae0834f2fa7721cee158e50ed873e6beca.tar.gz
ports-397f3fae0834f2fa7721cee158e50ed873e6beca.zip
Restore those ports to their previous state
No PORTEPOCH needed as they didn't build
Notes
Notes: svn path=/head/; revision=374475
Diffstat (limited to 'graphics/giflib')
-rw-r--r--graphics/giflib/Makefile31
-rw-r--r--graphics/giflib/distinfo4
-rw-r--r--graphics/giflib/files/patch-Makefile.in27
-rw-r--r--graphics/giflib/files/patch-gif_hash.c10
-rw-r--r--graphics/giflib/files/patch-gif_lib.h18
-rw-r--r--graphics/giflib/files/patch-rgb2gif.c20
-rw-r--r--graphics/giflib/files/quantize.c332
-rw-r--r--graphics/giflib/pkg-plist83
8 files changed, 497 insertions, 28 deletions
diff --git a/graphics/giflib/Makefile b/graphics/giflib/Makefile
index 88118ea74a59..2de345e778bf 100644
--- a/graphics/giflib/Makefile
+++ b/graphics/giflib/Makefile
@@ -2,27 +2,34 @@
# $FreeBSD$
PORTNAME= giflib
-PORTVERSION= 5.0.6
+PORTVERSION= 4.2.3
+PORTREVISION= 4
CATEGORIES= graphics
-MASTER_SITES= SF/${PORTNAME}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-4.x
PKGNAMESUFFIX= ${NOX11SUFFIX}${PKGNAMESUFFIX2}
MAINTAINER= portmgr@FreeBSD.org
COMMENT= Tools and library routines for working with GIF images
CONFLICTS= libungif-[0-9]*
+PORTSCOUT= limit:^4\.
-USES= tar:bzip2 libtool
+USES= tar:bzip2 libtool shebangfix
+SHEBANG_FILES= ${WRKSRC}/util/gifburst
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-LMAN1= gif2raw.1 gif2rgb.1 gifbuild.1 gifclrmp.1 gifecho.1 \
- giffix.1 gifinto.1 giflib.1 giftext.1 giftool.1
+LMAN1= gif2rgb.1 gifasm.1 gifbg.1 gifclip.1 gifclrmp.1 gifcolor.1 gifcomb.1 \
+ gifcompose.1 giffiltr.1 giffix.1 gifflip.1 gifhisto.1 gifinter.1 \
+ gifinto.1 gifovly.1 gifpos.1 gifrotat.1 gifrsize.1 gifspnge.1 \
+ giftext.1 gifwedge.1 icon2gif.1 raw2gif.1 rgb2gif.1 text2gif.1
-OPTIONS_DEFINE= DOCBOOK DOCS
+OPTIONS_DEFINE= DOCBOOK X11 DOCS
OPTIONS_SUB= yes
DOCBOOK_DESC= Generate API documentation (requires DOCS)
+X11_CONFIGURE_ENABLE= x11
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCBOOK} && ${PORT_OPTIONS:MDOCS}
@@ -30,7 +37,16 @@ BUILD_DEPENDS+= xmlto:${PORTSDIR}/textproc/xmlto \
${LOCALBASE}/share/xml/docbook/4.1.2:${PORTSDIR}/textproc/docbook-xml
.endif
+.if ${PORT_OPTIONS:MX11}
+USE_XORG= x11 sm ice
+CPPFLAGS+= -I${LOCALBASE}/include
+LMAN1+= gif2x11.1
+.else
+NOX11SUFFIX= -nox11
+.endif
+
post-patch:
+ ${CP} ${FILESDIR}/quantize.c ${WRKSRC}/lib/
.if ! ${PORT_OPTIONS:MDOCBOOK} || ! ${PORT_OPTIONS:MDOCS}
${REINPLACE_CMD} \
-e 's|SUBDIRS = lib util doc pic|SUBDIRS = lib util pic|' \
@@ -38,7 +54,7 @@ post-patch:
.endif
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgif.so.6.0.1
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgif.so.4
.for i in ${LMAN1}
${INSTALL_MAN} ${WRKSRC}/doc/${i} ${STAGEDIR}${PREFIX}/man/man1/
.endfor
@@ -46,7 +62,6 @@ post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/*.html ${STAGEDIR}${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/doc/*.txt ${STAGEDIR}${DOCSDIR}/
-.else
.endif
.include <bsd.port.mk>
diff --git a/graphics/giflib/distinfo b/graphics/giflib/distinfo
index 1fe97cc3ef35..5a9f3ae3dbbb 100644
--- a/graphics/giflib/distinfo
+++ b/graphics/giflib/distinfo
@@ -1,2 +1,2 @@
-SHA256 (giflib-5.0.6.tar.bz2) = 8909839ccbdfca75cfbe6a4db907b55978e11fb268a8f3cde24bd923a0f669ea
-SIZE (giflib-5.0.6.tar.bz2) = 621073
+SHA256 (giflib-4.2.3.tar.bz2) = 0ac8d56726f77c8bc9648c93bbb4d6185d32b15ba7bdb702415990f96f3cb766
+SIZE (giflib-4.2.3.tar.bz2) = 560968
diff --git a/graphics/giflib/files/patch-Makefile.in b/graphics/giflib/files/patch-Makefile.in
new file mode 100644
index 000000000000..4238078c379b
--- /dev/null
+++ b/graphics/giflib/files/patch-Makefile.in
@@ -0,0 +1,27 @@
+--- lib/Makefile.in.orig 2012-05-16 17:59:23.000000000 -0700
++++ lib/Makefile.in 2012-06-03 22:25:28.000000000 -0700
+@@ -77,7 +77,7 @@
+ LTLIBRARIES = $(lib_LTLIBRARIES)
+ libgif_la_DEPENDENCIES =
+ am_libgif_la_OBJECTS = dgif_lib.lo egif_lib.lo gif_font.lo gif_hash.lo \
+- gifalloc.lo gif_err.lo
++ gifalloc.lo gif_err.lo quantize.lo
+ libgif_la_OBJECTS = $(am_libgif_la_OBJECTS)
+ libgif_la_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) \
+ $(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+@@ -234,6 +234,7 @@
+ gif_hash.h \
+ gifalloc.c \
+ gif_err.c \
++ quantize.c \
+ gif_lib_private.h
+
+ libgif_la_LDFLAGS = -version-info @SHLIBVERSION@
+@@ -319,6 +320,7 @@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/gif_font.Plo@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/gif_hash.Plo@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/gifalloc.Plo@am__quote@
++@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/quantize.Plo@am__quote@
+
+ .c.o:
+ @am__fastdepCC_TRUE@ $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
diff --git a/graphics/giflib/files/patch-gif_hash.c b/graphics/giflib/files/patch-gif_hash.c
new file mode 100644
index 000000000000..52b564bff909
--- /dev/null
+++ b/graphics/giflib/files/patch-gif_hash.c
@@ -0,0 +1,10 @@
+--- lib/gif_hash.c.orig 2013-08-29 21:32:18.000000000 +0200
++++ lib/gif_hash.c 2013-09-03 05:53:45.000000000 +0200
+@@ -21,6 +21,7 @@
+ #include <fcntl.h>
+ #include <stdio.h>
+ #include <string.h>
++#include <stdlib.h>
+
+ #include "gif_lib.h"
+ #include "gif_hash.h"
diff --git a/graphics/giflib/files/patch-gif_lib.h b/graphics/giflib/files/patch-gif_lib.h
new file mode 100644
index 000000000000..172e31008233
--- /dev/null
+++ b/graphics/giflib/files/patch-gif_lib.h
@@ -0,0 +1,18 @@
+--- lib/gif_lib.h.orig 2012-05-06 22:55:48.000000000 +0200
++++ lib/gif_lib.h 2012-06-03 12:12:23.000000000 +0200
+@@ -180,6 +180,15 @@
+ #define D_GIF_ERR_IMAGE_DEFECT 112
+ #define D_GIF_ERR_EOF_TOO_SOON 113
+
++/******************************************************************************
++ * O.K., here are the routines from GIF_LIB file QUANTIZE.C.
++******************************************************************************/
++int QuantizeBuffer(unsigned int Width, unsigned int Height,
++ int *ColorMapSize, GifByteType * RedInput,
++ GifByteType * GreenInput, GifByteType * BlueInput,
++ GifByteType * OutputBuffer,
++ GifColorType * OutputColorMap);
++
+ /* These are legacy. You probably do not want to call them directly */
+ int DGifGetScreenDesc(GifFileType * GifFile);
+ int DGifGetRecordType(GifFileType * GifFile, GifRecordType * GifType);
diff --git a/graphics/giflib/files/patch-rgb2gif.c b/graphics/giflib/files/patch-rgb2gif.c
new file mode 100644
index 000000000000..e6c82075ba18
--- /dev/null
+++ b/graphics/giflib/files/patch-rgb2gif.c
@@ -0,0 +1,20 @@
+--- util/rgb2gif.c.orig 2012-05-16 22:31:35.000000000 +0200
++++ util/rgb2gif.c 2012-06-03 12:23:21.000000000 +0200
+@@ -129,7 +129,7 @@
+ * This function returns GIF_OK if succesfull, GIF_ERROR otherwise.
+ ******************************************************************************/
+ static int
+-QuantizeBuffer(unsigned int Width,
++GifQuantizeBuffer(unsigned int Width,
+ unsigned int Height,
+ int *ColorMapSize,
+ GifByteType * RedInput,
+@@ -428,7 +428,7 @@
+ sizeof(GifByteType))) == NULL)
+ GIF_EXIT("Failed to allocate memory required, aborted.");
+
+- if (QuantizeBuffer(Width, Height, &ColorMapSize,
++ if (GifQuantizeBuffer(Width, Height, &ColorMapSize,
+ RedBuffer, GreenBuffer, BlueBuffer,
+ OutputBuffer, OutputColorMap->Colors) == GIF_ERROR)
+ QuitGifError(NULL);
diff --git a/graphics/giflib/files/quantize.c b/graphics/giflib/files/quantize.c
new file mode 100644
index 000000000000..fdcfe36efb93
--- /dev/null
+++ b/graphics/giflib/files/quantize.c
@@ -0,0 +1,332 @@
+/*****************************************************************************
+ * "Gif-Lib" - Yet another gif library.
+ *
+ * Written by: Gershon Elber IBM PC Ver 0.1, Jun. 1989
+ ******************************************************************************
+ * Module to quatize high resolution image into lower one. You may want to
+ * peek into the following article this code is based on:
+ * "Color Image Quantization for frame buffer Display", by Paul Heckbert
+ * SIGGRAPH 1982 page 297-307.
+ ******************************************************************************
+ * History:
+ * 5 Jan 90 - Version 1.0 by Gershon Elber.
+ *****************************************************************************/
+
+#ifdef HAVE_CONFIG_H
+#include <config.h>
+#endif
+
+#ifdef __MSDOS__
+#include <dos.h>
+#include <alloc.h>
+#include <graphics.h>
+#endif /* __MSDOS__ */
+
+#include <stdlib.h>
+#include <stdio.h>
+#include "gif_lib.h"
+#include "gif_lib_private.h"
+
+#define ABS(x) ((x) > 0 ? (x) : (-(x)))
+
+#define PROGRAM_NAME "giflib"
+
+/* The colors are stripped to 5 bits per primary color if non MSDOS system
+ * or to 4 (not enough memory...) if MSDOS as first step.
+ */
+#ifdef __MSDOS__
+#define COLOR_ARRAY_SIZE 4096
+#define BITS_PER_PRIM_COLOR 4
+#define MAX_PRIM_COLOR 0x0f
+#else
+#define COLOR_ARRAY_SIZE 32768
+#define BITS_PER_PRIM_COLOR 5
+#define MAX_PRIM_COLOR 0x1f
+#endif /* __MSDOS__ */
+
+static int SortRGBAxis;
+
+typedef struct QuantizedColorType {
+ GifByteType RGB[3];
+ GifByteType NewColorIndex;
+ long Count;
+ struct QuantizedColorType *Pnext;
+} QuantizedColorType;
+
+typedef struct NewColorMapType {
+ GifByteType RGBMin[3], RGBWidth[3];
+ unsigned int NumEntries; /* # of QuantizedColorType in linked list below */
+ unsigned long Count; /* Total number of pixels in all the entries */
+ QuantizedColorType *QuantizedColors;
+} NewColorMapType;
+
+static int SubdivColorMap(NewColorMapType * NewColorSubdiv,
+ unsigned int ColorMapSize,
+ unsigned int *NewColorMapSize);
+static int SortCmpRtn(const VoidPtr Entry1, const VoidPtr Entry2);
+
+/******************************************************************************
+ * Quantize high resolution image into lower one. Input image consists of a
+ * 2D array for each of the RGB colors with size Width by Height. There is no
+ * Color map for the input. Output is a quantized image with 2D array of
+ * indexes into the output color map.
+ * Note input image can be 24 bits at the most (8 for red/green/blue) and
+ * the output has 256 colors at the most (256 entries in the color map.).
+ * ColorMapSize specifies size of color map up to 256 and will be updated to
+ * real size before returning.
+ * Also non of the parameter are allocated by this routine.
+ * This function returns GIF_OK if succesfull, GIF_ERROR otherwise.
+ ******************************************************************************/
+int
+QuantizeBuffer(unsigned int Width,
+ unsigned int Height,
+ int *ColorMapSize,
+ GifByteType * RedInput,
+ GifByteType * GreenInput,
+ GifByteType * BlueInput,
+ GifByteType * OutputBuffer,
+ GifColorType * OutputColorMap) {
+
+ unsigned int Index, NumOfEntries;
+ int i, j, MaxRGBError[3];
+ unsigned int NewColorMapSize;
+ long Red, Green, Blue;
+ NewColorMapType NewColorSubdiv[256];
+ QuantizedColorType *ColorArrayEntries, *QuantizedColor;
+
+ ColorArrayEntries = (QuantizedColorType *)malloc(
+ sizeof(QuantizedColorType) * COLOR_ARRAY_SIZE);
+ if (ColorArrayEntries == NULL) {
+ _GifError = E_GIF_ERR_NOT_ENOUGH_MEM;
+ return GIF_ERROR;
+ }
+
+ for (i = 0; i < COLOR_ARRAY_SIZE; i++) {
+ ColorArrayEntries[i].RGB[0] = i >> (2 * BITS_PER_PRIM_COLOR);
+ ColorArrayEntries[i].RGB[1] = (i >> BITS_PER_PRIM_COLOR) &
+ MAX_PRIM_COLOR;
+ ColorArrayEntries[i].RGB[2] = i & MAX_PRIM_COLOR;
+ ColorArrayEntries[i].Count = 0;
+ }
+
+ /* Sample the colors and their distribution: */
+ for (i = 0; i < (int)(Width * Height); i++) {
+ Index = ((RedInput[i] >> (8 - BITS_PER_PRIM_COLOR)) <<
+ (2 * BITS_PER_PRIM_COLOR)) +
+ ((GreenInput[i] >> (8 - BITS_PER_PRIM_COLOR)) <<
+ BITS_PER_PRIM_COLOR) +
+ (BlueInput[i] >> (8 - BITS_PER_PRIM_COLOR));
+ ColorArrayEntries[Index].Count++;
+ }
+
+ /* Put all the colors in the first entry of the color map, and call the
+ * recursive subdivision process. */
+ for (i = 0; i < 256; i++) {
+ NewColorSubdiv[i].QuantizedColors = NULL;
+ NewColorSubdiv[i].Count = NewColorSubdiv[i].NumEntries = 0;
+ for (j = 0; j < 3; j++) {
+ NewColorSubdiv[i].RGBMin[j] = 0;
+ NewColorSubdiv[i].RGBWidth[j] = 255;
+ }
+ }
+
+ /* Find the non empty entries in the color table and chain them: */
+ for (i = 0; i < COLOR_ARRAY_SIZE; i++)
+ if (ColorArrayEntries[i].Count > 0)
+ break;
+ QuantizedColor = NewColorSubdiv[0].QuantizedColors = &ColorArrayEntries[i];
+ NumOfEntries = 1;
+ while (++i < COLOR_ARRAY_SIZE)
+ if (ColorArrayEntries[i].Count > 0) {
+ QuantizedColor->Pnext = &ColorArrayEntries[i];
+ QuantizedColor = &ColorArrayEntries[i];
+ NumOfEntries++;
+ }
+ QuantizedColor->Pnext = NULL;
+
+ NewColorSubdiv[0].NumEntries = NumOfEntries; /* Different sampled colors */
+ NewColorSubdiv[0].Count = ((long)Width) * Height; /* Pixels */
+ NewColorMapSize = 1;
+ if (SubdivColorMap(NewColorSubdiv, *ColorMapSize, &NewColorMapSize) !=
+ GIF_OK) {
+ free((char *)ColorArrayEntries);
+ return GIF_ERROR;
+ }
+ if (NewColorMapSize < *ColorMapSize) {
+ /* And clear rest of color map: */
+ for (i = NewColorMapSize; i < *ColorMapSize; i++)
+ OutputColorMap[i].Red = OutputColorMap[i].Green =
+ OutputColorMap[i].Blue = 0;
+ }
+
+ /* Average the colors in each entry to be the color to be used in the
+ * output color map, and plug it into the output color map itself. */
+ for (i = 0; i < NewColorMapSize; i++) {
+ if ((j = NewColorSubdiv[i].NumEntries) > 0) {
+ QuantizedColor = NewColorSubdiv[i].QuantizedColors;
+ Red = Green = Blue = 0;
+ while (QuantizedColor) {
+ QuantizedColor->NewColorIndex = i;
+ Red += QuantizedColor->RGB[0];
+ Green += QuantizedColor->RGB[1];
+ Blue += QuantizedColor->RGB[2];
+ QuantizedColor = QuantizedColor->Pnext;
+ }
+ OutputColorMap[i].Red = (Red << (8 - BITS_PER_PRIM_COLOR)) / j;
+ OutputColorMap[i].Green = (Green << (8 - BITS_PER_PRIM_COLOR)) / j;
+ OutputColorMap[i].Blue = (Blue << (8 - BITS_PER_PRIM_COLOR)) / j;
+ } else
+ fprintf(stderr,
+ "\n%s: Null entry in quantized color map - that's weird.\n",
+ PROGRAM_NAME);
+ }
+
+ /* Finally scan the input buffer again and put the mapped index in the
+ * output buffer. */
+ MaxRGBError[0] = MaxRGBError[1] = MaxRGBError[2] = 0;
+ for (i = 0; i < (int)(Width * Height); i++) {
+ Index = ((RedInput[i] >> (8 - BITS_PER_PRIM_COLOR)) <<
+ (2 * BITS_PER_PRIM_COLOR)) +
+ ((GreenInput[i] >> (8 - BITS_PER_PRIM_COLOR)) <<
+ BITS_PER_PRIM_COLOR) +
+ (BlueInput[i] >> (8 - BITS_PER_PRIM_COLOR));
+ Index = ColorArrayEntries[Index].NewColorIndex;
+ OutputBuffer[i] = Index;
+ if (MaxRGBError[0] < ABS(OutputColorMap[Index].Red - RedInput[i]))
+ MaxRGBError[0] = ABS(OutputColorMap[Index].Red - RedInput[i]);
+ if (MaxRGBError[1] < ABS(OutputColorMap[Index].Green - GreenInput[i]))
+ MaxRGBError[1] = ABS(OutputColorMap[Index].Green - GreenInput[i]);
+ if (MaxRGBError[2] < ABS(OutputColorMap[Index].Blue - BlueInput[i]))
+ MaxRGBError[2] = ABS(OutputColorMap[Index].Blue - BlueInput[i]);
+ }
+
+#ifdef DEBUG
+ fprintf(stderr,
+ "Quantization L(0) errors: Red = %d, Green = %d, Blue = %d.\n",
+ MaxRGBError[0], MaxRGBError[1], MaxRGBError[2]);
+#endif /* DEBUG */
+
+ free((char *)ColorArrayEntries);
+
+ *ColorMapSize = NewColorMapSize;
+
+ return GIF_OK;
+}
+
+/******************************************************************************
+ * Routine to subdivide the RGB space recursively using median cut in each
+ * axes alternatingly until ColorMapSize different cubes exists.
+ * The biggest cube in one dimension is subdivide unless it has only one entry.
+ * Returns GIF_ERROR if failed, otherwise GIF_OK.
+ ******************************************************************************/
+static int
+SubdivColorMap(NewColorMapType * NewColorSubdiv,
+ unsigned int ColorMapSize,
+ unsigned int *NewColorMapSize) {
+
+ int MaxSize;
+ unsigned int i, j, Index = 0, NumEntries, MinColor, MaxColor;
+ long Sum, Count;
+ QuantizedColorType *QuantizedColor, **SortArray;
+
+ while (ColorMapSize > *NewColorMapSize) {
+ /* Find candidate for subdivision: */
+ MaxSize = -1;
+ for (i = 0; i < *NewColorMapSize; i++) {
+ for (j = 0; j < 3; j++) {
+ if ((((int)NewColorSubdiv[i].RGBWidth[j]) > MaxSize) &&
+ (NewColorSubdiv[i].NumEntries > 1)) {
+ MaxSize = NewColorSubdiv[i].RGBWidth[j];
+ Index = i;
+ SortRGBAxis = j;
+ }
+ }
+ }
+
+ if (MaxSize == -1)
+ return GIF_OK;
+
+ /* Split the entry Index into two along the axis SortRGBAxis: */
+
+ /* Sort all elements in that entry along the given axis and split at
+ * the median. */
+ SortArray = (QuantizedColorType **)malloc(
+ sizeof(QuantizedColorType *) *
+ NewColorSubdiv[Index].NumEntries);
+ if (SortArray == NULL)
+ return GIF_ERROR;
+ for (j = 0, QuantizedColor = NewColorSubdiv[Index].QuantizedColors;
+ j < NewColorSubdiv[Index].NumEntries && QuantizedColor != NULL;
+ j++, QuantizedColor = QuantizedColor->Pnext)
+ SortArray[j] = QuantizedColor;
+
+ qsort(SortArray, NewColorSubdiv[Index].NumEntries,
+ sizeof(QuantizedColorType *), SortCmpRtn);
+
+ /* Relink the sorted list into one: */
+ for (j = 0; j < NewColorSubdiv[Index].NumEntries - 1; j++)
+ SortArray[j]->Pnext = SortArray[j + 1];
+ SortArray[NewColorSubdiv[Index].NumEntries - 1]->Pnext = NULL;
+ NewColorSubdiv[Index].QuantizedColors = QuantizedColor = SortArray[0];
+ free((char *)SortArray);
+
+ /* Now simply add the Counts until we have half of the Count: */
+ Sum = NewColorSubdiv[Index].Count / 2 - QuantizedColor->Count;
+ NumEntries = 1;
+ Count = QuantizedColor->Count;
+ while ((Sum -= QuantizedColor->Pnext->Count) >= 0 &&
+ QuantizedColor->Pnext != NULL &&
+ QuantizedColor->Pnext->Pnext != NULL) {
+ QuantizedColor = QuantizedColor->Pnext;
+ NumEntries++;
+ Count += QuantizedColor->Count;
+ }
+ /* Save the values of the last color of the first half, and first
+ * of the second half so we can update the Bounding Boxes later.
+ * Also as the colors are quantized and the BBoxes are full 0..255,
+ * they need to be rescaled.
+ */
+ MaxColor = QuantizedColor->RGB[SortRGBAxis]; /* Max. of first half */
+ MinColor = QuantizedColor->Pnext->RGB[SortRGBAxis]; /* of second */
+ MaxColor <<= (8 - BITS_PER_PRIM_COLOR);
+ MinColor <<= (8 - BITS_PER_PRIM_COLOR);
+
+ /* Partition right here: */
+ NewColorSubdiv[*NewColorMapSize].QuantizedColors =
+ QuantizedColor->Pnext;
+ QuantizedColor->Pnext = NULL;
+ NewColorSubdiv[*NewColorMapSize].Count = Count;
+ NewColorSubdiv[Index].Count -= Count;
+ NewColorSubdiv[*NewColorMapSize].NumEntries =
+ NewColorSubdiv[Index].NumEntries - NumEntries;
+ NewColorSubdiv[Index].NumEntries = NumEntries;
+ for (j = 0; j < 3; j++) {
+ NewColorSubdiv[*NewColorMapSize].RGBMin[j] =
+ NewColorSubdiv[Index].RGBMin[j];
+ NewColorSubdiv[*NewColorMapSize].RGBWidth[j] =
+ NewColorSubdiv[Index].RGBWidth[j];
+ }
+ NewColorSubdiv[*NewColorMapSize].RGBWidth[SortRGBAxis] =
+ NewColorSubdiv[*NewColorMapSize].RGBMin[SortRGBAxis] +
+ NewColorSubdiv[*NewColorMapSize].RGBWidth[SortRGBAxis] - MinColor;
+ NewColorSubdiv[*NewColorMapSize].RGBMin[SortRGBAxis] = MinColor;
+
+ NewColorSubdiv[Index].RGBWidth[SortRGBAxis] =
+ MaxColor - NewColorSubdiv[Index].RGBMin[SortRGBAxis];
+
+ (*NewColorMapSize)++;
+ }
+
+ return GIF_OK;
+}
+
+/****************************************************************************
+ * Routine called by qsort to compare to entries.
+ ****************************************************************************/
+static int
+SortCmpRtn(const VoidPtr Entry1,
+ const VoidPtr Entry2) {
+
+ return (*((QuantizedColorType **) Entry1))->RGB[SortRGBAxis] -
+ (*((QuantizedColorType **) Entry2))->RGB[SortRGBAxis];
+}
diff --git a/graphics/giflib/pkg-plist b/graphics/giflib/pkg-plist
index fb2d8dbdd722..1fe90a202c55 100644
--- a/graphics/giflib/pkg-plist
+++ b/graphics/giflib/pkg-plist
@@ -1,43 +1,90 @@
-bin/gif2raw
bin/gif2rgb
-bin/gifbuild
+%%X11%%bin/gif2x11
+bin/gifasm
+bin/gifbg
+bin/gifburst
+bin/gifclip
bin/gifclrmp
-bin/gifecho
+bin/gifcolor
+bin/gifcomb
+bin/gifcompose
+bin/giffiltr
bin/giffix
+bin/gifflip
+bin/gifhisto
+bin/gifinfo
+bin/gifinter
bin/gifinto
+bin/gifovly
+bin/gifpos
+bin/gifrotat
+bin/gifrsize
+bin/gifspnge
bin/giftext
-bin/giftool
+bin/gifwedge
+bin/icon2gif
+bin/raw2gif
+bin/rgb2gif
+bin/text2gif
include/gif_lib.h
lib/libgif.a
lib/libgif.so
-lib/libgif.so.6
-lib/libgif.so.6.0.1
-man/man1/gif2raw.1.gz
+lib/libgif.so.4
+lib/libgif.so.4.1.7
man/man1/gif2rgb.1.gz
-man/man1/gifbuild.1.gz
+%%X11%%man/man1/gif2x11.1.gz
+man/man1/gifasm.1.gz
+man/man1/gifbg.1.gz
+man/man1/gifclip.1.gz
man/man1/gifclrmp.1.gz
-man/man1/gifecho.1.gz
+man/man1/gifcolor.1.gz
+man/man1/gifcomb.1.gz
+man/man1/gifcompose.1.gz
+man/man1/giffiltr.1.gz
man/man1/giffix.1.gz
+man/man1/gifflip.1.gz
+man/man1/gifhisto.1.gz
+man/man1/gifinter.1.gz
man/man1/gifinto.1.gz
-man/man1/giflib.1.gz
+man/man1/gifovly.1.gz
+man/man1/gifpos.1.gz
+man/man1/gifrotat.1.gz
+man/man1/gifrsize.1.gz
+man/man1/gifspnge.1.gz
man/man1/giftext.1.gz
-man/man1/giftool.1.gz
-%%DOCBOOK%%%%DOCSDIR%%/gif2raw.html
+man/man1/gifwedge.1.gz
+man/man1/icon2gif.1.gz
+man/man1/raw2gif.1.gz
+man/man1/rgb2gif.1.gz
+man/man1/text2gif.1.gz
%%DOCBOOK%%%%DOCSDIR%%/gif2rgb.html
-%%DOCBOOK%%%%DOCSDIR%%/gif87.txt
+%%DOCBOOK%%%%DOCSDIR%%/gif2x11.html
%%DOCBOOK%%%%DOCSDIR%%/gif89.txt
-%%DOCBOOK%%%%DOCSDIR%%/gifbg.html
%%DOCBOOK%%%%DOCSDIR%%/gif_lib.html
-%%DOCBOOK%%%%DOCSDIR%%/gifbuild.html
+%%DOCBOOK%%%%DOCSDIR%%/gifasm.html
+%%DOCBOOK%%%%DOCSDIR%%/gifbg.html
+%%DOCBOOK%%%%DOCSDIR%%/gifclip.html
%%DOCBOOK%%%%DOCSDIR%%/gifclrmp.html
%%DOCBOOK%%%%DOCSDIR%%/gifcolor.html
-%%DOCBOOK%%%%DOCSDIR%%/gifecho.html
+%%DOCBOOK%%%%DOCSDIR%%/gifcomb.html
+%%DOCBOOK%%%%DOCSDIR%%/gifcompose.html
+%%DOCBOOK%%%%DOCSDIR%%/giffiltr.html
%%DOCBOOK%%%%DOCSDIR%%/giffix.html
+%%DOCBOOK%%%%DOCSDIR%%/gifflip.html
%%DOCBOOK%%%%DOCSDIR%%/gifhisto.html
+%%DOCBOOK%%%%DOCSDIR%%/gifinter.html
%%DOCBOOK%%%%DOCSDIR%%/gifinto.html
-%%DOCBOOK%%%%DOCSDIR%%/giflib.html
+%%DOCBOOK%%%%DOCSDIR%%/gifovly.html
+%%DOCBOOK%%%%DOCSDIR%%/gifpos.html
+%%DOCBOOK%%%%DOCSDIR%%/gifrotat.html
+%%DOCBOOK%%%%DOCSDIR%%/gifrsize.html
+%%DOCBOOK%%%%DOCSDIR%%/gifspnge.html
%%DOCBOOK%%%%DOCSDIR%%/giftext.html
-%%DOCBOOK%%%%DOCSDIR%%/giftool.html
%%DOCBOOK%%%%DOCSDIR%%/gifwedge.html
+%%DOCBOOK%%%%DOCSDIR%%/icon2gif.html
%%DOCBOOK%%%%DOCSDIR%%/intro.html
+%%DOCBOOK%%%%DOCSDIR%%/liberror.html
%%DOCBOOK%%%%DOCSDIR%%/lzgif.txt
+%%DOCBOOK%%%%DOCSDIR%%/raw2gif.html
+%%DOCBOOK%%%%DOCSDIR%%/rgb2gif.html
+%%DOCBOOK%%%%DOCSDIR%%/text2gif.html