aboutsummaryrefslogtreecommitdiff
path: root/graphics/giftool
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-03-02 12:44:30 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-03-02 12:44:30 +0000
commit6c2d21d1d4fc44d853e544d1d952efb43413118e (patch)
tree30ec0761a39b32ccc2728bed5108e75ed7e3ff6b /graphics/giftool
parent144bcef92be0eef15e6404ad9b093b06e9c4158f (diff)
downloadports-6c2d21d1d4fc44d853e544d1d952efb43413118e.tar.gz
ports-6c2d21d1d4fc44d853e544d1d952efb43413118e.zip
Notes
Diffstat (limited to 'graphics/giftool')
-rw-r--r--graphics/giftool/Makefile33
-rw-r--r--graphics/giftool/distinfo4
-rw-r--r--graphics/giftool/files/patch-aa8
-rw-r--r--graphics/giftool/pkg-descr9
-rw-r--r--graphics/giftool/pkg-message (renamed from graphics/giftool/files/post-install-notes)0
-rw-r--r--graphics/giftool/pkg-plist5
6 files changed, 24 insertions, 35 deletions
diff --git a/graphics/giftool/Makefile b/graphics/giftool/Makefile
index ba153a56c93d..e697fc5e174d 100644
--- a/graphics/giftool/Makefile
+++ b/graphics/giftool/Makefile
@@ -8,7 +8,9 @@
PORTNAME= giftool
PORTVERSION= 1.0
CATEGORIES= graphics
-MASTER_SITES= ftp://ftp.sbs.de/pub/www/tools/giftool/
+MASTER_SITES= http://www.the-labs.com/GIFTool/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= A tool for GIF89a transparent option and interlace mode
@@ -17,29 +19,28 @@ NO_CDROM= "Shareware"
NO_WRKSUBDIR= yes
ALL_TARGET= giftool
+MAKE_ARGS= CFLAGS="${CFLAGS}"
-.if defined(RETVALUE)
-pre-patch::
- @${ECHO_MSG} "Return value patch enabled....."
+OPTIONS= RETVALUE "Return value patch" on \
+ MALLOCSIZE "Improve malloc size" on
+
+PORTDOCS= COPYRIGHT README
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_RETVALUE)
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-aa
.endif
-.if defined(MALLOCSIZE)
-pre-patch::
- @${ECHO_MSG} "Malloc size improve parch enabled....."
+.if defined(WITH_MALLOCSIZE)
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ab
.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/giftool ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/share/doc/giftool
-.for file in COPYRIGHT README
- ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/giftool
-.endfor
- ${INSTALL_DATA} ${FILESDIR}/post-install-notes ${PREFIX}/share/doc/giftool
+ ${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
post-install:
-.if !defined(BATCH)
- @ /usr/bin/more -e ${FILESDIR}/post-install-notes
-.endif
+ @${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/giftool/distinfo b/graphics/giftool/distinfo
index 524133b6babf..a9af2784c871 100644
--- a/graphics/giftool/distinfo
+++ b/graphics/giftool/distinfo
@@ -1,2 +1,2 @@
-MD5 (giftool-1.0.tar.gz) = 3d90069d230b5d42a5e1803cfcb9d6ed
-SIZE (giftool-1.0.tar.gz) = 21508
+MD5 (giftool.tar.Z) = d8f1a8a2055467f90c88906628c1cc79
+SIZE (giftool.tar.Z) = 33697
diff --git a/graphics/giftool/files/patch-aa b/graphics/giftool/files/patch-aa
deleted file mode 100644
index 54fb7e481ccf..000000000000
--- a/graphics/giftool/files/patch-aa
+++ /dev/null
@@ -1,8 +0,0 @@
---- Makefile.orig Fri Dec 9 11:16:58 1994
-+++ Makefile Sun Oct 19 02:23:29 2003
-@@ -1,4 +1,4 @@
--CFLAGS = -O2
-+CFLAGS ?= -O -pipe
-
- LIBS = # -lsent
-
diff --git a/graphics/giftool/pkg-descr b/graphics/giftool/pkg-descr
index 41d225d54a48..dd67bf885b16 100644
--- a/graphics/giftool/pkg-descr
+++ b/graphics/giftool/pkg-descr
@@ -3,13 +3,14 @@ instance 'giftool -B -i *.gif' converts all images to interlaced GIF files.
GIFTool is shareware. Use the -info option to read the licensing information.
-Two options are recommended. You can specify them after "make clean".
-make RETVALUE=yes
+Two options are recommended:
+WITH_RETVALUE=yes
This option, suggested by Sergei Chechetkin
<csl@whale.sunbay.crimea.ua>, causes GIFTool to provide a return value
so may be used in pipes or with programs like make(1).
-make MALLOCSIZE=yes
+WITH_MALLOCSIZE=yes
This option, suggested by Hidetoshi Shimokawa
<simokawa@sat.t.u-tokyo.ac.jp>, increases the size of a malloc, to avoid
a segmentation fault when pre-reading some images.
-You can specify both options such as 'make RETVALUE=yes MALLOCSIZE=yes'.
+
+WWW: http://www.the-labs.com/GIFTool/
diff --git a/graphics/giftool/files/post-install-notes b/graphics/giftool/pkg-message
index b87eb7c7d2dc..b87eb7c7d2dc 100644
--- a/graphics/giftool/files/post-install-notes
+++ b/graphics/giftool/pkg-message
diff --git a/graphics/giftool/pkg-plist b/graphics/giftool/pkg-plist
deleted file mode 100644
index 7bf0af233128..000000000000
--- a/graphics/giftool/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/giftool
-share/doc/giftool/COPYRIGHT
-share/doc/giftool/README
-share/doc/giftool/post-install-notes
-@dirrm share/doc/giftool