aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimageview
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-24 15:43:51 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-24 15:43:51 +0000
commit6ad95e6c36da6d7ddaa01631165e45b9434ea295 (patch)
tree3bea780607f4496c2ecba977a503ca24f4f32161 /graphics/gimageview
parent7ba689cef0044893d978bde14a66099c08e286b0 (diff)
downloadports-6ad95e6c36da6d7ddaa01631165e45b9434ea295.tar.gz
ports-6ad95e6c36da6d7ddaa01631165e45b9434ea295.zip
- use OPTIONS_DEFINE
Notes
Notes: svn path=/head/; revision=299887
Diffstat (limited to 'graphics/gimageview')
-rw-r--r--graphics/gimageview/Makefile34
1 files changed, 15 insertions, 19 deletions
diff --git a/graphics/gimageview/Makefile b/graphics/gimageview/Makefile
index 70aee8d00d0d..b52d90b81243 100644
--- a/graphics/gimageview/Makefile
+++ b/graphics/gimageview/Makefile
@@ -24,15 +24,11 @@ CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
MAKE_ARGS= CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
-OPTIONS= SPLASH "Show splash on startup" on \
- NLS "Build with gettext support" on \
- LIBMNG "Build with libmng support" on \
- LIBWMF "Build with libwmf support" on \
- LIBRSVG2 "Build with librsvg-2 support" on \
- LIBEXIF "Build with libexif support" on \
- MPLAYER "Build with Mplayer support" on \
- LIBXINE "Build with Xine support" off \
- IMLIB "Build with imlib instead of gdk-pixbuf" off
+OPTIONS_DEFINE= SPLASH NLS LIBMNG LIBWMF LIBRSVG2 LIBEXIF MPLAYER LIBXINE IMLIB
+OPTIONS_DEFAULT=SPLASH NLS LIBMNG LIBWMF LIBRSVG2 LIBEXIF MPLAYER
+NO_OPTIONS_SORT=yes
+SPLASH_DESC= Show splash screen on startup
+IMLIB_DESC= Enable imlib, disable gdk-pixbuf
USE_GNOME= gtk20
USE_XORG= xinerama ice
@@ -41,11 +37,11 @@ CFLAGS+= -DUSE_GTK2
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_SPLASH)
+.if empty(PORT_OPTIONS:MSPLASH)
CONFIGURE_ARGS+= --disable-splash
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
@@ -53,12 +49,12 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if defined(WITH_IMLIB)
+.if ${PORT_OPTIONS:MIMLIB}
USE_GNOME+= imlib
CONFIGURE_ARGS+= --disable-gdk-pixbuf
.endif
-.if !defined(WITHOUT_LIBMNG)
+.if ${PORT_OPTIONS:MLIBMNG}
LIB_DEPENDS+= mng.1:${PORTSDIR}/graphics/libmng
PLIST_SUB+= WITH_LIBMNG=""
.else
@@ -66,7 +62,7 @@ CONFIGURE_ARGS+= --without-libmng
PLIST_SUB+= WITH_LIBMNG="@comment "
.endif
-.if !defined(WITHOUT_LIBWMF)
+.if ${PORT_OPTIONS:MLIBWMF}
LIB_DEPENDS+= wmf.2:${PORTSDIR}/graphics/libwmf
PLIST_SUB+= WITH_LIBWMF=""
.else
@@ -74,7 +70,7 @@ CONFIGURE_ARGS+= --without-libwmf
PLIST_SUB+= WITH_LIBWMF="@comment "
.endif
-.if !defined(WITHOUT_LIBRSVG2)
+.if ${PORT_OPTIONS:MLIBRSVG2}
LIB_DEPENDS+= rsvg-2.2:${PORTSDIR}/graphics/librsvg2
PLIST_SUB+= WITH_LIBRSVG=""
.else
@@ -82,14 +78,14 @@ CONFIGURE_ARGS+= --without-librsvg
PLIST_SUB+= WITH_LIBRSVG="@comment "
.endif
-.if !defined(WITHOUT_LIBEXIF)
+.if ${PORT_OPTIONS:MLIBEXIF}
LIB_DEPENDS+= exif.12:${PORTSDIR}/graphics/libexif
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src-exit_view.c
.else
CONFIGURE_ARGS+= --disable-exif
.endif
-.if !defined(WITHOUT_MPLAYER)
+.if ${PORT_OPTIONS:MMPLAYER}
RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
CONFIGURE_ARGS+= --enable-mplayer
PLIST_SUB+= WITH_LIBMPLAYER=""
@@ -98,7 +94,7 @@ CONFIGURE_ARGS+= --disable-mplayer
PLIST_SUB+= WITH_LIBMPLAYER="@comment "
.endif
-.if defined(WITH_LIBXINE)
+.if ${PORT_OPTIONS:MLIBXINE}
LIB_DEPENDS+= xine.2:${PORTSDIR}/multimedia/libxine
CONFIGURE_ARGS+= --with-xine
PLIST_SUB+= WITH_LIBXINE=""
@@ -116,7 +112,7 @@ post-patch:
${WRKSRC}/etc/Makefile.in
post-configure:
-.if !defined(WITH_IMLIB)
+.if ${PORT_OPTIONS:MIMLIB}
@${FIND} ${WRKSRC} -name 'Makefile' | ${XARGS} ${REINPLACE_CMD} -Ee \
's/^(GDK_IMLIB_(CFLAGS|LIBS) =).*$$/$${1}/'
.endif