aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimp-app
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2020-12-25 13:30:40 +0000
committerThomas Zander <riggs@FreeBSD.org>2020-12-25 13:30:40 +0000
commitf159c33a342752e6d2075ff2ef33326c29a8b0f2 (patch)
treea6608f7d82818839fb66a86b90d43d4c1267518f /graphics/gimp-app
parente126046a6038b6358ecfd12302717659e0ee3565 (diff)
downloadports-f159c33a342752e6d2075ff2ef33326c29a8b0f2.tar.gz
ports-f159c33a342752e6d2075ff2ef33326c29a8b0f2.zip
Fix gimp startup due to missing gegl action 'gegl:introspect'.
Details: - The fix applied to the OpenBSD source tree (https://github.com/openbsd/ports/commit/b3b872c09b35d84889a2d5e1945bf3a31642296f) resolves the problem on FreeBSD as well. Approved by: fluffy
Notes
Notes: svn path=/head/; revision=559241
Diffstat (limited to 'graphics/gimp-app')
-rw-r--r--graphics/gimp-app/Makefile2
-rw-r--r--graphics/gimp-app/files/patch-app_actions_debug-actions.c13
-rw-r--r--graphics/gimp-app/files/patch-app_sanity.c10
3 files changed, 24 insertions, 1 deletions
diff --git a/graphics/gimp-app/Makefile b/graphics/gimp-app/Makefile
index 2ab58b49f5bd..1188ded00623 100644
--- a/graphics/gimp-app/Makefile
+++ b/graphics/gimp-app/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= gimp-app
PORTVERSION= 2.10.20
-PORTREVISION= 12
+PORTREVISION= 13
PORTEPOCH?= 1
CATEGORIES?= graphics gnome
MASTER_SITES= GIMP/gimp/v${PORTVERSION:R}
diff --git a/graphics/gimp-app/files/patch-app_actions_debug-actions.c b/graphics/gimp-app/files/patch-app_actions_debug-actions.c
new file mode 100644
index 000000000000..9444616e1557
--- /dev/null
+++ b/graphics/gimp-app/files/patch-app_actions_debug-actions.c
@@ -0,0 +1,13 @@
+--- app/actions/debug-actions.c.orig 2019-10-26 18:49:18 UTC
++++ app/actions/debug-actions.c
+@@ -98,4 +98,10 @@ void
+ debug_actions_update (GimpActionGroup *group,
+ gpointer data)
+ {
++#define SET_SENSITIVE(action,condition) \
++ gimp_action_group_set_action_sensitive (group, action, (condition) != 0)
++
++ SET_SENSITIVE ("debug-show-image-graph", gegl_has_operation ("gegl:introspect"));
++
++#undef SET_SENSITIVE
+ }
diff --git a/graphics/gimp-app/files/patch-app_sanity.c b/graphics/gimp-app/files/patch-app_sanity.c
new file mode 100644
index 000000000000..ae1f0127a8f3
--- /dev/null
+++ b/graphics/gimp-app/files/patch-app_sanity.c
@@ -0,0 +1,10 @@
+--- app/sanity.c.orig 2020-06-07 20:03:47 UTC
++++ app/sanity.c
+@@ -650,7 +650,6 @@ sanity_check_gegl_ops (void)
+ "gegl:hue-chroma",
+ "gegl:illusion",
+ "gegl:image-gradient",
+- "gegl:introspect",
+ "gegl:invert-gamma",
+ "gegl:invert-linear",
+ "gegl:lens-blur",