aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimp-lensfun-plugin
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2014-03-23 23:10:58 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2014-03-23 23:10:58 +0000
commit6f40a8d7bf430a889264d5c242a5f44a6901606e (patch)
treede09d320e8ac987e115eee318be345b51504a651 /graphics/gimp-lensfun-plugin
parentaf2bdc0dda441217762aa41e25344ccb553132aa (diff)
downloadports-6f40a8d7bf430a889264d5c242a5f44a6901606e.tar.gz
ports-6f40a8d7bf430a889264d5c242a5f44a6901606e.zip
New port Lensfun GIMP plugin: correct lens distortion using the lensfun library
Approved by: bdrewery (mentor)
Notes
Notes: svn path=/head/; revision=348900
Diffstat (limited to 'graphics/gimp-lensfun-plugin')
-rw-r--r--graphics/gimp-lensfun-plugin/Makefile54
-rw-r--r--graphics/gimp-lensfun-plugin/distinfo2
-rw-r--r--graphics/gimp-lensfun-plugin/files/patch-Makefile20
-rw-r--r--graphics/gimp-lensfun-plugin/pkg-descr11
4 files changed, 87 insertions, 0 deletions
diff --git a/graphics/gimp-lensfun-plugin/Makefile b/graphics/gimp-lensfun-plugin/Makefile
new file mode 100644
index 000000000000..131fd3e92b13
--- /dev/null
+++ b/graphics/gimp-lensfun-plugin/Makefile
@@ -0,0 +1,54 @@
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= lensfun
+DISTVERSION= 0.2.4-dev
+CATEGORIES= graphics
+PKGNAMEPREFIX= gimp-
+PKGNAMESUFFIX= -plugin
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Gimp plugin to correct lens distortion using the lensfun library
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/exiv2.pc:${PORTSDIR}/graphics/exiv2 \
+ ${LOCALBASE}/libdata/pkgconfig/gimp-2.0.pc:${PORTSDIR}/graphics/gimp-app \
+ ${LOCALBASE}/libdata/pkgconfig/lensfun.pc:${PORTSDIR}/graphics/lensfun
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/exiv2.pc:${PORTSDIR}/graphics/exiv2 \
+ ${LOCALBASE}/libdata/pkgconfig/gimp-2.0.pc:${PORTSDIR}/graphics/gimp-app \
+ ${LOCALBASE}/libdata/pkgconfig/lensfun.pc:${PORTSDIR}/graphics/lensfun
+
+USE_GITHUB= yes
+GH_ACCOUNT= seebk
+GH_PROJECT= GIMP-Lensfun
+GH_COMMIT= d0a0bd2
+GH_TAGNAME= ${GH_COMMIT}
+
+USES= gmake pkgconfig
+
+PLUGIN_DIR?= libexec/gimp/2.2/plug-ins/
+PLUGINS= gimp-lensfun
+
+# installed files
+.for plugin in ${PLUGINS}
+PLIST_FILES+= ${PLUGIN_DIR}/${plugin}
+.endfor
+
+# installed dirs
+PLIST_DIRSTRY= libexec/gimp/2.2/plug-ins \
+ libexec/gimp/2.2 \
+ libexec/gimp
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|gimptool-2.0|${LOCALBASE}/bin/gimptool-2.0|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${PLUGIN_DIR}
+.for plugin in ${PLUGINS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${plugin} ${STAGEDIR}${PREFIX}/${PLUGIN_DIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/graphics/gimp-lensfun-plugin/distinfo b/graphics/gimp-lensfun-plugin/distinfo
new file mode 100644
index 000000000000..dcf2e44860ba
--- /dev/null
+++ b/graphics/gimp-lensfun-plugin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (lensfun-0.2.4-dev.tar.gz) = e87d63c70ed199b82e0996a281a775a70e0d1e9032e99562a2ea69481ba7213a
+SIZE (lensfun-0.2.4-dev.tar.gz) = 28958
diff --git a/graphics/gimp-lensfun-plugin/files/patch-Makefile b/graphics/gimp-lensfun-plugin/files/patch-Makefile
new file mode 100644
index 000000000000..b339e520a9f5
--- /dev/null
+++ b/graphics/gimp-lensfun-plugin/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig 2014-02-08 09:31:49.000000000 -0200
++++ Makefile 2014-03-22 22:41:34.000000000 -0300
+@@ -9,8 +9,6 @@
+
+
+ # set standard values, if not set by default
+-CXX ?= g++
+-CXXFLAGS += -O3 -Wall
+
+
+ # project-specific flags
+@@ -26,8 +24,6 @@
+ endif
+ else
+ # comment to disable OpenMP
+- CXXFLAGS += -fopenmp
+- LDFLAGS += -fopenmp
+ endif
+
+
diff --git a/graphics/gimp-lensfun-plugin/pkg-descr b/graphics/gimp-lensfun-plugin/pkg-descr
new file mode 100644
index 000000000000..1544a96520b3
--- /dev/null
+++ b/graphics/gimp-lensfun-plugin/pkg-descr
@@ -0,0 +1,11 @@
+[ edition version of author's www site ]
+
+GimpLensfun is a Gimp plugin to correct lens distortion using the
+lensfun library and database.
+
+The plugin can be found under "Filters > Enhance > GimpLensfun".
+
+It autodetects camera, lens type and corresponding parameters
+from the EXIF information embedded in the image file.
+
+WWW: http://github.com/seebk/GIMP-Lensfun.git