aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimp-resynthesizer
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-05-06 16:29:43 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-05-06 16:29:43 +0000
commit457022d0285fdd0ecaeb5fd3ac57944d2cc6658b (patch)
treefd263ca273e81608abc9b03544f5c857d7e18330 /graphics/gimp-resynthesizer
parent619336abdf11002aab0c85490943ce8d6e9df4c0 (diff)
downloadports-457022d0285fdd0ecaeb5fd3ac57944d2cc6658b.tar.gz
ports-457022d0285fdd0ecaeb5fd3ac57944d2cc6658b.zip
Notes
Diffstat (limited to 'graphics/gimp-resynthesizer')
-rw-r--r--graphics/gimp-resynthesizer/Makefile44
-rw-r--r--graphics/gimp-resynthesizer/distinfo3
-rw-r--r--graphics/gimp-resynthesizer/pkg-descr9
-rw-r--r--graphics/gimp-resynthesizer/pkg-message7
4 files changed, 63 insertions, 0 deletions
diff --git a/graphics/gimp-resynthesizer/Makefile b/graphics/gimp-resynthesizer/Makefile
new file mode 100644
index 000000000000..681887973d1f
--- /dev/null
+++ b/graphics/gimp-resynthesizer/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: resynthesizer
+# Date created: 05 May 2010
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= resynthesizer
+PORTVERSION= 0.16
+CATEGORIES= graphics
+MASTER_SITES= http://www.logarithmic.net/pfh-files/resynthesizer/ \
+ http://mirror.amdmi3.ru/distfiles/
+PKGNAMEPREFIX= gimp-
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Gimp plug-in for texture synthesis
+
+LIB_DEPENDS= gimp-2.0:${PORTSDIR}/graphics/gimp-app
+
+GIMPTOOL?= gimptool-2.0
+PLUGINS_DIR?= libexec/gimp/2.2/plug-ins
+SCRIPTS_DIR?= share/gimp/scripts
+
+MAKE_JOBS_SAFE= yes
+PLIST_FILES= ${PLUGINS_DIR}/resynth \
+ ${SCRIPTS_DIR}/smart-enlarge.scm \
+ ${SCRIPTS_DIR}/smart-remove.scm
+
+do-build:
+ cd ${WRKSRC} && ${CXX} ${CXXFLAGS} \
+ `${GIMPTOOL} --cflags --libs` -o resynth resynth.cc
+
+do-install:
+ ${MKDIR} ${PREFIX}/${PLUGINS_DIR} ${PREFIX}/${SCRIPTS_DIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/resynth ${PREFIX}/${PLUGINS_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/smart-enlarge.scm \
+ ${WRKSRC}/smart-remove.scm ${PREFIX}/${SCRIPTS_DIR}
+
+post-install:
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/graphics/gimp-resynthesizer/distinfo b/graphics/gimp-resynthesizer/distinfo
new file mode 100644
index 000000000000..8810dd2988c9
--- /dev/null
+++ b/graphics/gimp-resynthesizer/distinfo
@@ -0,0 +1,3 @@
+MD5 (resynthesizer-0.16.tar.gz) = 097b3a21803fe02e47b8b8649af48144
+SHA256 (resynthesizer-0.16.tar.gz) = dd24ec89f3a36f867b733c6a5c1d193b6d603251bd6553ac54b573fd655020cd
+SIZE (resynthesizer-0.16.tar.gz) = 18241
diff --git a/graphics/gimp-resynthesizer/pkg-descr b/graphics/gimp-resynthesizer/pkg-descr
new file mode 100644
index 000000000000..35ec4ee5bdcc
--- /dev/null
+++ b/graphics/gimp-resynthesizer/pkg-descr
@@ -0,0 +1,9 @@
+Resynthesizer is a Gimp plug-in for texture synthesis. Given a
+sample of a texture, it can create more of that texture. This has
+a surprising number of uses:
+
+ * Creating more of a texture
+ * Removing objects from images
+ * Creating themed images
+
+WWW: http://www.logarithmic.net/pfh/resynthesizer
diff --git a/graphics/gimp-resynthesizer/pkg-message b/graphics/gimp-resynthesizer/pkg-message
new file mode 100644
index 000000000000..dfc9b08aa7f1
--- /dev/null
+++ b/graphics/gimp-resynthesizer/pkg-message
@@ -0,0 +1,7 @@
+After restarting the Gimp you should find the following items in
+the pop-up image menu:
+
+ * Filters/Map/Resynthesize
+ * Filters/Enhance/Smart enlarge
+ * Filters/Enhance/Smart sharpen
+ * Filters/Enhance/Smart remove selection