aboutsummaryrefslogtreecommitdiff
path: root/graphics/giram
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-01-17 06:22:50 +0000
committerPatrick Li <pat@FreeBSD.org>2002-01-17 06:22:50 +0000
commit0bae732de76c73640d03141be7c9eab8fea211ca (patch)
tree65ecea381415551ca97e6248e17f353a76deb4a9 /graphics/giram
parentd3dfc05021206b1f27bf29f3e32b9a954c825951 (diff)
downloadports-0bae732de76c73640d03141be7c9eab8fea211ca.tar.gz
ports-0bae732de76c73640d03141be7c9eab8fea211ca.zip
Notes
Diffstat (limited to 'graphics/giram')
-rw-r--r--graphics/giram/Makefile2
-rw-r--r--graphics/giram/files/patch-configure31
2 files changed, 32 insertions, 1 deletions
diff --git a/graphics/giram/Makefile b/graphics/giram/Makefile
index c95f1bc1c025..64ddeb302b50 100644
--- a/graphics/giram/Makefile
+++ b/graphics/giram/Makefile
@@ -35,7 +35,7 @@ CONFIGURE_ARGS+=--disable-gnome
.endif
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
diff --git a/graphics/giram/files/patch-configure b/graphics/giram/files/patch-configure
new file mode 100644
index 000000000000..327fc6f8f04c
--- /dev/null
+++ b/graphics/giram/files/patch-configure
@@ -0,0 +1,31 @@
+--- configure.orig Thu Jan 17 01:15:12 2002
++++ configure Thu Jan 17 01:17:15 2002
+@@ -4152,7 +4152,6 @@
+ #
+ have_pthread=no
+ mesa_requires_pthread=no
+- if test "$ac_have_mesa_gl" = yes; then
+ echo $ac_n "checking for pthread_create in -pthread""... $ac_c" 1>&6
+ echo "configure:4158: checking for pthread_create in -pthread" >&5
+ ac_lib_var=`echo pthread'_'pthread_create | sed 'y%./+-%__p_%'`
+@@ -4240,12 +4239,7 @@
+ LIBS="$ac_save_LIBS"
+
+ fi
+-if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+- echo "$ac_t""yes" 1>&6
+ mesa_requires_pthread=yes
+-else
+- echo "$ac_t""no" 1>&6
+-fi
+
+ CPPFLAGS="$ac_save_CPPFLAGS"
+ LDFLAGS="$ac_save_LDFLAGS"
+@@ -4253,7 +4247,6 @@
+ if test "$mesa_requires_pthread" = yes; then
+ GL_LIBS="$GL_LIBS -pthread"
+ fi
+- fi
+ # Check for OpenGL 1.1 features.
+ #
+