aboutsummaryrefslogtreecommitdiff
path: root/graphics/glexcess
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-07-24 11:47:31 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-07-24 11:47:31 +0000
commitd3c9ed56a95dfd59cd58d129aafbfc40255154c8 (patch)
tree266029ad903e2ff7fecd74c7d358951064fc2aaf /graphics/glexcess
parentb9a51fb412300f0ebb7a51754972037b16526b43 (diff)
downloadports-d3c9ed56a95dfd59cd58d129aafbfc40255154c8.tar.gz
ports-d3c9ed56a95dfd59cd58d129aafbfc40255154c8.zip
- Fix build with gcc 4.2
PR: 114787 Submitted by: Hernan Di Pietro <hernan.di.pietro@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=196184
Diffstat (limited to 'graphics/glexcess')
-rw-r--r--graphics/glexcess/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/graphics/glexcess/Makefile b/graphics/glexcess/Makefile
index 39e2a72d0bb0..c72a68234e2a 100644
--- a/graphics/glexcess/Makefile
+++ b/graphics/glexcess/Makefile
@@ -25,6 +25,9 @@ MAKE_ARGS= 'CXXFLAGS=${CXXFLAGS} -I${X11BASE}/include -pipe -s -O2' \
post-patch:
@${REINPLACE_CMD} -e 's|data/|${DATADIR}/|' ${WRKSRC}/scene*.cpp
+ @${REINPLACE_CMD} -e 's|k_InitGL(GLvoid)|k_InitGL(void)|' ${WRKSRC}/scene12.cpp
+ @${REINPLACE_CMD} -e 's|Load(char\*|Load(const char* |g' ${WRKSRC}/Texture.*
+ @${REINPLACE_CMD} -e 's|Create(char\*|Create(const char* |g' ${WRKSRC}/Texture.*
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/glxs ${PREFIX}/bin