aboutsummaryrefslogtreecommitdiff
path: root/graphics/glfw
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-01-28 20:31:49 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-01-28 20:31:49 +0000
commit19582e0b7aad0d71349231d0e3e824712e1e2196 (patch)
tree6ecd7f81769280acd12f7d7545b4396eb6cef7ef /graphics/glfw
parent934778842fc419f3367c3d049cde23d6c32868fd (diff)
downloadports-19582e0b7aad0d71349231d0e3e824712e1e2196.tar.gz
ports-19582e0b7aad0d71349231d0e3e824712e1e2196.zip
- Update to 3.0.4, stable version
- Import from graphics/glfw-devel - Add USES=cmake - Add USE_GCC=yes - Remove MAKE_JOBS_UNSAFE=yes - Remove PLIST_FILES, add pkg-plist - Add CPPFLAGS and LDFLAGS - Change DOCS and EXAMPLES - Remove PORTSCOUT - Add DOCS and EXAMPLES Options - Remove post-extract - Change REINPLACE - Remove obsolete patches - Change pkg-descr
Notes
Notes: svn path=/head/; revision=341653
Diffstat (limited to 'graphics/glfw')
-rw-r--r--graphics/glfw/Makefile67
-rw-r--r--graphics/glfw/distinfo4
-rw-r--r--graphics/glfw/files/patch-lib__x11__Makefile.x11.in29
-rw-r--r--graphics/glfw/pkg-descr12
-rw-r--r--graphics/glfw/pkg-plist11
5 files changed, 47 insertions, 76 deletions
diff --git a/graphics/glfw/Makefile b/graphics/glfw/Makefile
index d9b13f233345..aecec7d93387 100644
--- a/graphics/glfw/Makefile
+++ b/graphics/glfw/Makefile
@@ -1,8 +1,8 @@
-# Created by: Igor Pokrovsky <tiamat@comset.net>
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
# $FreeBSD$
PORTNAME= glfw
-PORTVERSION= 2.7.9
+PORTVERSION= 3.0.4
CATEGORIES= graphics
MASTER_SITES= SF
@@ -11,72 +11,57 @@ COMMENT= Portable framework for OpenGL development
LICENSE= ZLIB
-USE_BZIP2= yes
-HAS_CONFIGURE= yes
-CONFIGURE_SCRIPT= compile.sh
-ALL_TARGET= x11
-INSTALL_TARGET= x11-install
+USES= cmake
USE_XORG= xi xrandr
USE_GL= glu
+USE_GCC= yes
USE_LDCONFIG= yes
-MAKE_JOBS_UNSAFE= yes
-PLIST_FILES= include/GL/glfw.h \
- lib/libglfw.a \
- lib/libglfw.so \
- lib/libglfw.so.0 \
- libdata/pkgconfig/libglfw.pc
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= *
DOCSRCDIR1= ${WRKSRC}
-DOC_FILES1= *.html
+DOC_FILES1= README.md
-DOCSRCDIR2= ${WRKSRC}/docs
-DOCSDIR2= ${DOCSDIR}/docs
-DOC_FILES2= *.pdf *.sty *.tex *.txt
+DOCSRCDIR2= ${WRKSRC}/docs/html/search
+DOCSDIR2= ${DOCSDIR}/docs/html/search
+DOC_FILES2= *
+
+DOCSRCDIR3= ${WRKSRC}/docs/html
+DOCSDIR3= ${DOCSDIR}/docs/html
+DOC_FILES3= *.html *.png *.css *.js
PORTEXAMPLES= *
EXAMPLESSRCDIR1= ${WRKSRC}/examples
-EXAMPLES_FILES1= boing gears heightmap listmodes mipmaps mtbench mthello \
- pong3d splitview triangle wave
+EXAMPLES_FILES1= boing gears heightmap simple splitview wave
EXAMPLESSRCDIR2= ${WRKSRC}/tests
EXAMPLESDIR2= ${EXAMPLESDIR}/tests
-EXAMPLES_FILES2= accuracy defaults dynamic events fsaa fsinput iconify \
- joysticks peter reopen tearing version
-
-# Restrict to stable (even) versions, indicated by the second component.
-PORTSCOUT= limit:^2\..*
+EXAMPLES_FILES2= accuracy clipboard defaults events fsaa gamma glfwinfo \
+ iconify joysticks modes peter reopen sharing tearing \
+ threads title windows
-post-extract:
- @${CHMOD} ${BINMODE} ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+OPTIONS_DEFINE= DOCS EXAMPLES
post-patch:
- @${REINPLACE_CMD} -e \
- 's|/usr/X11R6|${LOCALBASE}| ; \
- /SOFLAGS/s|-soname |-Wl,-soname,| ; \
- /CFLAGS_THREAD/s|"-pthread"|"${PTHREAD_CFLAGS}"| ; \
- /LFLAGS_THREAD/s|"-pthread"|"${PTHREAD_LIBS}"|' \
- ${WRKSRC}/${CONFIGURE_SCRIPT}
- @${REINPLACE_CMD} \
- -e 's|lib/pkgconfig|libdata/pkgconfig|g' \
- ${WRKSRC}/lib/x11/Makefile.x11.in
+ @${REINPLACE_CMD} -e 's|lib$${LIB_SUFFIX}/pkgconfig|libdata/pkgconfig|' \
+ ${WRKSRC}/CMakeLists.txt
post-install:
- ${INSTALL_DATA} ${WRKSRC}/lib/x11/libglfw.so ${STAGEDIR}${PREFIX}/lib/libglfw.so.0
- ${LN} -sf ${PREFIX}/lib/libglfw.so.0 ${STAGEDIR}${PREFIX}/lib/libglfw.so
-
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR2}
${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES3:S|^|${DOCSRCDIR3}/|} ${STAGEDIR}${DOCSDIR3}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_PROGRAM} ${EXAMPLES_FILES1:S|^|${EXAMPLESSRCDIR1}/|} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${EXAMPLESSRCDIR1}/*.tga ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_PROGRAM} ${EXAMPLES_FILES1:S|^|${EXAMPLESSRCDIR1}/|} \
+ ${STAGEDIR}${EXAMPLESDIR}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR2}
- ${INSTALL_PROGRAM} ${EXAMPLES_FILES2:S|^|${EXAMPLESSRCDIR2}/|} ${STAGEDIR}${EXAMPLESDIR2}
+ ${INSTALL_PROGRAM} ${EXAMPLES_FILES2:S|^|${EXAMPLESSRCDIR2}/|} \
+ ${STAGEDIR}${EXAMPLESDIR2}
.include <bsd.port.mk>
diff --git a/graphics/glfw/distinfo b/graphics/glfw/distinfo
index dadf5d37140e..8f97357a954e 100644
--- a/graphics/glfw/distinfo
+++ b/graphics/glfw/distinfo
@@ -1,2 +1,2 @@
-SHA256 (glfw-2.7.9.tar.bz2) = d1f47e99e4962319f27f30d96571abcb04c1022c000de4d01df69ec59aae829d
-SIZE (glfw-2.7.9.tar.bz2) = 946924
+SHA256 (glfw-3.0.4.tar.gz) = c8bea730b1e3a6ec690370dfa0ec06716e3c4e454736c58bef584dff13cdb784
+SIZE (glfw-3.0.4.tar.gz) = 592216
diff --git a/graphics/glfw/files/patch-lib__x11__Makefile.x11.in b/graphics/glfw/files/patch-lib__x11__Makefile.x11.in
deleted file mode 100644
index 1e31d02863a7..000000000000
--- a/graphics/glfw/files/patch-lib__x11__Makefile.x11.in
+++ /dev/null
@@ -1,29 +0,0 @@
---- ./lib/x11/Makefile.x11.in.orig 2013-05-30 16:07:32.000000000 +0200
-+++ ./lib/x11/Makefile.x11.in 2013-09-30 12:46:48.994429398 +0200
-@@ -26,19 +26,19 @@
- # Install GLFW static library
- ##########################################################################
- install: libglfw.a libglfw.pc
-- $(INSTALL) -d $(PREFIX)/lib
-- $(INSTALL) -c -m 644 libglfw.a $(PREFIX)/lib/libglfw.a
-- $(INSTALL) -d $(PREFIX)/include/GL
-- $(INSTALL) -c -m 644 ../../include/GL/glfw.h $(PREFIX)/include/GL/glfw.h
-- $(INSTALL) -d $(PREFIX)/lib/pkgconfig
-- $(INSTALL) -c -m 644 libglfw.pc $(PREFIX)/lib/pkgconfig/libglfw.pc
-+ $(INSTALL) -d $(DESTDIR)$(PREFIX)/lib
-+ $(INSTALL) -c -m 644 libglfw.a $(DESTDIR)$(PREFIX)/lib/libglfw.a
-+ $(INSTALL) -d $(DESTDIR)$(PREFIX)/include/GL
-+ $(INSTALL) -c -m 644 ../../include/GL/glfw.h $(DESTDIR)$(PREFIX)/include/GL/glfw.h
-+ $(INSTALL) -d $(DESTDIR)$(PREFIX)/lib/pkgconfig
-+ $(INSTALL) -c -m 644 libglfw.pc $(DESTDIR)$(PREFIX)/lib/pkgconfig/libglfw.pc
-
-
- ##########################################################################
- # Install GLFW static and shared libraries
- ##########################################################################
- dist-install: libglfw.so install
-- $(INSTALL) -c -m 644 libglfw.so $(PREFIX)/lib/libglfw.so
-+ $(INSTALL) -c -m 644 libglfw.so $(DESTDIR)$(PREFIX)/lib/libglfw.so
-
-
- ##########################################################################
diff --git a/graphics/glfw/pkg-descr b/graphics/glfw/pkg-descr
index a411cc447c5e..93bf8a4b725c 100644
--- a/graphics/glfw/pkg-descr
+++ b/graphics/glfw/pkg-descr
@@ -1,6 +1,10 @@
-GLFW is a free, Open Source, multi-platform library for OpenGL application
-development that provides a powerful API for handling operating system specific
-tasks such as opening an OpenGL window, reading keyboard, mouse, joystick and
-time input, creating threads, and more.
+GLFW is a free, Open Source, portable library for OpenGL and OpenGL ES
+application development. It provides a simple, platform-independent API for
+creating windows and contexts, reading input, handling events, etc.
+
+Version 3.0 brings a new API with many new features such as multiple windows
+and contexts, multi-monitor support, EGL and OpenGL ES support, clipboard text
+support, an error description callback, gamma ramp control, layout-independent
+keyboard input and UTF-8 for all strings.
WWW: http://www.glfw.org/
diff --git a/graphics/glfw/pkg-plist b/graphics/glfw/pkg-plist
new file mode 100644
index 000000000000..c48e2d76f386
--- /dev/null
+++ b/graphics/glfw/pkg-plist
@@ -0,0 +1,11 @@
+include/GLFW/glfw3.h
+include/GLFW/glfw3native.h
+lib/cmake/glfw/glfwConfig.cmake
+lib/cmake/glfw/glfwConfigVersion.cmake
+lib/cmake/glfw/glfwTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/glfw/glfwTargets.cmake
+lib/libglfw3.a
+libdata/pkgconfig/glfw3.pc
+@dirrm lib/cmake/glfw
+@dirrmtry lib/cmake
+@dirrm include/GLFW