aboutsummaryrefslogtreecommitdiff
path: root/graphics/glfw
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-12-17 17:35:34 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-12-17 17:35:34 +0000
commit390e47c7ce34f63e88a382258f455df4e60313d4 (patch)
treec7c541649899d1e6b71c93c22f0d6b10d0d255c7 /graphics/glfw
parentf25e0cd2531340ac15555c83ee5012c7dd315309 (diff)
downloadports-390e47c7ce34f63e88a382258f455df4e60313d4.tar.gz
ports-390e47c7ce34f63e88a382258f455df4e60313d4.zip
- Update to 2.7.7, add LICENSE
- Remove pkg-plist, switch to PLIST_FILES, PORTDOCS, PORTEXAMPLES - Give maintainership to submitter While I'm here: - Add missing deps - Sort USE_ flags PR: ports/173571 Submitted by: nemysis <nemysis@gmx.ch>
Notes
Notes: svn path=/head/; revision=309114
Diffstat (limited to 'graphics/glfw')
-rw-r--r--graphics/glfw/Makefile39
-rw-r--r--graphics/glfw/distinfo4
-rw-r--r--graphics/glfw/pkg-descr8
-rw-r--r--graphics/glfw/pkg-plist30
4 files changed, 34 insertions, 47 deletions
diff --git a/graphics/glfw/Makefile b/graphics/glfw/Makefile
index 92c8515be613..f98201c3aaf5 100644
--- a/graphics/glfw/Makefile
+++ b/graphics/glfw/Makefile
@@ -2,23 +2,38 @@
# $FreeBSD$
PORTNAME= glfw
-PORTVERSION= 2.7.6
+PORTVERSION= 2.7.7
CATEGORIES= graphics
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@gmx.ch
COMMENT= Portable framework for OpenGL development
+LICENSE= ZLIB
+
+LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ drm:${PORTSDIR}/graphics/libdrm \
+ xcb:${PORTSDIR}/x11/libxcb
+
USE_BZIP2= yes
-USE_XORG= x11 xext xrandr
-USE_GL= glu
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= compile.sh
ALL_TARGET= x11
INSTALL_TARGET= x11-install
+USE_XORG= x11 xau xdamage xdmcp xext xfixes xrandr xrender xxf86vm
+USE_GL= glu
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE=yes
+PLIST_FILES= include/GL/glfw.h \
+ lib/libglfw.a \
+ lib/libglfw.so \
+ lib/libglfw.so.0 \
+ libdata/pkgconfig/libglfw.pc
+
+PORTDOCS= *.pdf
+PORTEXAMPLES= Makefile.x11.in *.c *.tga
+
.include <bsd.port.options.mk>
post-extract:
@@ -29,22 +44,24 @@ post-patch:
's|/usr/X11R6|${LOCALBASE}| ; \
/SOFLAGS/s|-soname |-Wl,-soname,| ; \
/CFLAGS_THREAD/s|"-pthread"|"${PTHREAD_CFLAGS}"| ; \
- /LFLAGS_THREAD/s|"-pthread"|"${PTHREAD_LIBS}"|' ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ /LFLAGS_THREAD/s|"-pthread"|"${PTHREAD_LIBS}"|' ${WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -e \
's|lib/pkgconfig|libdata/pkgconfig|g' ${WRKSRC}/lib/x11/Makefile.x11.in
post-install:
${INSTALL_DATA} ${WRKSRC}/lib/x11/libglfw.so ${PREFIX}/lib/libglfw.so.0
${LN} -sf ${PREFIX}/lib/libglfw.so.0 ${PREFIX}/lib/libglfw.so
+
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/*.pdf ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${DOCSDIR}
.endif
+
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/Makefile.x11 ${EXAMPLESDIR}/makefile
- ${INSTALL_DATA} ${WRKSRC}/examples/*.c ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/*.tga ${EXAMPLESDIR}
+ ${MKDIR} ${EXAMPLESDIR}
+.for e in ${PORTEXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/examples/${e} ${EXAMPLESDIR}
+.endfor
.endif
.include <bsd.port.mk>
diff --git a/graphics/glfw/distinfo b/graphics/glfw/distinfo
index 3e14683b8a35..cf249625d71e 100644
--- a/graphics/glfw/distinfo
+++ b/graphics/glfw/distinfo
@@ -1,2 +1,2 @@
-SHA256 (glfw-2.7.6.tar.bz2) = d4e9a74be4c20ff03470c6aa5dad6877e65e4e1aa6b31039a4579b281e89a333
-SIZE (glfw-2.7.6.tar.bz2) = 907927
+SHA256 (glfw-2.7.7.tar.bz2) = 422e755979524a1da28e4addcae723b7132998ca15e89be41bf34964d9360aa2
+SIZE (glfw-2.7.7.tar.bz2) = 927805
diff --git a/graphics/glfw/pkg-descr b/graphics/glfw/pkg-descr
index 78cdea568b43..a411cc447c5e 100644
--- a/graphics/glfw/pkg-descr
+++ b/graphics/glfw/pkg-descr
@@ -1,6 +1,6 @@
-GLFW is a free, open source, portable framework for OpenGL application
-development. In short, it is a library that constitutes a powerful API
-for handling operating system specific tasks, such as opening an OpenGL
-window, reading keyboard and mouse input, creating threads, and much more.
+GLFW is a free, Open Source, multi-platform library for OpenGL application
+development that provides a powerful API for handling operating system specific
+tasks such as opening an OpenGL window, reading keyboard, mouse, joystick and
+time input, creating threads, and more.
WWW: http://www.glfw.org/
diff --git a/graphics/glfw/pkg-plist b/graphics/glfw/pkg-plist
deleted file mode 100644
index 685c852ea96f..000000000000
--- a/graphics/glfw/pkg-plist
+++ /dev/null
@@ -1,30 +0,0 @@
-include/GL/glfw.h
-lib/libglfw.a
-lib/libglfw.so
-lib/libglfw.so.0
-libdata/pkgconfig/libglfw.pc
-%%PORTDOCS%%%%DOCSDIR%%/Reference.pdf
-%%PORTDOCS%%%%DOCSDIR%%/UsersGuide.pdf
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/makefile
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/boing.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gears.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/getopt.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/heightmap.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/listmodes.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mipmaps.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mtbench.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mthello.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/particles.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pong3d.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/splitview.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/triangle.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wave.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mipmaps.tga
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pong3d_field.tga
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pong3d_instr.tga
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pong3d_menu.tga
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pong3d_title.tga
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pong3d_winner1.tga
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pong3d_winner2.tga
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%