aboutsummaryrefslogtreecommitdiff
path: root/graphics/glfw
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /graphics/glfw
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadports-707c6bf295fc3955c86c9244533c1524bb7dea15.tar.gz
ports-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=488341
Diffstat (limited to 'graphics/glfw')
-rw-r--r--graphics/glfw/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/glfw/Makefile b/graphics/glfw/Makefile
index ef623481efc4..731c2fce0452 100644
--- a/graphics/glfw/Makefile
+++ b/graphics/glfw/Makefile
@@ -13,7 +13,7 @@ COMMENT= Portable framework for OpenGL development
LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/COPYING.txt
-USES= cmake localbase zip
+USES= cmake:insource localbase zip
USE_GL= glu
USE_LDCONFIG= yes
CMAKE_ON= BUILD_SHARED_LIBS