aboutsummaryrefslogtreecommitdiff
path: root/graphics/glfw
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-10-20 21:39:08 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-10-20 21:39:08 +0000
commit834bafd613c85958374d78cbf9dea9611668b684 (patch)
tree0f4826c36e0812b0833face0e16e4e823dadb4d9 /graphics/glfw
parent25831616e55d483d811d12a5f73df0f3da30f17e (diff)
downloadports-834bafd613c85958374d78cbf9dea9611668b684.tar.gz
ports-834bafd613c85958374d78cbf9dea9611668b684.zip
graphics/glfw: prevent enabling WAYLAND without disabling X11
PR: 232323 Reviewed by: tobik Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=482624
Diffstat (limited to 'graphics/glfw')
-rw-r--r--graphics/glfw/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/graphics/glfw/Makefile b/graphics/glfw/Makefile
index cadc2abc675e..8acb17c219b9 100644
--- a/graphics/glfw/Makefile
+++ b/graphics/glfw/Makefile
@@ -21,7 +21,11 @@ CMAKE_ON= BUILD_SHARED_LIBS
PORTDOCS= *
PORTEXAMPLES= *
-OPTIONS_DEFINE= DOCS EXAMPLES WAYLAND
+OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_DEFAULT=X11
+PLATFORM_DESC= Window creation platform
+OPTIONS_SINGLE= PLATFORM
+OPTIONS_SINGLE_PLATFORM= WAYLAND X11
OPTIONS_EXCLUDE_FreeBSD_10= WAYLAND # needs dev/evdev/input.h
WAYLAND_BUILD_DEPENDS= wayland-protocols>=0:graphics/wayland-protocols
@@ -30,7 +34,8 @@ WAYLAND_LIB_DEPENDS= libwayland-egl.so:graphics/wayland \
libxkbcommon.so:x11/libxkbcommon
WAYLAND_USES= kde:5 pkgconfig
WAYLAND_USE= KDE=ecm
-WAYLAND_USE_OFF= XORG=x11,xcursor,xinerama,xrandr,xxf86vm
+
+X11_USE= XORG=x11,xcursor,xinerama,xrandr,xxf86vm
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/docs/html/search