aboutsummaryrefslogtreecommitdiff
path: root/graphics/gliv
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-04-02 20:24:10 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-04-02 20:24:10 +0000
commit926d938f46618c0848a289c13898da217cb9cb23 (patch)
treee4459d49d6f55ce1353a18f9a32110cab5580939 /graphics/gliv
parentc274063a6a3f6157b82a5873466110a285255708 (diff)
downloadports-926d938f46618c0848a289c13898da217cb9cb23.tar.gz
ports-926d938f46618c0848a289c13898da217cb9cb23.zip
- Update to 1.9.2
PR: 79476 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=132268
Diffstat (limited to 'graphics/gliv')
-rw-r--r--graphics/gliv/Makefile3
-rw-r--r--graphics/gliv/distinfo4
-rw-r--r--graphics/gliv/files/patch-src::collection.c87
-rw-r--r--graphics/gliv/files/patch-src::options.c38
-rw-r--r--graphics/gliv/pkg-plist1
5 files changed, 4 insertions, 129 deletions
diff --git a/graphics/gliv/Makefile b/graphics/gliv/Makefile
index 931b0f5be471..acd907d89523 100644
--- a/graphics/gliv/Makefile
+++ b/graphics/gliv/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gliv
-PORTVERSION= 1.9.1
-PORTREVISION= 1
+PORTVERSION= 1.9.2
CATEGORIES= graphics
MASTER_SITES= http://guichaz.free.fr/gliv/
diff --git a/graphics/gliv/distinfo b/graphics/gliv/distinfo
index a0866f7c9a8f..b1639a97f2dc 100644
--- a/graphics/gliv/distinfo
+++ b/graphics/gliv/distinfo
@@ -1,2 +1,2 @@
-MD5 (gliv-1.9.1.tar.bz2) = 2feec67d5a3263a50cb6d75c6ff42fa7
-SIZE (gliv-1.9.1.tar.bz2) = 446120
+MD5 (gliv-1.9.2.tar.bz2) = 171c4be01093f0517b040a340c1a69b7
+SIZE (gliv-1.9.2.tar.bz2) = 455979
diff --git a/graphics/gliv/files/patch-src::collection.c b/graphics/gliv/files/patch-src::collection.c
deleted file mode 100644
index 00b8afd23221..000000000000
--- a/graphics/gliv/files/patch-src::collection.c
+++ /dev/null
@@ -1,87 +0,0 @@
---- src/collection.c.orig Mon Dec 20 08:16:25 2004
-+++ src/collection.c Sat Dec 25 23:01:11 2004
-@@ -713,8 +713,8 @@
- guchar *base;
- guchar *ptr;
- guchar *end;
-- };
-- };
-+ } s;
-+ } u;
- };
-
- static void free_buffer(struct coll_src *source, guchar * buffer)
-@@ -730,16 +730,16 @@
-
- if (source->is_file) {
- data = g_new(guchar, length);
-- if (fread(data, 1, length, source->file) != length) {
-+ if (fread(data, 1, length, source->u.file) != length) {
- g_free(data);
- return NULL;
- }
- } else {
-- if (source->ptr + length > source->end)
-+ if (source->u.s.ptr + length > source->u.s.end)
- return NULL;
-
-- data = source->ptr;
-- source->ptr += length;
-+ data = source->u.s.ptr;
-+ source->u.s.ptr += length;
- }
-
- if (is_string && data[length - 1] != '\0') {
-@@ -753,12 +753,12 @@
- static gint read_char(struct coll_src *source)
- {
- if (source->is_file)
-- return fgetc(source->file);
-+ return fgetc(source->u.file);
-
-- if (source->ptr >= source->end)
-+ if (source->u.s.ptr >= source->u.s.end)
- return EOF;
-
-- return *(source->ptr++);
-+ return *(source->u.s.ptr++);
- }
-
- static GdkPixbufDestroyNotify destroy_func(struct coll_src *source)
-@@ -930,22 +930,22 @@
- goto no_mmap;
- }
-
-- source->base = mmap(NULL, length, PROT_READ, MAP_PRIVATE, fileno(file), 0);
-- if (source->base == MAP_FAILED) {
-+ source->u.s.base = mmap(NULL, length, PROT_READ, MAP_PRIVATE, fileno(file), 0);
-+ if (source->u.s.base == MAP_FAILED) {
- perror("mmap");
- goto no_mmap;
- }
-
- source->is_file = FALSE;
-- source->ptr = source->base;
-- source->end = source->base + length;
-+ source->u.s.ptr = source->u.s.base;
-+ source->u.s.end = source->u.s.base + length;
- goto ok;
-
- no_mmap:
- fseeko(file, 0, SEEK_SET);
-
- source->is_file = TRUE;
-- source->file = file;
-+ source->u.file = file;
-
- ok:
- return source;
-@@ -954,7 +954,7 @@
- static void destroy_source(struct coll_src *source, gboolean ok)
- {
- if (ok == FALSE && source->is_file == FALSE)
-- if (munmap(source->base, source->end - source->base) < 0)
-+ if (munmap(source->u.s.base, source->u.s.end - source->u.s.base) < 0)
- perror("munmap");
- }
-
diff --git a/graphics/gliv/files/patch-src::options.c b/graphics/gliv/files/patch-src::options.c
deleted file mode 100644
index 742e3fe2b270..000000000000
--- a/graphics/gliv/files/patch-src::options.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/options.c.orig Mon Dec 20 08:24:26 2004
-+++ src/options.c Sat Dec 25 23:10:14 2004
-@@ -199,12 +199,15 @@
-
- static gboolean on_read_config_realize(GtkLabel * widget)
- {
-- const gchar *filename = get_read_config_file();
-+ const gchar *filename;
-+ gchar *text;
-+
-+ filename = get_read_config_file();
-
- if (filename == NULL)
- filename = _("NONE");
-
-- gchar *text =
-+ text =
- g_strdup_printf(_("This configuration file has been read: %s"),
- filename);
-
-@@ -216,12 +219,15 @@
-
- static gboolean on_write_config_realize(GtkLabel * widget)
- {
-- const gchar *filename = get_write_config_file();
-+ const gchar *filename;
-+ gchar *text;
-+
-+ filename = get_write_config_file();
-
- if (filename == NULL)
- filename = _("NONE");
-
-- gchar *text =
-+ text =
- g_strdup_printf(_("This configuration file will be written: %s"),
- filename);
-
diff --git a/graphics/gliv/pkg-plist b/graphics/gliv/pkg-plist
index 1db6814d0d46..e974d7b765d6 100644
--- a/graphics/gliv/pkg-plist
+++ b/graphics/gliv/pkg-plist
@@ -8,6 +8,7 @@ share/locale/pt_BR/LC_MESSAGES/gliv.mo
share/locale/ro/LC_MESSAGES/gliv.mo
share/locale/ru/LC_MESSAGES/gliv.mo
share/locale/sk/LC_MESSAGES/gliv.mo
+share/locale/tr/LC_MESSAGES/gliv.mo
@unexec rmdir %D/man/ru/man1 2>/dev/null || true
@unexec rmdir %D/man/ru 2>/dev/null || true
@unexec rmdir %D/man/fr/man1 2>/dev/null || true