aboutsummaryrefslogtreecommitdiff
path: root/graphics/glosm
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-09-18 08:47:31 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-09-18 08:47:31 +0000
commit03cf2e0916b5eadaaa5d50ad8034f0f648102053 (patch)
tree2e7efe898622c1415ef112d3cb11991db31f4790 /graphics/glosm
parent0d005beba9e28875a2ea08dc3dd55d446547630a (diff)
downloadports-03cf2e0916b5eadaaa5d50ad8034f0f648102053.tar.gz
ports-03cf2e0916b5eadaaa5d50ad8034f0f648102053.zip
Conditionalize the addition of -Wno-c++11-narrowing to fix clang6 errors
in CFLAGS to affect clang-based archs. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=479998
Diffstat (limited to 'graphics/glosm')
-rw-r--r--graphics/glosm/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/graphics/glosm/Makefile b/graphics/glosm/Makefile
index ff6aea0c9363..5bd294687070 100644
--- a/graphics/glosm/Makefile
+++ b/graphics/glosm/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png \
libexpat.so:textproc/expat2
-USES= tar:bzip2 cmake
+USES= cmake compiler tar:bzip2
USE_GL= gl
USE_XORG= x11
USE_SDL= sdl
@@ -24,7 +24,8 @@ USE_GITHUB= yes
GH_ACCOUNT= AMDmi3
TEST_TARGET= test
-CXXFLAGS+= -Wno-c++11-narrowing
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
PORTDOCS= README ChangeLog