aboutsummaryrefslogtreecommitdiff
path: root/graphics/glosm
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-05-14 19:38:32 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-05-14 19:38:32 +0000
commit3720dfe89bd8d52b5a90f3cd601dc51a728a4bf7 (patch)
tree497144e43ead3a280594c5f32039bbfce83aef22 /graphics/glosm
parentfff6da0e782b150da1acce9e2b93c993c8ba3a55 (diff)
downloadports-3720dfe89bd8d52b5a90f3cd601dc51a728a4bf7.tar.gz
ports-3720dfe89bd8d52b5a90f3cd601dc51a728a4bf7.zip
- Add LICENSE
- Add missing dependency - Fix build with clang 6.0
Notes
Notes: svn path=/head/; revision=469961
Diffstat (limited to 'graphics/glosm')
-rw-r--r--graphics/glosm/Makefile8
-rw-r--r--graphics/glosm/files/patch-tiler_PBuffer.cc20
2 files changed, 27 insertions, 1 deletions
diff --git a/graphics/glosm/Makefile b/graphics/glosm/Makefile
index 3d3f1824f4ca..ff6aea0c9363 100644
--- a/graphics/glosm/Makefile
+++ b/graphics/glosm/Makefile
@@ -10,22 +10,28 @@ MASTER_SITES= GHC http://mirror.amdmi3.ru/distfiles/
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= 3D OpenGL renderer for OpenStreetMap
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libpng.so:graphics/png \
libexpat.so:textproc/expat2
USES= tar:bzip2 cmake
USE_GL= gl
+USE_XORG= x11
USE_SDL= sdl
USE_GITHUB= yes
GH_ACCOUNT= AMDmi3
TEST_TARGET= test
+CXXFLAGS+= -Wno-c++11-narrowing
+
PORTDOCS= README ChangeLog
OPTIONS_DEFINE= DOCS
post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
.endfor
diff --git a/graphics/glosm/files/patch-tiler_PBuffer.cc b/graphics/glosm/files/patch-tiler_PBuffer.cc
new file mode 100644
index 000000000000..4142ed5ab080
--- /dev/null
+++ b/graphics/glosm/files/patch-tiler_PBuffer.cc
@@ -0,0 +1,20 @@
+--- tiler/PBuffer.cc.orig 2011-02-27 15:05:45 UTC
++++ tiler/PBuffer.cc
+@@ -38,7 +38,7 @@ static bool CheckGLXVersion(Display* dis
+ return true;
+ }
+
+-PBuffer::PBuffer(int width, int height, int samples) : width_(width), height_(height), display_(NULL), context_(NULL), pbuffer_(NULL) {
++PBuffer::PBuffer(int width, int height, int samples) : width_(width), height_(height), display_(NULL), context_(NULL), pbuffer_(None) {
+ if ((display_ = XOpenDisplay(NULL)) == NULL)
+ throw PBufferException() << "cannot open default X display";
+
+@@ -113,7 +113,7 @@ PBuffer::PBuffer(int width, int height,
+ }
+
+ PBuffer::~PBuffer() {
+- if (!glXMakeCurrent(display_, NULL, NULL))
++ if (!glXMakeCurrent(display_, None, NULL))
+ warnx("cannot reset GLX context: glXMakeCurrent failed");
+ glXDestroyContext(display_, context_);
+ glXDestroyPbuffer(display_, pbuffer_);