aboutsummaryrefslogtreecommitdiff
path: root/graphics/glosm
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-02-21 20:50:29 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-02-21 20:50:29 +0000
commitbb8b585221d1f8c551df25c7f89c6d6974c2eb7a (patch)
treefbf1abbe329649a091f47986e77d599cd56dacf8 /graphics/glosm
parent5db27e472ed713303865fba180af9caf63881a30 (diff)
downloadports-bb8b585221d1f8c551df25c7f89c6d6974c2eb7a.tar.gz
ports-bb8b585221d1f8c551df25c7f89c6d6974c2eb7a.zip
- Switch to more correct way of avoiding C++11 related build errors
Notes
Notes: svn path=/head/; revision=493529
Diffstat (limited to 'graphics/glosm')
-rw-r--r--graphics/glosm/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/graphics/glosm/Makefile b/graphics/glosm/Makefile
index 5bd294687070..b93214dd15db 100644
--- a/graphics/glosm/Makefile
+++ b/graphics/glosm/Makefile
@@ -16,17 +16,15 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png \
libexpat.so:textproc/expat2
-USES= cmake compiler tar:bzip2
+USES= cmake gl sdl tar:bzip2
USE_GL= gl
USE_XORG= x11
USE_SDL= sdl
+USE_CXXSTD= c++98
USE_GITHUB= yes
GH_ACCOUNT= AMDmi3
TEST_TARGET= test
-CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
-CXXFLAGS_clang= -Wno-c++11-narrowing
-
PORTDOCS= README ChangeLog
OPTIONS_DEFINE= DOCS