aboutsummaryrefslogtreecommitdiff
path: root/graphics/glosm
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-10-19 00:14:22 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-10-19 00:14:22 +0000
commitbc21aba983241427217bfbf5e2966af3d892c336 (patch)
treec22de7c3da9b1d990ecd342e36ce236e44af10b3 /graphics/glosm
parent382a949b6f1d2fb5e6e7ce11d6fa170aaece746f (diff)
downloadports-bc21aba983241427217bfbf5e2966af3d892c336.tar.gz
ports-bc21aba983241427217bfbf5e2966af3d892c336.zip
- Support staging
- Use new LIB_DEPENDS syntax
Notes
Notes: svn path=/head/; revision=330809
Diffstat (limited to 'graphics/glosm')
-rw-r--r--graphics/glosm/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/graphics/glosm/Makefile b/graphics/glosm/Makefile
index 9a6bd46b5ec6..92fa4f86eb77 100644
--- a/graphics/glosm/Makefile
+++ b/graphics/glosm/Makefile
@@ -11,8 +11,8 @@ MASTER_SITES= http://cloud.github.com/downloads/AMDmi3/glosm/ \
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= 3D OpenGL renderer for OpenStreetMap
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- expat:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
+ libexpat.so:${PORTSDIR}/textproc/expat2
USE_BZIP2= yes
USES= cmake
@@ -21,18 +21,16 @@ USE_SDL= sdl
PORTDOCS= README ChangeLog
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT=DOCS
regression-test:
cd ${BUILD_WRKSRC} && ctest
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
.endfor
-.endif
.include <bsd.port.mk>