aboutsummaryrefslogtreecommitdiff
path: root/graphics/glosm
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-01-17 23:44:12 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-01-17 23:44:12 +0000
commited297c71cb11d3fe0eddc21bc30c0372d84f1516 (patch)
tree25e269cc6f4d14c01a7de5e5f686bae2b260db71 /graphics/glosm
parent6b4ca93557014ceef1521a047bf6f2b0e781eccb (diff)
downloadports-ed297c71cb11d3fe0eddc21bc30c0372d84f1516.tar.gz
ports-ed297c71cb11d3fe0eddc21bc30c0372d84f1516.zip
glosm is a framework for developing high-performance geospatial
data visualization applications of both interactive and batch nature featuring OpenGL-based 3D first-person and tile renderers. WWW: http://glosm.amdmi3.ru/about.html Feature safe: yes
Notes
Notes: svn path=/head/; revision=267927
Diffstat (limited to 'graphics/glosm')
-rw-r--r--graphics/glosm/Makefile40
-rw-r--r--graphics/glosm/distinfo2
-rw-r--r--graphics/glosm/pkg-descr5
3 files changed, 47 insertions, 0 deletions
diff --git a/graphics/glosm/Makefile b/graphics/glosm/Makefile
new file mode 100644
index 000000000000..d00be757ab45
--- /dev/null
+++ b/graphics/glosm/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: glosm
+# Date created: 15 Jan 2011
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= glosm
+PORTVERSION= 0.0.1
+CATEGORIES= graphics geography
+MASTER_SITES= http://github.com/downloads/AMDmi3/glosm/ \
+ http://mirror.amdmi3.ru/distfiles/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= 3D OpenGL renderer for OpenStreetMap
+
+LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
+ expat.6:${PORTSDIR}/textproc/expat2
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_GL= gl glu glut
+MAKE_JOBS_SAFE= yes
+
+PORTDOCS= README
+
+PLIST_FILES= bin/glosm-tiler bin/glosm-viewer lib/libglosm.so
+
+regression-test:
+ cd ${BUILD_WRKSRC} && ctest
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/glosm/distinfo b/graphics/glosm/distinfo
new file mode 100644
index 000000000000..9d873e8ea2ac
--- /dev/null
+++ b/graphics/glosm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (glosm-0.0.1.tar.bz2) = afedd47f3973c345e124bdc0b6a26145e567cfeaa2fe3017abf97d22b09cb65d
+SIZE (glosm-0.0.1.tar.bz2) = 60250
diff --git a/graphics/glosm/pkg-descr b/graphics/glosm/pkg-descr
new file mode 100644
index 000000000000..67b52d0f047c
--- /dev/null
+++ b/graphics/glosm/pkg-descr
@@ -0,0 +1,5 @@
+glosm is a framework for developing high-performance geospatial
+data visualization applications of both interactive and batch nature
+featuring OpenGL-based 3D first-person and tile renderers.
+
+WWW: http://glosm.amdmi3.ru/about.html