aboutsummaryrefslogtreecommitdiff
path: root/graphics/glslang
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-12-25 00:31:35 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-12-25 00:31:35 +0000
commit22b2ac0d2cf446c0dc419d1c4ed896aaa6533af1 (patch)
tree2e816b24d3237de29be7a77b93967c9d408f05bb /graphics/glslang
parent6dca3a6ad34487bf33492cacf030a65e6ca42ab8 (diff)
downloadports-22b2ac0d2cf446c0dc419d1c4ed896aaa6533af1.tar.gz
ports-22b2ac0d2cf446c0dc419d1c4ed896aaa6533af1.zip
graphics/glslang: update to 11.0.0
Notes
Notes: svn path=/head/; revision=559202
Diffstat (limited to 'graphics/glslang')
-rw-r--r--graphics/glslang/Makefile3
-rw-r--r--graphics/glslang/distinfo6
-rw-r--r--graphics/glslang/pkg-plist29
3 files changed, 16 insertions, 22 deletions
diff --git a/graphics/glslang/Makefile b/graphics/glslang/Makefile
index 856fcbd7bfd6..6318c19b55dd 100644
--- a/graphics/glslang/Makefile
+++ b/graphics/glslang/Makefile
@@ -1,7 +1,8 @@
# $FreeBSD$
PORTNAME= glslang
-DISTVERSION= 8.13.3743
+DISTVERSIONPREFIX= 10-
+DISTVERSION= 11.0.0
CATEGORIES= graphics
MAINTAINER= jbeich@FreeBSD.org
diff --git a/graphics/glslang/distinfo b/graphics/glslang/distinfo
index ecbf75e7546f..2aa7b1e301e7 100644
--- a/graphics/glslang/distinfo
+++ b/graphics/glslang/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1589409209
-SHA256 (KhronosGroup-glslang-8.13.3743_GH0.tar.gz) = 639ebec56f1a7402f2fa094469a5ddea1eceecfaf2e9efe361376a0f73a7ee2f
-SIZE (KhronosGroup-glslang-8.13.3743_GH0.tar.gz) = 3183453
+TIMESTAMP = 1603744150
+SHA256 (KhronosGroup-glslang-10-11.0.0_GH0.tar.gz) = 30c12243574d38407d137ea4581743732b893c8246b687e589bf5a6b02e83172
+SIZE (KhronosGroup-glslang-10-11.0.0_GH0.tar.gz) = 3246205
diff --git a/graphics/glslang/pkg-plist b/graphics/glslang/pkg-plist
index ec57fa1f7965..d78a8df97e5f 100644
--- a/graphics/glslang/pkg-plist
+++ b/graphics/glslang/pkg-plist
@@ -1,22 +1,13 @@
bin/glslangValidator
bin/spirv-remap
-include/SPIRV/GLSL.ext.AMD.h
-include/SPIRV/GLSL.ext.EXT.h
-include/SPIRV/GLSL.ext.KHR.h
-include/SPIRV/GLSL.ext.NV.h
-include/SPIRV/GLSL.std.450.h
-include/SPIRV/GlslangToSpv.h
-include/SPIRV/Logger.h
-include/SPIRV/NonSemanticDebugPrintf.h
-include/SPIRV/SPVRemapper.h
-include/SPIRV/SpvBuilder.h
-include/SPIRV/SpvTools.h
-include/SPIRV/bitutils.h
-include/SPIRV/disassemble.h
-include/SPIRV/doc.h
-include/SPIRV/hex_float.h
-include/SPIRV/spirv.hpp
-include/SPIRV/spvIR.h
+include/glslang/HLSL/hlslAttributes.h
+include/glslang/HLSL/hlslGrammar.h
+include/glslang/HLSL/hlslOpMap.h
+include/glslang/HLSL/hlslParseHelper.h
+include/glslang/HLSL/hlslParseables.h
+include/glslang/HLSL/hlslScanContext.h
+include/glslang/HLSL/hlslTokenStream.h
+include/glslang/HLSL/hlslTokens.h
include/glslang/Include/BaseTypes.h
include/glslang/Include/Common.h
include/glslang/Include/ConstantUnion.h
@@ -30,7 +21,6 @@ include/glslang/Include/arrays.h
include/glslang/Include/glslang_c_interface.h
include/glslang/Include/glslang_c_shader_types.h
include/glslang/Include/intermediate.h
-include/glslang/Include/revision.h
include/glslang/MachineIndependent/Initialize.h
include/glslang/MachineIndependent/LiveTraverser.h
include/glslang/MachineIndependent/ParseHelper.h
@@ -67,6 +57,7 @@ include/glslang/SPIRV/doc.h
include/glslang/SPIRV/hex_float.h
include/glslang/SPIRV/spirv.hpp
include/glslang/SPIRV/spvIR.h
+include/glslang/build_info.h
lib/cmake/HLSLTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/HLSLTargets.cmake
lib/cmake/OGLCompilerTargets-%%CMAKE_BUILD_TYPE%%.cmake
@@ -83,7 +74,9 @@ lib/cmake/glslangValidatorTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/glslangValidatorTargets.cmake
lib/cmake/spirv-remapTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/spirv-remapTargets.cmake
+lib/libGenericCodeGen.a
lib/libHLSL.a
+lib/libMachineIndependent.a
lib/libOGLCompiler.a
lib/libOSDependent.a
lib/libSPIRV.a