aboutsummaryrefslogtreecommitdiff
path: root/graphics/gltt/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-08-16 16:55:57 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-08-16 16:55:57 +0000
commit2249e260d25f5c20d86d0686a4967cbeddd40fbf (patch)
treeaf402868960cc712866ab9a2e3a72a06b4c65a9a /graphics/gltt/Makefile
parente1e0fcca3ed0cc668a0bd28d0e936494c2a82345 (diff)
downloadports-2249e260d25f5c20d86d0686a4967cbeddd40fbf.tar.gz
ports-2249e260d25f5c20d86d0686a4967cbeddd40fbf.zip
Notes
Diffstat (limited to 'graphics/gltt/Makefile')
-rw-r--r--graphics/gltt/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/graphics/gltt/Makefile b/graphics/gltt/Makefile
index 0426412054cc..8d12024ce107 100644
--- a/graphics/gltt/Makefile
+++ b/graphics/gltt/Makefile
@@ -7,28 +7,27 @@
PORTNAME= gltt
PORTVERSION= 2.5.2
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://gltt.sourceforge.net/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= TrueType fonts rendering using OpenGL
-LIB_DEPENDS= ttf.4:${PORTSDIR}/print/freetype
-
-USE_GMAKE= yes
-USE_MESA= yes
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} \
- --x-includes=${X11BASE}/include \
- --x-libraries=${X11BASE}/lib \
- --with-ttf-includes=${LOCALBASE}/include/freetype1 \
+USE_MESA= yes
+USE_FREETYPE= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
+ LIBS="-L${X11BASE}/lib"
+CONFIGURE_ARGS= --with-ttf-includes=${LOCALBASE}/include/freetype1 \
--with-ttf-libraries=${LOCALBASE}/lib \
--with-gl-includes=${X11BASE}/include \
--with-gl-libraries=${X11BASE}/lib \
--with-glut-includes=${X11BASE}/include \
--with-glut-libraries=${X11BASE}/lib
-CONFIGURE_ENV= CPPFLAGS=-I${X11BASE}/include
INSTALLS_SHLIB= yes
.include <bsd.port.mk>