aboutsummaryrefslogtreecommitdiff
path: root/graphics/gltt
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /graphics/gltt
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'graphics/gltt')
-rw-r--r--graphics/gltt/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/graphics/gltt/Makefile b/graphics/gltt/Makefile
index ae6e297460d1..7bbd5619fcd9 100644
--- a/graphics/gltt/Makefile
+++ b/graphics/gltt/Makefile
@@ -7,29 +7,27 @@
PORTNAME= gltt
PORTVERSION= 2.5.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics
MASTER_SITES= http://gltt.sourceforge.net/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= TrueType fonts rendering using OpenGL
-LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
-
USE_AUTOTOOLS= libtool:15
-USE_X_PREFIX= yes
+USE_GL= gl glut
USE_FREETYPE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
- LIBS="-L${X11BASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-ttf-includes=${LOCALBASE}/include/freetype1 \
--with-ttf-libraries=${LOCALBASE}/lib \
- --with-gl-includes=${X11BASE}/include \
- --with-gl-libraries=${X11BASE}/lib \
- --with-glut-includes=${X11BASE}/include \
- --with-glut-libraries=${X11BASE}/lib
+ --with-gl-includes=${LOCALBASE}/include \
+ --with-gl-libraries=${LOCALBASE}/lib \
+ --with-glut-includes=${LOCALBASE}/include \
+ --with-glut-libraries=${LOCALBASE}/lib
USE_LDCONFIG= yes
.include <bsd.port.mk>