aboutsummaryrefslogtreecommitdiff
path: root/graphics/gmic-qt
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-10-29 09:20:57 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-10-29 09:20:57 +0000
commit62a9d645c84c377090425788aa428646ed3c4eed (patch)
treed12bca818bc5f63eebd6a1aa449ed3e546f9c1a5 /graphics/gmic-qt
parent627a084eeab0c735fcde7d04750d7d4f7774d08d (diff)
downloadports-62a9d645c84c377090425788aa428646ed3c4eed.tar.gz
ports-62a9d645c84c377090425788aa428646ed3c4eed.zip
New port: graphics/gmic-qt
GMIC filters for future versions of graphics/krita. Reviewed by: mat, adridg Differential Revision: https://reviews.freebsd.org/D12549
Notes
Notes: svn path=/head/; revision=453103
Diffstat (limited to 'graphics/gmic-qt')
-rw-r--r--graphics/gmic-qt/Makefile48
-rw-r--r--graphics/gmic-qt/distinfo9
-rw-r--r--graphics/gmic-qt/files/patch-CMakeLists.txt27
-rw-r--r--graphics/gmic-qt/pkg-descr4
-rw-r--r--graphics/gmic-qt/pkg-plist14
5 files changed, 102 insertions, 0 deletions
diff --git a/graphics/gmic-qt/Makefile b/graphics/gmic-qt/Makefile
new file mode 100644
index 000000000000..37926d0d20ea
--- /dev/null
+++ b/graphics/gmic-qt/Makefile
@@ -0,0 +1,48 @@
+# $FreeBSD$
+
+PORTNAME= gmic-qt
+DISTVERSIONPREFIX= v.
+DISTVERSION= 204
+CATEGORIES= graphics kde
+MASTER_SITES= http://gmic.eu/:stdlib \
+ LOCAL/tcberner/${PORTNAME}/${PORTVERSION}:stdlib
+DISTFILES= gmic_stdlib.h:stdlib
+DIST_SUBDIR= KDE/${PORTNAME}
+EXTRACT_ONLY= ${DISTNAME}.tar.gz ${DISTFILE_gmic} ${DISTFILE_cimg}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Versatile Qt front-end to GMIC
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libfftw3.so:math/fftw3 \
+ libpng.so:graphics/png
+
+USES= cmake:outsource pkgconfig
+USE_QT5= core gui network widgets \
+ buildtools_build linguisttools_build qmake_build
+USE_XORG= ice sm x11 xext
+
+# Use the extracted cimg/gmic & Co, as we do not want to depend on graphics/gimp
+# which would get pulled in by graphics/cimg.
+CMAKE_ARGS= -DGMIC_QT_HOST:STRING="krita" \
+ -DGMIC_PATH:STRING="${WRKSRC_gmic}/src"
+
+USE_GITHUB= yes
+GH_ACCOUNT= c-koi
+GH_TUPLE= dtschump:gmic:${DISTVERSIONFULL}:gmic \
+ dtschump:cimg:${DISTVERSIONFULL}:cimg
+
+pre-configure:
+# Copy the necessary files
+ ${CP} ${WRKDIR}/CImg-${DISTVERSIONFULL}/CImg.h ${WRKSRC_gmic}/src
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/gmic_stdlib.h ${WRKSRC_gmic}/src
+
+do-install:
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/gmic_krita_qt ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DATADIR}/translations
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/*.qm ${STAGEDIR}${DATADIR}/translations/
+
+.include <bsd.port.mk>
diff --git a/graphics/gmic-qt/distinfo b/graphics/gmic-qt/distinfo
new file mode 100644
index 000000000000..af535d39c495
--- /dev/null
+++ b/graphics/gmic-qt/distinfo
@@ -0,0 +1,9 @@
+TIMESTAMP = 1509037058
+SHA256 (KDE/gmic-qt/gmic_stdlib.h) = 127f10099f86ee97a87571c6f4372cc419171b3cb139396e1189739911fcb865
+SIZE (KDE/gmic-qt/gmic_stdlib.h) = 3041437
+SHA256 (KDE/gmic-qt/c-koi-gmic-qt-v.204_GH0.tar.gz) = cd4170adbe916802e8ced03b6e63dea5ba9bf26a1e29e01cebf07a4001d1a126
+SIZE (KDE/gmic-qt/c-koi-gmic-qt-v.204_GH0.tar.gz) = 313433
+SHA256 (KDE/gmic-qt/dtschump-gmic-v.204_GH0.tar.gz) = 2a99e457b764bc843aa4d67d22842e0af6567934604ba9c3e3cf9dd9bbe381b4
+SIZE (KDE/gmic-qt/dtschump-gmic-v.204_GH0.tar.gz) = 37274742
+SHA256 (KDE/gmic-qt/dtschump-cimg-v.204_GH0.tar.gz) = 1663e1710f50b412bcaeeaf59725723d042b63242eaee8503e5cd13e28976dd3
+SIZE (KDE/gmic-qt/dtschump-cimg-v.204_GH0.tar.gz) = 11028464
diff --git a/graphics/gmic-qt/files/patch-CMakeLists.txt b/graphics/gmic-qt/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..50a624b14c23
--- /dev/null
+++ b/graphics/gmic-qt/files/patch-CMakeLists.txt
@@ -0,0 +1,27 @@
+--- CMakeLists.txt.orig 2017-09-18 13:15:50 UTC
++++ CMakeLists.txt
+@@ -139,9 +139,10 @@ if (UNIX AND NOT APPLE)
+ add_definitions(-D_IS_LINUX_)
+ add_definitions(-Dcimg_use_vt100)
+ add_definitions(-D_IS_UNIX_)
++ find_package(X11)
+ set(gmic_qt_LIBRARIES
+ ${gmic_qt_LIBRARIES}
+- X11 # XXX: Search for X11: Wayland is coming!
++ ${X11_LIBRARIES} # XXX: Search for X11: Wayland is coming!
+ )
+
+ endif()
+@@ -162,6 +163,12 @@ if (WIN32)
+ pthread psapi gdi32
+ )
+ endif()
++
++find_package(Threads)
++set(gmic_qt_LIBRARIES
++ ${gmic_qt_LIBRARIES}
++ Threads::Threads
++)
+
+ if (NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE "Release")
diff --git a/graphics/gmic-qt/pkg-descr b/graphics/gmic-qt/pkg-descr
new file mode 100644
index 000000000000..f90d9fe6423f
--- /dev/null
+++ b/graphics/gmic-qt/pkg-descr
@@ -0,0 +1,4 @@
+G'MIC-Qt is a versatile front-end to the image processing framework G'MIC.
+It is in fact a plugin for GIMP, as well as a standalone application.
+
+WWW: https://github.com/c-koi/gmic-qt
diff --git a/graphics/gmic-qt/pkg-plist b/graphics/gmic-qt/pkg-plist
new file mode 100644
index 000000000000..e8a010ac0fc0
--- /dev/null
+++ b/graphics/gmic-qt/pkg-plist
@@ -0,0 +1,14 @@
+bin/gmic_krita_qt
+%%DATADIR%%/translations/cs.qm
+%%DATADIR%%/translations/de.qm
+%%DATADIR%%/translations/es.qm
+%%DATADIR%%/translations/fr.qm
+%%DATADIR%%/translations/id.qm
+%%DATADIR%%/translations/it.qm
+%%DATADIR%%/translations/ja.qm
+%%DATADIR%%/translations/nl.qm
+%%DATADIR%%/translations/pl.qm
+%%DATADIR%%/translations/pt.qm
+%%DATADIR%%/translations/ru.qm
+%%DATADIR%%/translations/ua.qm
+%%DATADIR%%/translations/zh.qm