aboutsummaryrefslogtreecommitdiff
path: root/graphics/gmic
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-12-26 07:39:07 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-12-26 07:39:07 +0000
commita67f3f35a3078187a2ab3b4163d501c43cabbb66 (patch)
treeb274afcf47c12e1636954dfc54569a65b23e89c7 /graphics/gmic
parent804d2050820a9639f5a5c8a55b61c8d6a8a7266b (diff)
downloadports-a67f3f35a3078187a2ab3b4163d501c43cabbb66.tar.gz
ports-a67f3f35a3078187a2ab3b4163d501c43cabbb66.zip
graphics/gmic: Fix build by adding the devel/openmp dependency
Reported by: fallout
Notes
Notes: svn path=/head/; revision=520893
Diffstat (limited to 'graphics/gmic')
-rw-r--r--graphics/gmic/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/graphics/gmic/Makefile b/graphics/gmic/Makefile
index 4c24df4bb227..5726337d4900 100644
--- a/graphics/gmic/Makefile
+++ b/graphics/gmic/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gmic
DISTVERSION= 2.8.1
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= https://gmic.eu/files/source/
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -16,7 +17,6 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BROKEN_i386= error: "c++ crashes, clang-5 and 6 fail: undefined reference to `__atomic_load'"
-BUILD_DEPENDS= ${LOCALBASE}/include/CImg.h:graphics/cimg
LIB_DEPENDS= libfftw3.so:math/fftw3 \
libGraphicsMagick++.so:graphics/GraphicsMagick \
libIlmImf.so:graphics/openexr \
@@ -55,4 +55,11 @@ X11_CMAKE_BOOL= ENABLE_X
X11_USES= xorg
X11_USE= XORG=ice,sm,x11,xext
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# XXX Drop after FreeBSD 12.0 EOL
+.if ${CHOSEN_COMPILER_TYPE} == clang && !exists(/usr/include/omp.h)
+LIB_DEPENDS+= libomp.so:devel/openmp
+.endif
+
+.include <bsd.port.post.mk>