aboutsummaryrefslogtreecommitdiff
path: root/graphics/gnash
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2017-02-09 08:57:26 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2017-02-09 08:57:26 +0000
commit3b224e8fc73df6b4838708c8206b26f80270c0b0 (patch)
tree75dc84e3ea208c5a2e5b0f7edca8c478b3ab0312 /graphics/gnash
parent8dba87b4b30ced89ea2cf2e196076e9f9e35c184 (diff)
downloadports-3b224e8fc73df6b4838708c8206b26f80270c0b0.tar.gz
ports-3b224e8fc73df6b4838708c8206b26f80270c0b0.zip
- make portlint happier
Notes
Notes: svn path=/head/; revision=433713
Diffstat (limited to 'graphics/gnash')
-rw-r--r--graphics/gnash/Makefile2
-rw-r--r--graphics/gnash/files/patch-Makefile.am6
-rw-r--r--graphics/gnash/files/patch-configure.ac8
-rw-r--r--graphics/gnash/files/patch-gui-gtk-gtk_canvas.cpp4
-rw-r--r--graphics/gnash/files/patch-libbase-Makefile.am (renamed from graphics/gnash/files/patch-libbase_Makefile.am)8
-rw-r--r--graphics/gnash/files/patch-libcore-movie_root.cpp (renamed from graphics/gnash/files/patch-libcore_movie__root.cpp)4
-rw-r--r--graphics/gnash/files/patch-libdevice-vaapi-VaapiSurface.cpp (renamed from graphics/gnash/files/patch-libdevice_vaapi_VaapiSurface.cpp)6
-rw-r--r--graphics/gnash/files/patch-libmedia-ffmpeg-VideoDecoderFfmpeg.cpp (renamed from graphics/gnash/files/patch-libmedia_ffmpeg_VideoDecoderFfmpeg.cpp)6
-rw-r--r--graphics/gnash/files/patch-plugin-klash-klash_part.cpp6
-rw-r--r--graphics/gnash/files/patch-plugin-klash4-klash_part.cpp6
-rw-r--r--graphics/gnash/pkg-descr22
11 files changed, 32 insertions, 46 deletions
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index 91003546a877..145113aa57d5 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -185,7 +185,7 @@ CONFIGURE_ARGS+= --enable-renderer=${GNASH_RENDERERS:S/^ //W:S/ /,/gW}
#
.if ${PORT_OPTIONS:MVAAPI}
.if empty(PORT_OPTIONS:MFFMPEG)
-IGNORE= VAAPI currently works only with FFMPEG. Please rerun 'make config' and enable FFMPEG
+IGNORE= option VAAPI currently works only with FFMPEG. Please rerun 'make config' and enable FFMPEG
.endif
LIB_DEPENDS+= libva.so:multimedia/libva
CONFIGURE_ARGS+= --enable-device=egl,x11,vaapi
diff --git a/graphics/gnash/files/patch-Makefile.am b/graphics/gnash/files/patch-Makefile.am
index 00267e2b94d0..8ecbc1352de7 100644
--- a/graphics/gnash/files/patch-Makefile.am
+++ b/graphics/gnash/files/patch-Makefile.am
@@ -1,6 +1,6 @@
---- Makefile.am.orig 2016-07-21 14:25:09.000000000 +0200
-+++ Makefile.am 2016-12-13 10:23:36.939767000 +0100
-@@ -512,7 +512,7 @@
+--- Makefile.am.orig 2016-07-21 12:25:09 UTC
++++ Makefile.am
+@@ -512,7 +512,7 @@ install-plugins install-plugin uninstall
apidoc:
$(MAKE) -C doc $@
diff --git a/graphics/gnash/files/patch-configure.ac b/graphics/gnash/files/patch-configure.ac
index fda056143baf..e07ab86b66e9 100644
--- a/graphics/gnash/files/patch-configure.ac
+++ b/graphics/gnash/files/patch-configure.ac
@@ -1,6 +1,6 @@
---- configure.ac.orig 2016-07-21 14:25:09.000000000 +0200
-+++ configure.ac 2016-12-13 08:41:26.852652000 +0100
-@@ -4144,7 +4144,7 @@
+--- configure.ac.orig 2016-07-21 12:25:09 UTC
++++ configure.ac
+@@ -4144,7 +4144,7 @@ if test x${build_ssl} = xyes; then
fi
echo " SSL libs are: $SSL_LIBS"
else
@@ -9,7 +9,7 @@
fi
fi
-@@ -4157,7 +4157,7 @@
+@@ -4157,7 +4157,7 @@ if test x${build_ssh} = xyes; then
fi
echo " SSH libs are: $SSH_LIBS"
else
diff --git a/graphics/gnash/files/patch-gui-gtk-gtk_canvas.cpp b/graphics/gnash/files/patch-gui-gtk-gtk_canvas.cpp
index d4517c7eaa05..b6dc165f05bb 100644
--- a/graphics/gnash/files/patch-gui-gtk-gtk_canvas.cpp
+++ b/graphics/gnash/files/patch-gui-gtk-gtk_canvas.cpp
@@ -1,6 +1,6 @@
---- gui/gtk/gtk_canvas.cpp.orig 2012-01-19 19:17:48 UTC
+--- gui/gtk/gtk_canvas.cpp.orig 2016-07-21 12:25:09 UTC
+++ gui/gtk/gtk_canvas.cpp
-@@ -212,7 +212,7 @@ gnash_canvas_setup(GnashCanvas *canvas,
+@@ -211,7 +211,7 @@ gnash_canvas_setup(GnashCanvas *canvas,
renderer = "agg";
#elif defined (RENDERER_CAIRO)
renderer = "cairo";
diff --git a/graphics/gnash/files/patch-libbase_Makefile.am b/graphics/gnash/files/patch-libbase-Makefile.am
index b1e893b73a0a..90e2e60819e2 100644
--- a/graphics/gnash/files/patch-libbase_Makefile.am
+++ b/graphics/gnash/files/patch-libbase-Makefile.am
@@ -1,6 +1,6 @@
---- libbase/Makefile.am.orig 2016-07-21 14:25:09.000000000 +0200
-+++ libbase/Makefile.am 2016-12-13 22:20:48.980088000 +0100
-@@ -135,6 +135,7 @@
+--- libbase/Makefile.am.orig 2016-07-21 12:25:09 UTC
++++ libbase/Makefile.am
+@@ -135,6 +135,7 @@ libgnashbase_la_SOURCES += \
endif
if HAVE_VAAPI
@@ -8,7 +8,7 @@
libgnashbase_la_SOURCES += \
GnashVaapiImage.cpp \
GnashVaapiImage.h \
-@@ -143,6 +144,14 @@
+@@ -143,6 +144,14 @@ libgnashbase_la_SOURCES += \
GnashVaapiTexture.h \
$(NULL)
diff --git a/graphics/gnash/files/patch-libcore_movie__root.cpp b/graphics/gnash/files/patch-libcore-movie_root.cpp
index 97970208e37a..757c19bbb4e7 100644
--- a/graphics/gnash/files/patch-libcore_movie__root.cpp
+++ b/graphics/gnash/files/patch-libcore-movie_root.cpp
@@ -1,6 +1,4 @@
-$NetBSD: patch-libcore_movie__root.cpp,v 1.1 2013/02/26 11:04:25 joerg Exp $
-
---- libcore/movie_root.cpp.orig 2013-02-25 18:54:08.000000000 +0000
+--- libcore/movie_root.cpp.orig 2016-07-21 12:25:09 UTC
+++ libcore/movie_root.cpp
@@ -156,7 +156,7 @@ movie_root::movie_root(VirtualClock& clo
_hostfd(-1),
diff --git a/graphics/gnash/files/patch-libdevice_vaapi_VaapiSurface.cpp b/graphics/gnash/files/patch-libdevice-vaapi-VaapiSurface.cpp
index 61c91730ff92..5fa7ef65bde2 100644
--- a/graphics/gnash/files/patch-libdevice_vaapi_VaapiSurface.cpp
+++ b/graphics/gnash/files/patch-libdevice-vaapi-VaapiSurface.cpp
@@ -1,6 +1,6 @@
---- libdevice/vaapi/VaapiSurface.cpp.orig 2012-01-19 20:17:48.000000000 +0100
-+++ libdevice/vaapi/VaapiSurface.cpp 2013-07-05 01:44:21.927681308 +0200
-@@ -62,8 +62,8 @@
+--- libdevice/vaapi/VaapiSurface.cpp.orig 2016-07-21 12:25:09 UTC
++++ libdevice/vaapi/VaapiSurface.cpp
+@@ -62,8 +62,8 @@ public:
VAStatus status;
VASurfaceID surface_id;
status = vaCreateSurfaces(gvactx->display(),
diff --git a/graphics/gnash/files/patch-libmedia_ffmpeg_VideoDecoderFfmpeg.cpp b/graphics/gnash/files/patch-libmedia-ffmpeg-VideoDecoderFfmpeg.cpp
index 938c2bab6d82..cc739526a9a2 100644
--- a/graphics/gnash/files/patch-libmedia_ffmpeg_VideoDecoderFfmpeg.cpp
+++ b/graphics/gnash/files/patch-libmedia-ffmpeg-VideoDecoderFfmpeg.cpp
@@ -1,6 +1,6 @@
---- libmedia/ffmpeg/VideoDecoderFfmpeg.cpp.orig 2016-07-21 14:25:09.000000000 +0200
-+++ libmedia/ffmpeg/VideoDecoderFfmpeg.cpp 2016-12-13 21:47:28.602555000 +0100
-@@ -544,7 +544,9 @@
+--- libmedia/ffmpeg/VideoDecoderFfmpeg.cpp.orig 2016-07-21 12:25:09 UTC
++++ libmedia/ffmpeg/VideoDecoderFfmpeg.cpp
+@@ -544,7 +544,9 @@ get_buffer(AVCodecContext* avctx, AVFram
vaapi_set_surface(pic, surface);
static unsigned int pic_num = 0;
diff --git a/graphics/gnash/files/patch-plugin-klash-klash_part.cpp b/graphics/gnash/files/patch-plugin-klash-klash_part.cpp
index 704948946b40..1d54ff4c1538 100644
--- a/graphics/gnash/files/patch-plugin-klash-klash_part.cpp
+++ b/graphics/gnash/files/patch-plugin-klash-klash_part.cpp
@@ -1,6 +1,6 @@
---- plugin/klash/klash_part.cpp.orig 2011-06-16 18:54:16.833252653 -0400
-+++ plugin/klash/klash_part.cpp 2011-06-16 18:54:56.913835639 -0400
-@@ -161,7 +161,7 @@
+--- plugin/klash/klash_part.cpp.orig 2016-07-21 12:25:09 UTC
++++ plugin/klash/klash_part.cpp
+@@ -160,7 +160,7 @@ KDE_NO_EXPORT void KlashPart::play ()
QString procname;
char *gnash_env = getenv("KLASH_PLAYER");
if (!gnash_env) {
diff --git a/graphics/gnash/files/patch-plugin-klash4-klash_part.cpp b/graphics/gnash/files/patch-plugin-klash4-klash_part.cpp
index d896220545eb..3b2eb3d2cfc1 100644
--- a/graphics/gnash/files/patch-plugin-klash4-klash_part.cpp
+++ b/graphics/gnash/files/patch-plugin-klash4-klash_part.cpp
@@ -1,6 +1,6 @@
---- plugin/klash4/klash_part.cpp.orig 2011-06-16 18:56:30.869545798 -0400
-+++ plugin/klash4/klash_part.cpp 2011-06-16 18:57:04.979892841 -0400
-@@ -148,7 +148,7 @@
+--- plugin/klash4/klash_part.cpp.orig 2016-07-21 12:25:09 UTC
++++ plugin/klash4/klash_part.cpp
+@@ -148,7 +148,7 @@ KDE_NO_CDTOR_EXPORT KlashPart::KlashPart
}
}
KParts::Part::setWidget (new KlashView (wparent));
diff --git a/graphics/gnash/pkg-descr b/graphics/gnash/pkg-descr
index 8e9c07ebcc3c..27ca35c463ad 100644
--- a/graphics/gnash/pkg-descr
+++ b/graphics/gnash/pkg-descr
@@ -3,31 +3,19 @@ to play flash movies with proprietary software. While there are
some other free flash players, none support anything beyond SWF v4.
Gnash is based on GameSWF, and supports many SWF v7 features.
-- Runs standalone
- Gnash can run standalone to play flash movies.
-- Browser plugin
- Gnash can also run as a plugin from within most Mozilla derived
+- Gnash can run standalone to play flash movies.
+- Gnash can also run as a plugin from within most Mozilla derived
browsers, such as Firefox. Gnash also has support for Konqueror.
- SWF v7+ compliant
Gnash can play many current flash movies.
-- Streaming Video
- Gnash supports the viewing of streaming video from popular video
+- Gnash supports the viewing of streaming video from popular video
sharing sites like Lulu.tv or YouTube.com.
-- XML Message server
- Gnash also supports an XML based message system as documented in
+- Gnash also supports an XML based message system as documented in
the Flash Format specification.
- High Quality Output
Gnash uses OpenGL for rendering the graphics on the desktop, and
AntiGrain (AGG) for embedded framebuffer only devices.
-- Free Software
- Gnash is 100% free software. For more information on the GPL, go
- to the Free Software Foundation web site.
-- Better Security
- Gnash pays extra attention to all network connections, and allows
+- Gnash pays extra attention to all network connections, and allows
the user to control access.
-- Extensible
- Gnash supports extending ActionScript by creating your own. You
- can write wrappers for any development library, and import them
- into the player.
WWW: http://www.gnu.org/software/gnash/