aboutsummaryrefslogtreecommitdiff
path: root/graphics/gnash
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2021-02-07 20:14:23 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2021-02-07 20:14:23 +0000
commit614dd8eda53061898c8b07e4de282d103a7126ba (patch)
treea4025a9500f79f94944f159e54834bc9957bf408 /graphics/gnash
parentc31a5b8e4cce4c4717cf0304a51cf05b19fe8661 (diff)
downloadports-614dd8eda53061898c8b07e4de282d103a7126ba.tar.gz
ports-614dd8eda53061898c8b07e4de282d103a7126ba.zip
- fix regression from r563992
- remove option FFMPEG
Notes
Notes: svn path=/head/; revision=564644
Diffstat (limited to 'graphics/gnash')
-rw-r--r--graphics/gnash/Makefile50
-rw-r--r--graphics/gnash/pkg-plist2
2 files changed, 19 insertions, 33 deletions
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index a279ccb1215f..1a32043e8e09 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnash
PORTVERSION= 0.8.10
-PORTREVISION= 45
+PORTREVISION= 46
CATEGORIES= graphics
MASTER_SITES= http://git.savannah.gnu.org/cgit/gnash.git/snapshot/
DISTNAME= gnash-2b3bdede0305c4fc3ad21a0a4197330606c9b880
@@ -22,22 +22,29 @@ LIB_DEPENDS= libltdl.so:devel/libltdl \
libspeexdsp.so:audio/speexdsp \
libboost_thread.so:devel/boost-libs \
libfreetype.so:print/freetype2 \
- libfontconfig.so:x11-fonts/fontconfig
+ libfontconfig.so:x11-fonts/fontconfig \
+ libavcodec.so:multimedia/ffmpeg \
+ libtheora.so:multimedia/libtheora \
+ libogg.so:audio/libogg \
+ libvorbis.so:audio/libvorbis \
+ libdca.so:multimedia/libdca \
+ libgsm.so:audio/gsm
CONFLICTS= gnash-devel-[0-9]*
USES= cpe tar:bzip2 compiler:c++11-lang autoreconf gmake libtool \
- pkgconfig jpeg gnome gl desktop-file-utils xorg
+ pkgconfig jpeg gnome gl sdl desktop-file-utils xorg
CPE_VENDOR= gnu
GNU_CONFIGURE= yes
USE_GNOME= atk gconf2 gtk20 libxml2 pango
USE_XORG= x11 xau xdmcp xext xi xinerama ice sm xv
USE_GL= egl
+USE_SDL= sdl
INSTALLS_ICONS= yes
SYSCONFIGDIR= ${PREFIX}/etc
# jemalloc leads to infinite recursion on FreeBSD
-CFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/ffmpeg
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-boost-incl="${LOCALBASE}/include" \
@@ -45,9 +52,13 @@ CONFIGURE_ARGS= --with-boost-incl="${LOCALBASE}/include" \
--with-plugins-install=prefix \
--sysconfdir="${SYSCONFIGDIR}" \
--enable-gui=gtk \
+ --enable-media=ffmpeg \
+ --with-ffmpeg-incl=${LOCALBASE}/include/libavcodec \
+ --with-ffmpeg-lib=${LOCALBASE}/lib \
--disable-testsuite \
--disable-kparts3 \
--disable-jemalloc
+#MAKE_ARGS+= INCLUDES="-I${LOCALBASE}/include/ffmpeg"
GNASHVER= 0.8.11dev
CONFIG_FILES= gnashpluginrc gnashrc
@@ -57,10 +68,10 @@ PLIST_SUB+= GNASHVER="${GNASHVER}"
USE_LDCONFIG= ${PREFIX}/lib/gnash
-OPTIONS_DEFINE= CYGNAL VAAPI DOCS NLS FFMPEG
-OPTIONS_SINGLE= RENDERER
+OPTIONS_DEFINE= CYGNAL VAAPI DOCS NLS
+OPTIONS_SINGLE= MEDIA RENDERER
OPTIONS_SINGLE_RENDERER=AGG OPENGL CAIRO
-OPTIONS_DEFAULT=AGG FFMPEG VAAPI
+OPTIONS_DEFAULT=AGG VAAPI
NO_OPTIONS_SORT=yes
OPTIONS_SUB= yes
@@ -68,8 +79,7 @@ CYGNAL_DESC= Cygnal media server
AGG_DESC= AGG renderer
OPENGL_DESC= OpenGL renderer (experimental)
CAIRO_DESC= Cairo renderer
-FFMPEG_DESC= ffmpeg media handler
-VAAPI_DESC= VAAPI support (requires FFMPEG)
+VAAPI_DESC= VAAPI support
CYGNAL_CONFIGURE_ENABLE= cygnal
@@ -125,9 +135,6 @@ CONFIGURE_ARGS+= --enable-renderer=${GNASH_RENDERERS:S/^ //W:S/ /,/gW}
# Hardware acceleration options processing
#
.if ${PORT_OPTIONS:MVAAPI}
-.if empty(PORT_OPTIONS:MFFMPEG)
-IGNORE= option VAAPI currently works only with FFMPEG. Please rerun 'make config' and enable FFMPEG
-.endif
LIB_DEPENDS+= libva.so:multimedia/libva
CONFIGURE_ARGS+= --enable-device=egl,x11,vaapi
.else
@@ -135,25 +142,6 @@ CONFIGURE_ARGS+= --enable-hwaccel=none # XVideo
CONFIGURE_ARGS+= --enable-device=egl,x11
.endif
-#
-# Media handler options processing
-#
-.if ${PORT_OPTIONS:MFFMPEG}
-LIB_DEPENDS+= libavcodec.so:multimedia/ffmpeg \
- libtheora.so:multimedia/libtheora \
- libogg.so:audio/libogg \
- libvorbis.so:audio/libvorbis
-CONFIGURE_ARGS+= --enable-media=ffmpeg \
- --with-ffmpeg-incl=${LOCALBASE}/include/libavcodec \
- --with-ffmpeg-lib=${LOCALBASE}/lib
-USES+= sdl
-USE_SDL+= sdl
-MAKE_ARGS+= INCLUDES="-I${LOCALBASE}/include/ffmpeg"
-.else
-CONFIGURE_ARGS+= --enable-media=none
-IGNORE= can't be built with multiple media handlers enabled. Please rerun 'make config' and leave one or none of them (ffmpeg|gstreamer)
-.endif
-
.include <bsd.port.pre.mk>
post-patch:
diff --git a/graphics/gnash/pkg-plist b/graphics/gnash/pkg-plist
index 22d28228eaa8..0d67297b8c3e 100644
--- a/graphics/gnash/pkg-plist
+++ b/graphics/gnash/pkg-plist
@@ -4,8 +4,6 @@ bin/gnash-gtk-launcher
bin/gtk-gnash
bin/gprocessor
bin/rtmpget
-%%GSTREAMER%%bin/findmicrophones
-%%GSTREAMER%%bin/findwebcams
%%CYGNAL%%bin/cygnal
%%CYGNAL%%bin/flvdumper
%%CYGNAL%%bin/soldumper