aboutsummaryrefslogtreecommitdiff
path: root/graphics/gnash
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-10-26 08:23:57 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-10-26 08:23:57 +0000
commite63a4c07594501d61d6ffa6ef72aeb45e306c506 (patch)
tree3c528ccf6b3e48c3631ba0e2eb374ca8a026009b /graphics/gnash
parent530485b495451590d3f0efb337f572f80468b715 (diff)
downloadports-e63a4c07594501d61d6ffa6ef72aeb45e306c506.tar.gz
ports-e63a4c07594501d61d6ffa6ef72aeb45e306c506.zip
Notes
Diffstat (limited to 'graphics/gnash')
-rw-r--r--graphics/gnash/Makefile29
-rw-r--r--graphics/gnash/files/ffmpeg0.patch102
-rw-r--r--graphics/gnash/files/patch-configure100
3 files changed, 121 insertions, 110 deletions
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index 8fe513ee0b54..324c0dbc995e 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnash
PORTVERSION= 0.8.10
-PORTREVISION= 8
+PORTREVISION= 7
CATEGORIES= graphics
MASTER_SITES= GNU/${PORTNAME}/${PORTVERSION}/
@@ -54,12 +54,12 @@ MAN1= cygnal.1 findmicrophones.1 findwebcams.1 \
flvdumper.1 gnash.1 gprocessor.1 \
rtmpget.1 soldumper.1
-OPTIONS_DEFINE= PLUGIN CYGNAL VAAPI FFMPEG GSTREAMER
-OPTIONS_SINGLE= GUI RENDERER
+OPTIONS_DEFINE= PLUGIN CYGNAL VAAPI
+OPTIONS_SINGLE= MEDIA GUI RENDERER
+OPTIONS_SINGLE_MEDIA= FFMPEG FFMPEG2 GSTREAMER
OPTIONS_SINGLE_GUI= GTK2 KDE4
OPTIONS_SINGLE_RENDERER=AGG OPENGL CAIRO
-#OPTIONS_SINGLE_MEDIA= FFMPEG GSTREAMER
-OPTIONS_DEFAULT=GTK2 PLUGIN AGG FFMPEG VAAPI
+OPTIONS_DEFAULT=GTK2 PLUGIN AGG FFMPEG2 VAAPI
NO_OPTIONS_SORT=yes
PLUGIN_DESC= browser plugin
@@ -67,7 +67,8 @@ CYGNAL_DESC= Cygnal media server
AGG_DESC= AGG renderer
OPENGL_DESC= OpenGL renderer (broken)
CAIRO_DESC= Cairo renderer (experimental)
-FFMPEG_DESC= ffmpeg media handler
+FFMPEG_DESC= ffmpeg0 media handler
+FFMPEG2_DESC= ffmpeg2 media handler
GSTREAMER_DESC= GStreamer media handler
VAAPI_DESC= VAAPI support (requires FFMPEG)
@@ -185,7 +186,7 @@ CONFIGURE_ARGS+= --enable-renderer=`${ECHO} ${GNASH_RENDERERS} | ${TR} ' ' ,`
# Hardware acceleration options processing
#
.if ${PORT_OPTIONS:MVAAPI}
-.if empty(PORT_OPTIONS:MFFMPEG)
+.if empty(PORT_OPTIONS:MFFMPEG) && empty(PORT_OPTIONS:MFFMPEG2)
IGNORE= VAAPI currently works only with FFMPEG. Please rerun 'make config' and enable FFMPEG
.endif
LIB_DEPENDS+= va:${PORTSDIR}/multimedia/libva
@@ -198,18 +199,26 @@ PLIST_SUB+= VAAPI="@comment "
#
# Media handler options processing
#
-.if ${PORT_OPTIONS:MFFMPEG} && empty(PORT_OPTIONS:MGSTREAMER)
+.if ${PORT_OPTIONS:MFFMPEG2} && empty(PORT_OPTIONS:MFFMPEG) && empty(PORT_OPTIONS:MGSTREAMER)
+LIB_DEPENDS+= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
+CONFIGURE_ARGS+= --enable-media=ffmpeg \
+ --with-ffmpeg-incl=${LOCALBASE}/include \
+ --with-ffmpeg-lib=${LOCALBASE}/lib/ffmpeg
+USE_SDL+= sdl
+MAKE_ARGS+= INCLUDES="-I${LOCALBASE}/include/ffmpeg"
+.elif ${PORT_OPTIONS:MFFMPEG} && empty(PORT_OPTIONS:MFFMPEG2) && empty(PORT_OPTIONS:MGSTREAMER)
+EXTRA_PATCHES+= ${FILESDIR}/ffmpeg0.patch
LIB_DEPENDS+= libavcodec0.so:${PORTSDIR}/multimedia/ffmpeg0
CONFIGURE_ARGS+= --enable-media=ffmpeg \
--with-ffmpeg-incl=${LOCALBASE}/include/ffmpeg0/libavcodec \
--with-ffmpeg-lib=${LOCALBASE}/lib/ffmpeg0
USE_SDL+= sdl
MAKE_ARGS+= INCLUDES="-I${LOCALBASE}/include/ffmpeg0"
-.elif empty(PORT_OPTIONS:MFFMPEG) && ${PORT_OPTIONS:MGSTREAMER}
+.elif ${PORT_OPTIONS:MGSTREAMER} && empty(PORT_OPTIONS:MFFMPEG) && empty(PORT_OPTIONS:MFFMPEG2)
USE_GSTREAMER= yes
CONFIGURE_ARGS+= --enable-media=gst
USE_SDL+= sdl
-.elif empty(PORT_OPTIONS:MFFMPEG) && empty(PORT_OPTIONS:MGSTREAMER)
+.else
CONFIGURE_ARGS+= --enable-media=none
IGNORE= can't be built with multiple media handlers enabled. Please rerun 'make config' and leave one or none of them (ffmpeg|gstreamer)
.endif
diff --git a/graphics/gnash/files/ffmpeg0.patch b/graphics/gnash/files/ffmpeg0.patch
new file mode 100644
index 000000000000..639d25d6b93b
--- /dev/null
+++ b/graphics/gnash/files/ffmpeg0.patch
@@ -0,0 +1,102 @@
+--- configure.orig 2012-01-19 17:19:29.000000000 -0200
++++ configure 2013-10-09 15:07:40.051081546 -0300
+@@ -9336,7 +9336,7 @@
+ if test x${ffmpeg_top_incl} = x; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking location of avcodec.h" >&5
+ $as_echo_n "checking location of avcodec.h... " >&6; }
+- if test x"$PKG_CONFIG" != x; then if $PKG_CONFIG --exists libavcodec; then ffmpeg_pkg=`$PKG_CONFIG --cflags-only-I libavcodec`
++ if test x"$PKG_CONFIG" != x; then if $PKG_CONFIG --exists libavcodec0; then ffmpeg_pkg=`$PKG_CONFIG --cflags-only-I libavcodec0`
+ ffmpeg_top_incl=`echo ${ffmpeg_pkg} | sed -e 's:-I::'`
+ for i in "" ffmpeg libavcodec ffmpeg/libavcodec; do
+ if test -f ${ffmpeg_top_incl}/${i}/avcodec.h; then
+@@ -9568,16 +9568,16 @@
+ else
+
+ if test x"${with_ffmpeg_lib}" != x ; then
+- if test -f ${with_ffmpeg_lib}/libavcodec.a -o -f ${with_ffmpeg_lib}/libavcodec.${shlibext}; then
++ if test -f ${with_ffmpeg_lib}/libavcodec0.a -o -f ${with_ffmpeg_lib}/libavcodec0.${shlibext}; then
+ ac_cv_path_ffmpeg_lib="-L`(cd ${with_ffmpeg_lib}; pwd)`"
+- libavcodec="-lavcodec"
++ libavcodec="-lavcodec0"
+ LIBS="${ac_cv_path_ffmpeg_lib} $LIBS" top_lib_dir=${with_ffmpeg_lib}
+ else
+ as_fn_error "${with_ffmpeg_lib} directory doesn't contain libavcodec libraries." "$LINENO" 5
+ fi
+- if test -f ${with_ffmpeg_lib}/libavformat.a -o -f ${with_ffmpeg_lib}/libavformat.${shlibext}; then
++ if test -f ${with_ffmpeg_lib}/libavformat0.a -o -f ${with_ffmpeg_lib}/libavformat0.${shlibext}; then
+ ac_cv_path_ffmpeg_lib="-L`(cd ${with_ffmpeg_lib}; pwd)`"
+- libavformat="-lavformat"
++ libavformat="-lavformat0"
+ top_lib_dir=${with_ffmpeg_lib}
+ else
+ as_fn_error "${with_ffmpeg_lib} directory doesn't contain libavformat libraries." "$LINENO" 5
+@@ -9869,13 +9869,13 @@
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for libavutil library" >&5
+ $as_echo_n "checking for libavutil library... " >&6; }
+ if test x"$PKG_CONFIG" != x -a x${cross_compiling} = xno; then
+- $PKG_CONFIG --exists libavutil && libavutil=`$PKG_CONFIG --libs-only-l libavutil`
++ $PKG_CONFIG --exists libavutil0 && libavutil=`$PKG_CONFIG --libs-only-l libavutil0`
+ else
+ libavutil=""
+ fi
+ if test x"${libavutil}" = x; then
+- if test -f ${top_lib_dir}/libavutil.a -o -f ${top_lib_dir}/libavutil.${shlibext}; then
+- ac_cv_path_ffmpeg_lib="${ac_cv_path_ffmpeg_lib} -lavutil"
++ if test -f ${top_lib_dir}/libavutil0.a -o -f ${top_lib_dir}/libavutil0.${shlibext}; then
++ ac_cv_path_ffmpeg_lib="${ac_cv_path_ffmpeg_lib} -lavutil0"
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: ${top_lib_dir}/libavutil" >&5
+ $as_echo "${top_lib_dir}/libavutil" >&6; }
+ else
+@@ -9888,7 +9888,7 @@
+ $as_echo_n "(cached) " >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lavutil $LIBS"
++LIBS="-lavutil0 $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -9919,7 +9919,7 @@
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_avutil_av_log" >&5
+ $as_echo "$ac_cv_lib_avutil_av_log" >&6; }
+ if test "x$ac_cv_lib_avutil_av_log" = x""yes; then :
+- ac_cv_path_ffmpeg_lib="${ac_cv_path_ffmpeg_lib} -lavutil"
++ ac_cv_path_ffmpeg_lib="${ac_cv_path_ffmpeg_lib} -lavutil0"
+ fi
+
+ fi
+@@ -10126,13 +10126,13 @@
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for libswscale library" >&5
+ $as_echo_n "checking for libswscale library... " >&6; }
+ if test x"$PKG_CONFIG" != x -a x${cross_compiling} = xno; then
+- $PKG_CONFIG --exists libswscale && libsws=`$PKG_CONFIG --libs-only-l libswscale`
++ $PKG_CONFIG --exists libswscale0 && libsws=`$PKG_CONFIG --libs-only-l libswscale0`
+ else
+ libsws=""
+ fi
+ if test x"${libsws}" = x; then
+- if test -f ${top_lib_dir}/libswscale.a -o -f ${top_lib_dir}/libswscale.${shlibext}; then
+- ac_cv_path_ffmpeg_lib="${ac_cv_path_ffmpeg_lib} -lswscale"
++ if test -f ${top_lib_dir}/libswscale0.a -o -f ${top_lib_dir}/libswscale0.${shlibext}; then
++ ac_cv_path_ffmpeg_lib="${ac_cv_path_ffmpeg_lib} -lswscale0"
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+ $as_echo "yes" >&6; }
+ else
+@@ -10145,7 +10145,7 @@
+ $as_echo_n "(cached) " >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lswscale $LIBS"
++LIBS="-lswscale0 $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -10176,7 +10176,7 @@
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_swscale_sws_scale" >&5
+ $as_echo "$ac_cv_lib_swscale_sws_scale" >&6; }
+ if test "x$ac_cv_lib_swscale_sws_scale" = x""yes; then :
+- ac_cv_path_ffmpeg_lib="${ac_cv_path_ffmpeg_lib} -lswscale"
++ ac_cv_path_ffmpeg_lib="${ac_cv_path_ffmpeg_lib} -lswscale0"
+ fi
+
+ fi
diff --git a/graphics/gnash/files/patch-configure b/graphics/gnash/files/patch-configure
index f9e7a3601cfe..2b0025a6769a 100644
--- a/graphics/gnash/files/patch-configure
+++ b/graphics/gnash/files/patch-configure
@@ -1,105 +1,5 @@
--- configure.orig 2012-01-19 17:19:29.000000000 -0200
+++ configure 2013-10-09 15:07:40.051081546 -0300
-@@ -9336,7 +9336,7 @@
- if test x${ffmpeg_top_incl} = x; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking location of avcodec.h" >&5
- $as_echo_n "checking location of avcodec.h... " >&6; }
-- if test x"$PKG_CONFIG" != x; then if $PKG_CONFIG --exists libavcodec; then ffmpeg_pkg=`$PKG_CONFIG --cflags-only-I libavcodec`
-+ if test x"$PKG_CONFIG" != x; then if $PKG_CONFIG --exists libavcodec0; then ffmpeg_pkg=`$PKG_CONFIG --cflags-only-I libavcodec0`
- ffmpeg_top_incl=`echo ${ffmpeg_pkg} | sed -e 's:-I::'`
- for i in "" ffmpeg libavcodec ffmpeg/libavcodec; do
- if test -f ${ffmpeg_top_incl}/${i}/avcodec.h; then
-@@ -9568,16 +9568,16 @@
- else
-
- if test x"${with_ffmpeg_lib}" != x ; then
-- if test -f ${with_ffmpeg_lib}/libavcodec.a -o -f ${with_ffmpeg_lib}/libavcodec.${shlibext}; then
-+ if test -f ${with_ffmpeg_lib}/libavcodec0.a -o -f ${with_ffmpeg_lib}/libavcodec0.${shlibext}; then
- ac_cv_path_ffmpeg_lib="-L`(cd ${with_ffmpeg_lib}; pwd)`"
-- libavcodec="-lavcodec"
-+ libavcodec="-lavcodec0"
- LIBS="${ac_cv_path_ffmpeg_lib} $LIBS" top_lib_dir=${with_ffmpeg_lib}
- else
- as_fn_error "${with_ffmpeg_lib} directory doesn't contain libavcodec libraries." "$LINENO" 5
- fi
-- if test -f ${with_ffmpeg_lib}/libavformat.a -o -f ${with_ffmpeg_lib}/libavformat.${shlibext}; then
-+ if test -f ${with_ffmpeg_lib}/libavformat0.a -o -f ${with_ffmpeg_lib}/libavformat0.${shlibext}; then
- ac_cv_path_ffmpeg_lib="-L`(cd ${with_ffmpeg_lib}; pwd)`"
-- libavformat="-lavformat"
-+ libavformat="-lavformat0"
- top_lib_dir=${with_ffmpeg_lib}
- else
- as_fn_error "${with_ffmpeg_lib} directory doesn't contain libavformat libraries." "$LINENO" 5
-@@ -9869,13 +9869,13 @@
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for libavutil library" >&5
- $as_echo_n "checking for libavutil library... " >&6; }
- if test x"$PKG_CONFIG" != x -a x${cross_compiling} = xno; then
-- $PKG_CONFIG --exists libavutil && libavutil=`$PKG_CONFIG --libs-only-l libavutil`
-+ $PKG_CONFIG --exists libavutil0 && libavutil=`$PKG_CONFIG --libs-only-l libavutil0`
- else
- libavutil=""
- fi
- if test x"${libavutil}" = x; then
-- if test -f ${top_lib_dir}/libavutil.a -o -f ${top_lib_dir}/libavutil.${shlibext}; then
-- ac_cv_path_ffmpeg_lib="${ac_cv_path_ffmpeg_lib} -lavutil"
-+ if test -f ${top_lib_dir}/libavutil0.a -o -f ${top_lib_dir}/libavutil0.${shlibext}; then
-+ ac_cv_path_ffmpeg_lib="${ac_cv_path_ffmpeg_lib} -lavutil0"
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: ${top_lib_dir}/libavutil" >&5
- $as_echo "${top_lib_dir}/libavutil" >&6; }
- else
-@@ -9888,7 +9888,7 @@
- $as_echo_n "(cached) " >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lavutil $LIBS"
-+LIBS="-lavutil0 $LIBS"
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
- /* end confdefs.h. */
-
-@@ -9919,7 +9919,7 @@
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_avutil_av_log" >&5
- $as_echo "$ac_cv_lib_avutil_av_log" >&6; }
- if test "x$ac_cv_lib_avutil_av_log" = x""yes; then :
-- ac_cv_path_ffmpeg_lib="${ac_cv_path_ffmpeg_lib} -lavutil"
-+ ac_cv_path_ffmpeg_lib="${ac_cv_path_ffmpeg_lib} -lavutil0"
- fi
-
- fi
-@@ -10126,13 +10126,13 @@
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for libswscale library" >&5
- $as_echo_n "checking for libswscale library... " >&6; }
- if test x"$PKG_CONFIG" != x -a x${cross_compiling} = xno; then
-- $PKG_CONFIG --exists libswscale && libsws=`$PKG_CONFIG --libs-only-l libswscale`
-+ $PKG_CONFIG --exists libswscale0 && libsws=`$PKG_CONFIG --libs-only-l libswscale0`
- else
- libsws=""
- fi
- if test x"${libsws}" = x; then
-- if test -f ${top_lib_dir}/libswscale.a -o -f ${top_lib_dir}/libswscale.${shlibext}; then
-- ac_cv_path_ffmpeg_lib="${ac_cv_path_ffmpeg_lib} -lswscale"
-+ if test -f ${top_lib_dir}/libswscale0.a -o -f ${top_lib_dir}/libswscale0.${shlibext}; then
-+ ac_cv_path_ffmpeg_lib="${ac_cv_path_ffmpeg_lib} -lswscale0"
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
- $as_echo "yes" >&6; }
- else
-@@ -10145,7 +10145,7 @@
- $as_echo_n "(cached) " >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lswscale $LIBS"
-+LIBS="-lswscale0 $LIBS"
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
- /* end confdefs.h. */
-
-@@ -10176,7 +10176,7 @@
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_swscale_sws_scale" >&5
- $as_echo "$ac_cv_lib_swscale_sws_scale" >&6; }
- if test "x$ac_cv_lib_swscale_sws_scale" = x""yes; then :
-- ac_cv_path_ffmpeg_lib="${ac_cv_path_ffmpeg_lib} -lswscale"
-+ ac_cv_path_ffmpeg_lib="${ac_cv_path_ffmpeg_lib} -lswscale0"
- fi
-
- fi
@@ -30836,12 +30836,17 @@
esac
fi