aboutsummaryrefslogtreecommitdiff
path: root/graphics/gnofract4d/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-01-17 12:27:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-01-17 12:27:07 +0000
commitde865df4fd9661851035e04f9559ced71ecf13b6 (patch)
treee48b42803c5004a0e37e18a1bf96f7d087e206d4 /graphics/gnofract4d/Makefile
parentabcd1b9e9063d340f1a6551ae7927f8b9e6104bc (diff)
downloadports-de865df4fd9661851035e04f9559ced71ecf13b6.tar.gz
ports-de865df4fd9661851035e04f9559ced71ecf13b6.zip
Notes
Diffstat (limited to 'graphics/gnofract4d/Makefile')
-rw-r--r--graphics/gnofract4d/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/graphics/gnofract4d/Makefile b/graphics/gnofract4d/Makefile
index d33583aa6ed1..b8459caea306 100644
--- a/graphics/gnofract4d/Makefile
+++ b/graphics/gnofract4d/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= gnofract4d
-PORTVERSION= 3.8
-PORTREVISION= 1
+PORTVERSION= 3.10
CATEGORIES= graphics gnome
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Weird GNOME fractal generator
@@ -20,7 +18,7 @@ USE_GNOME= gnomehack gnomeprefix gnometarget intlhack libgnomeui lthack \
USE_PYTHON= yes
USE_PYDISTUTILS=yes
-PORTDOCS= *
+PORTDOCS= README COPYING
INSTALLS_EGGINFO= yes
PYDISTUTILS_EGGINFODIR= ${PYTHON_SITELIBDIR}
@@ -41,10 +39,8 @@ post-patch:
# libraries again
@${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX}," ${WRKSRC}/gnofract4d
- # where to install docs
- @${REINPLACE_CMD} \
- -e "s,share/doc/gnofract4d-%s/'.*,${DOCSDIR:C/${PREFIX}\///}'\,," \
- ${WRKSRC}/setup.py
+ # fix NOPORTDOCS
+ @${REINPLACE_CMD} -e '233,235d' ${WRKSRC}/setup.py
# fixup library detection
@${REINPLACE_CMD} -e "s/libpng/libpng12/" ${WRKSRC}/setup.py
@@ -52,4 +48,10 @@ post-patch:
-e "s,/usr/include/jpeglib.h,${LOCALBASE}/include/jpeglib.h," \
${WRKSRC}/setup.py
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+.endif
+
.include <bsd.port.post.mk>