aboutsummaryrefslogtreecommitdiff
path: root/graphics/gnustep-slideshow/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2005-02-16 07:10:42 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2005-02-16 07:10:42 +0000
commite5dd5301cec7b07c3e190a0a46e709e74e41ca4a (patch)
tree1c2a005f75a794f9f5843e5ccd3c1050b21d7a0c /graphics/gnustep-slideshow/Makefile
parent8d45078f7f59f48c5f9a2b82334f74d27331dbac (diff)
downloadports-e5dd5301cec7b07c3e190a0a46e709e74e41ca4a.tar.gz
ports-e5dd5301cec7b07c3e190a0a46e709e74e41ca4a.zip
Notes
Diffstat (limited to 'graphics/gnustep-slideshow/Makefile')
-rw-r--r--graphics/gnustep-slideshow/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/graphics/gnustep-slideshow/Makefile b/graphics/gnustep-slideshow/Makefile
new file mode 100644
index 000000000000..96b2394d78ad
--- /dev/null
+++ b/graphics/gnustep-slideshow/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: preview
+# Date created: 16 Feb 2004
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= slideshow
+PORTVERSION= 0.3
+CATEGORIES= graphics
+MASTER_SITES= http://download.gna.org/gsimageapps/
+PKGNAMEPREFIX= gnustep-
+DISTNAME= SlideShow-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= SlideShow Viewer
+
+BUILD_DEPENDS+= ${LOCALLIBDIR}/libSlideShow.so:${PORTSDIR}/${SLIDESHOWKIT_PORT}
+RUN_DEPENDS+= ${LOCALLIBDIR}/libSlideShow.so:${PORTSDIR}/${SLIDESHOWKIT_PORT}
+
+USE_BZIP2= yes
+PREFIX= ${LOCALBASE}/GNUstep
+NO_MTREE= yes
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+MAKEFILE=
+
+SLIDESHOWKIT_PORT?= graphics/slideshowkit
+
+.include <bsd.port.mk>