aboutsummaryrefslogtreecommitdiff
path: root/graphics/goom
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2005-07-07 19:49:29 +0000
committerKoop Mast <kwm@FreeBSD.org>2005-07-07 19:49:29 +0000
commit0f2bdf8a70873698d1876afdf0ae64887f772bdd (patch)
tree1dbd1fc2e218d18f8633d030adc6414370dbd8cf /graphics/goom
parent931c1dfdc221bdf440f8134442229903e2f45941 (diff)
downloadports-0f2bdf8a70873698d1876afdf0ae64887f772bdd.tar.gz
ports-0f2bdf8a70873698d1876afdf0ae64887f772bdd.zip
Fix on 4.x.
Bugged by: pointyhat via kris
Notes
Notes: svn path=/head/; revision=138670
Diffstat (limited to 'graphics/goom')
-rw-r--r--graphics/goom/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/graphics/goom/Makefile b/graphics/goom/Makefile
index 02ca854cf5b9..a719e4949826 100644
--- a/graphics/goom/Makefile
+++ b/graphics/goom/Makefile
@@ -18,10 +18,11 @@ COMMENT= Visual effects library
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:S|.|-|}
USE_GNOME= gnomehack gnometarget
GNU_CONFIGURE= yes
-USE_LIBTOOL_VER= 15
+USE_GCC= 3.4
+USE_INC_LIBTOOL_VER= 15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-sdltest
+CONFIGURE_ARGS= --disable-sdltest --enable-static
INSTALLS_SHLIB= yes
.if exists(${X11R6}/bin/xmms) || defined(WITH_XMMS)
@@ -38,4 +39,13 @@ pre-everything::
@${ECHO} ""
.endif
+patch-autotools:
+ @(cd ${PATCH_WRKSRC}; \
+ for file in ${LIBTOOLFILES}; do \
+ ${CP} $$file $$file.tmp; \
+ ${SED} -e "/^ltmain=/s^\$$ac_aux_dir/ltmain.sh^${LTMAIN}^g" \
+ $$file.tmp > $$file; \
+ ${RM} $$file.tmp; \
+ done);
+
.include <bsd.port.mk>