aboutsummaryrefslogtreecommitdiff
path: root/graphics/gource/Makefile
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2013-03-11 12:36:26 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2013-03-11 12:36:26 +0000
commit6d30370c13e911020d7abe397597ad1c7fd67e68 (patch)
tree8301cf66c75e47e56c711ea4f3a7e6e3b6437879 /graphics/gource/Makefile
parentd7e992bebd42cc38212eec9b8a92746ea22508cd (diff)
Notes
Diffstat (limited to 'graphics/gource/Makefile')
-rw-r--r--graphics/gource/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/graphics/gource/Makefile b/graphics/gource/Makefile
index 77ee65bb2888..0b70e96c4884 100644
--- a/graphics/gource/Makefile
+++ b/graphics/gource/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gource
-PORTVERSION= 0.38
-PORTREVISION= 2
+PORTVERSION= 0.39
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -13,7 +12,7 @@ COMMENT= OpenGL-based 3D visualisation tool for source control repositories
BUILD_DEPENDS= ${LOCALBASE}/include/glm/glm.hpp:${PORTSDIR}/math/glm
LIB_DEPENDS= SDL_image:${PORTSDIR}/graphics/sdl_image \
- ftgl:${PORTSDIR}/graphics/ftgl \
+ freetype:${PORTSDIR}/print/freetype2 \
pcre:${PORTSDIR}/devel/pcre \
GLEW:${PORTSDIR}/graphics/glew \
boost_filesystem:${PORTSDIR}/devel/boost-libs
@@ -23,6 +22,8 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
MANCOMPRESSED= yes
+CONFIGURE_ARGS+=--with-boost-system=boost_system \
+ --with-boost-filesystem=boost_filesystem
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib