aboutsummaryrefslogtreecommitdiff
path: root/graphics/gource
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2013-10-25 17:35:10 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2013-10-25 17:35:10 +0000
commit3859652972f8fc4a4576d3a77c15f1faddd0fbba (patch)
tree297a57c53e4404421886972f34d16cd54d3bf183 /graphics/gource
parent246a4ffef321b1ccc37201f5d335f2e7efa225b0 (diff)
downloadports-3859652972f8fc4a4576d3a77c15f1faddd0fbba.tar.gz
ports-3859652972f8fc4a4576d3a77c15f1faddd0fbba.zip
Convert to new LIB_DEPENDS format;
Fix build on 10/stable (USES=compiler)
Notes
Notes: svn path=/head/; revision=331617
Diffstat (limited to 'graphics/gource')
-rw-r--r--graphics/gource/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/graphics/gource/Makefile b/graphics/gource/Makefile
index 3f287c28784c..5a100de3f757 100644
--- a/graphics/gource/Makefile
+++ b/graphics/gource/Makefile
@@ -11,16 +11,15 @@ MAINTAINER= demon@FreeBSD.org
COMMENT= OpenGL-based 3D visualisation tool for source control repositories
BUILD_DEPENDS= ${LOCALBASE}/include/glm/glm.hpp:${PORTSDIR}/math/glm
-LIB_DEPENDS= SDL_image:${PORTSDIR}/graphics/sdl_image \
- freetype:${PORTSDIR}/print/freetype2 \
- pcre:${PORTSDIR}/devel/pcre \
- GLEW:${PORTSDIR}/graphics/glew \
- boost_filesystem:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libSDL_image.so:${PORTSDIR}/graphics/sdl_image \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libpcre.so:${PORTSDIR}/devel/pcre \
+ libGLEW.so:${PORTSDIR}/graphics/glew \
+ libboost_filesystem.so:${PORTSDIR}/devel/boost-libs
RUN_DEPENDS= ${LOCALBASE}/include/glm/glm.hpp:${PORTSDIR}/math/glm
GNU_CONFIGURE= yes
-USE_GCC= yes
-USES= gmake pkgconfig
+USES= gmake pkgconfig compiler:c++11-lang
MANCOMPRESSED= yes
CONFIGURE_ARGS+=--with-boost-system=boost_system \