aboutsummaryrefslogtreecommitdiff
path: root/graphics/goxel
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-01-03 01:08:22 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-01-03 01:08:22 +0000
commit8a70fa9357a07f6bd56d62764790b1081c8010cb (patch)
tree78d55e1ba66d1481828438fd8538e942264fe7c2 /graphics/goxel
parenta2144b09cdd41b799c975f80db7c99efb5470e5d (diff)
downloadports-8a70fa9357a07f6bd56d62764790b1081c8010cb.tar.gz
ports-8a70fa9357a07f6bd56d62764790b1081c8010cb.zip
Notes
Diffstat (limited to 'graphics/goxel')
-rw-r--r--graphics/goxel/Makefile13
-rw-r--r--graphics/goxel/distinfo6
-rw-r--r--graphics/goxel/files/goxel.desktop10
-rw-r--r--graphics/goxel/files/patch-SConstruct35
-rw-r--r--graphics/goxel/files/patch-ext__src_cycles_src_util_util__path.cpp13
-rw-r--r--graphics/goxel/pkg-plist1
6 files changed, 56 insertions, 22 deletions
diff --git a/graphics/goxel/Makefile b/graphics/goxel/Makefile
index 91530b38eb61..c89221c0dc49 100644
--- a/graphics/goxel/Makefile
+++ b/graphics/goxel/Makefile
@@ -2,9 +2,7 @@
PORTNAME= goxel
DISTVERSIONPREFIX= v
-DISTVERSION= 0.7.1-70
-PORTREVISION= 2
-DISTVERSIONSUFFIX= -g193eded
+DISTVERSION= 0.8.2
CATEGORIES= graphics
MAINTAINER= greg@unrelenting.technology
@@ -13,20 +11,20 @@ COMMENT= Free and Open Source 3D Voxel Editor
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to build: sh: clang++: not found
-
LIB_DEPENDS= libargp.so:devel/argp-standalone \
libglfw.so:graphics/glfw \
libpng.so:graphics/png
-USES= compiler:c++11-lang pkgconfig scons
+USES= compiler:c++11-lang pkgconfig scons gnome gl
USE_GITHUB= yes
GH_ACCOUNT= guillaumechereau
USE_GNOME= cairo gtk30
USE_GL= gl
INSTALLS_ICONS= yes
-MAKE_ARGS= clang=1 debug=0
+MAKE_ARGS= debug=0
+DESKTOP_ENTRIES="Goxel" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Graphics;3DGraphics;" false
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
@@ -35,6 +33,5 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/osx/goxel/goxel/Assets.xcassets/AppIcon.appiconset/${SZ}.png \
${STAGEDIR}${PREFIX}/share/icons/hicolor/${SZ}x${SZ}/apps/goxel.png
.endfor
- ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}
.include <bsd.port.mk>
diff --git a/graphics/goxel/distinfo b/graphics/goxel/distinfo
index c6e67be84221..a23644b16088 100644
--- a/graphics/goxel/distinfo
+++ b/graphics/goxel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1506893291
-SHA256 (guillaumechereau-goxel-v0.7.1-70-g193eded_GH0.tar.gz) = b5c4fea8029543f81dff4c73377f0ef6411f87e65463604a581e3bbc277e66cf
-SIZE (guillaumechereau-goxel-v0.7.1-70-g193eded_GH0.tar.gz) = 1441265
+TIMESTAMP = 1545486941
+SHA256 (guillaumechereau-goxel-v0.8.2_GH0.tar.gz) = 4f8297560e356cb69469e0a23bcb4e9c4e8549766a0466ffeaa0c9cfb7a04049
+SIZE (guillaumechereau-goxel-v0.8.2_GH0.tar.gz) = 3387515
diff --git a/graphics/goxel/files/goxel.desktop b/graphics/goxel/files/goxel.desktop
deleted file mode 100644
index 032035256756..000000000000
--- a/graphics/goxel/files/goxel.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Type=Application
-Version=1.0
-Name=Goxel
-GenericName=3D Voxel Editor
-Icon=goxel
-Exec=goxel
-Keywords=3d;voxel;
-Categories=Graphics;3DGraphics;
-Terminal=false
diff --git a/graphics/goxel/files/patch-SConstruct b/graphics/goxel/files/patch-SConstruct
new file mode 100644
index 000000000000..3ee0c2f64df3
--- /dev/null
+++ b/graphics/goxel/files/patch-SConstruct
@@ -0,0 +1,35 @@
+--- SConstruct.orig 2018-12-22 14:00:12 UTC
++++ SConstruct
+@@ -28,15 +28,18 @@ clang = int(ARGUMENTS.get("clang", 0))
+ cycles = int(ARGUMENTS.get('cycles', 1))
+ sound = False
+
+-if os.environ.get('CC') == 'clang': clang = 1
++import subprocess
++if 'clang' in subprocess.check_output([os.environ.get('CC', 'cc'), '-v'],
++ stderr=subprocess.STDOUT):
++ clang = 1
++print 'clang', clang
+ if profile: debug = 0
+
+-env = Environment(ENV = os.environ)
++
++env = Environment(ENV = os.environ, CC = os.environ.get('CC', 'cc'),
++ CXX = os.environ.get('CXX', 'c++'))
+ conf = env.Configure()
+
+-if clang:
+- env.Replace(CC='clang', CXX='clang++')
+-
+ # Asan & Ubsan (need to come first).
+ # Cycles doesn't like libasan with clang, so we only use it on
+ # C code with clang.
+@@ -145,7 +148,7 @@ if cycles:
+ sources += glob.glob('ext_src/cycles/src/subd/*.cpp')
+
+ env.Append(CPPPATH=['ext_src/cycles/src'])
+- env.Append(CPPPATH=['ext_src/cycles/third_party/atomic'])
++ env.Prepend(CPPPATH=['ext_src/cycles/third_party/atomic'])
+ env.Append(CPPFLAGS=[
+ '-DCYCLES_STD_UNORDERED_MAP',
+ '-DCCL_NAMESPACE_BEGIN=namespace ccl {',
diff --git a/graphics/goxel/files/patch-ext__src_cycles_src_util_util__path.cpp b/graphics/goxel/files/patch-ext__src_cycles_src_util_util__path.cpp
new file mode 100644
index 000000000000..008ccd5b9909
--- /dev/null
+++ b/graphics/goxel/files/patch-ext__src_cycles_src_util_util__path.cpp
@@ -0,0 +1,13 @@
+--- ext_src/cycles/src/util/util_path.cpp.orig 2018-12-22 14:23:19 UTC
++++ ext_src/cycles/src/util/util_path.cpp
+@@ -38,6 +38,10 @@
+ # include <shlwapi.h>
+ #endif
+
++#if defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
++#include <sys/sysctl.h>
++#endif
++
+ #include "util/util_map.h"
+ #include "util/util_windows.h"
+
diff --git a/graphics/goxel/pkg-plist b/graphics/goxel/pkg-plist
index e0ba7bb9d038..12fd45320092 100644
--- a/graphics/goxel/pkg-plist
+++ b/graphics/goxel/pkg-plist
@@ -1,5 +1,4 @@
bin/goxel
-share/applications/goxel.desktop
share/icons/hicolor/32x32/apps/goxel.png
share/icons/hicolor/64x64/apps/goxel.png
share/icons/hicolor/256x256/apps/goxel.png