aboutsummaryrefslogtreecommitdiff
path: root/graphics/goxel
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-03-21 11:04:55 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-03-21 11:04:55 +0000
commit9c1f0ec512d433654da0dc4e1be1c99fed3be868 (patch)
tree9759a3d7c1aa4fd21b233d69c4dd0733cb9d23b7 /graphics/goxel
parentd59a2a33373065279b356ddf13289ee8c7f58083 (diff)
downloadports-9c1f0ec512d433654da0dc4e1be1c99fed3be868.tar.gz
ports-9c1f0ec512d433654da0dc4e1be1c99fed3be868.zip
Fix the following error on !x86:
g++8: error: unrecognized command line option '-msse2'; did you mean '-misel'? PR: 236692 Submitted by: Piotr Kubaj Approved by: maintainer
Notes
Notes: svn path=/head/; revision=496442
Diffstat (limited to 'graphics/goxel')
-rw-r--r--graphics/goxel/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/graphics/goxel/Makefile b/graphics/goxel/Makefile
index 5532900b6e5a..8a89c392c290 100644
--- a/graphics/goxel/Makefile
+++ b/graphics/goxel/Makefile
@@ -26,6 +26,13 @@ MAKE_ARGS= debug=0 werror=0
DESKTOP_ENTRIES="Goxel" "${COMMENT}" "${PORTNAME}" \
"${PORTNAME}" "Graphics;3DGraphics;" false
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${ARCH} != amd64 && ${ARCH} != i386
+ ${REINPLACE_CMD} -e 's/-msse2 //g' ${WRKSRC}/SConstruct
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
.for SZ in 32 64 256
@@ -34,4 +41,4 @@ do-install:
${STAGEDIR}${PREFIX}/share/icons/hicolor/${SZ}x${SZ}/apps/goxel.png
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>