aboutsummaryrefslogtreecommitdiff
path: root/graphics/gphoto2
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-12-29 23:14:24 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-12-29 23:14:24 +0000
commit541cf0967efcc73552bbc7c0fb22b705131684b1 (patch)
tree8e0c0dfacd4b07d14343c4cab798670e0d72bdf6 /graphics/gphoto2
parent5de2e326447951c0ee5a7905794921949d24286d (diff)
downloadports-541cf0967efcc73552bbc7c0fb22b705131684b1.tar.gz
ports-541cf0967efcc73552bbc7c0fb22b705131684b1.zip
Convert pav's ports to new options framework
While here trim headers Explicitly set USE_PKGCONFIG=build where needed Approved by: pav
Notes
Notes: svn path=/head/; revision=309643
Diffstat (limited to 'graphics/gphoto2')
-rw-r--r--graphics/gphoto2/Makefile35
1 files changed, 17 insertions, 18 deletions
diff --git a/graphics/gphoto2/Makefile b/graphics/gphoto2/Makefile
index e86fdcd76600..e4ae296bbcf5 100644
--- a/graphics/gphoto2/Makefile
+++ b/graphics/gphoto2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gphoto
-# Date created: 26 May 1999
-# Whom: Anders Nordby <anders@fix.no>
-#
+# Created by: Anders Nordby <anders@fix.no>
# $FreeBSD$
-#
PORTNAME= gphoto2
PORTVERSION= 2.4.14
@@ -13,11 +9,12 @@ MASTER_SITES= SF/gphoto/gphoto/${PORTVERSION}
MAINTAINER= pav@FreeBSD.org
COMMENT= A command-line frontend to libgphoto2
-LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
- gphoto2.2:${PORTSDIR}/graphics/libgphoto2
+LIB_DEPENDS= popt:${PORTSDIR}/devel/popt \
+ gphoto2:${PORTSDIR}/graphics/libgphoto2
USE_BZIP2= yes
USE_GMAKE= yes
+USE_PKGCONFIG= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-cdk
MAKE_JOBS_SAFE= yes
@@ -27,23 +24,25 @@ MAN1= gphoto2.1
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-OPTIONS= AALIB "Enable command line capture preview (aalib)" on
+OPTIONS_DEFINE= AALIB DOCS NLS
+OPTIONS_DEFAULT= AALIB
+AALIB_DESC= Command line capture preview (aalib)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_AALIB)
-LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib \
- jpeg.11:${PORTSDIR}/graphics/jpeg
+.if ${PORT_OPTIONS:MAALIB}
+LIB_DEPENDS+= aa:${PORTSDIR}/graphics/aalib \
+ jpeg:${PORTSDIR}/graphics/jpeg
.else
CONFIGURE_ARGS+=--without-aalib --without-jpeg
.endif
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
@@ -51,10 +50,10 @@ post-patch:
s|-g -Wall||g' ${WRKSRC}/configure
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
.for file in NEWS
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>