aboutsummaryrefslogtreecommitdiff
path: root/graphics/gplot/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-02-18 20:53:44 +0000
committerSteve Price <steve@FreeBSD.org>1998-02-18 20:53:44 +0000
commit49f7c50002763d90e0556468daac9708e216dd76 (patch)
treeb0aaf0996f93e5b1f97db2c7005171f3878c99a4 /graphics/gplot/Makefile
parentf5585aa71fd4ba483a5c64749f889d5ec125e9a6 (diff)
Notes
Diffstat (limited to 'graphics/gplot/Makefile')
-rw-r--r--graphics/gplot/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/graphics/gplot/Makefile b/graphics/gplot/Makefile
new file mode 100644
index 000000000000..ca29fa298214
--- /dev/null
+++ b/graphics/gplot/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Gplot
+# Version required: 4.3
+# Date created: 26 Dec 97
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $Id$
+#
+
+DISTNAME= gplot
+PKGNAME= gplot-4.3
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.psc.edu/pub/gplot/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= giffunip@asme.org
+
+NO_WRKSUBDIR= yes
+
+ALL_TARGET= drawcgm gtex gplot
+MAN1= gplot.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gplot ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/gtex ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/drawcgm/drawcgm.a ${PREFIX}/lib/libcgm.a
+ ${INSTALL_MAN} ${WRKSRC}/gplot.man ${PREFIX}/man/man1/gplot.1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/Gplot
+ ${GZIP_CMD} ${WRKSRC}/gplot.hlp
+ ${GZIP_CMD} ${WRKSRC}/gplot.txt
+ ${GZIP_CMD} ${WRKSRC}/gtex.doc
+ ${INSTALL_DATA} ${WRKSRC}/*.gz ${PREFIX}/share/doc/Gplot
+.endif
+
+.include <bsd.port.mk>