aboutsummaryrefslogtreecommitdiff
path: root/graphics/grads
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 08:31:29 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 08:31:29 +0000
commitcda59ea3e25f7188d5070e5a9ee5d0af11627402 (patch)
tree933a79805e8e74784ee3f4b8399955b260e7b423 /graphics/grads
parent381250fd12c0b35545d8073b16e86cf0e561e9be (diff)
downloadports-cda59ea3e25f7188d5070e5a9ee5d0af11627402.tar.gz
ports-cda59ea3e25f7188d5070e5a9ee5d0af11627402.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=317482
Diffstat (limited to 'graphics/grads')
-rw-r--r--graphics/grads/Makefile30
1 files changed, 14 insertions, 16 deletions
diff --git a/graphics/grads/Makefile b/graphics/grads/Makefile
index 979010ee18dc..55ef41a5f60c 100644
--- a/graphics/grads/Makefile
+++ b/graphics/grads/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: GrADS
-# Date created: 25 October 2002
-# Whom: Greg Lewis <glewis@FreeBSD.org>
-#
+# Created by: Greg Lewis <glewis@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= grads
PORTVERSION= 1.9b4
@@ -32,30 +28,32 @@ CONFIGURE_ARGS+= --enable-dyn-supplibs \
--with-gui \
--with-x
-OPTIONS= HDF "Build hdf-support (only hdf OR netcdf is supported)" on \
- NETCDF "Build netcdf-support" off
+OPTIONS_DEFINE= HDF NETCDF DOCS EXAMPLES
+OPTIONS_DEFAULT= HDF
+HDF_DESC= Build hdf-support (only hdf OR netcdf is supported)
+NETCDF_DESC= Build netcdf-support
.if !defined(NOPORTDATA)
PORTDATA= *
.endif
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= *
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
PORTEXAMPLES= *
.endif
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_HDF)
+.if ${PORT_OPTIONS:MHDF}
LIB_DEPENDS+= mfhdf.3:${PORTSDIR}/science/hdf
CONFIGURE_ARGS+= --with-hdf
PLIST_SUB+= NETCDF="@comment " HDF=""
.endif
-.if defined(WITH_NETCDF)
+.if ${PORT_OPTIONS:MNETCDF}
LIB_DEPENDS+= netcdf:${PORTSDIR}/science/netcdf4
CONFIGURE_ARGS+= --with-nc
PLIST_SUB+= NETCDF="" HDF="@comment "
@@ -74,13 +72,13 @@ post-install:
${MKDIR} "${DATADIR}"
cd ${WRKSRC}/data && ${COPYTREE_SHARE} . "${DATADIR}"
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} "${EXAMPLESDIR}"
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . "${EXAMPLESDIR}"
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} "${DOCSDIR}"
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . "${DOCSDIR}"
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>