aboutsummaryrefslogtreecommitdiff
path: root/graphics/grafx2/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-06-03 15:00:05 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-06-03 15:00:05 +0000
commitaa5b23decc2486f24bf656a6ec27b7f029be642c (patch)
tree1777631f46e918cb124fc2f960fc499784f96471 /graphics/grafx2/Makefile
parent5355afe606556cdb07e7e73dbe82288cd7fe05ed (diff)
downloadports-aa5b23decc2486f24bf656a6ec27b7f029be642c.tar.gz
ports-aa5b23decc2486f24bf656a6ec27b7f029be642c.zip
Notes
Diffstat (limited to 'graphics/grafx2/Makefile')
-rw-r--r--graphics/grafx2/Makefile54
1 files changed, 40 insertions, 14 deletions
diff --git a/graphics/grafx2/Makefile b/graphics/grafx2/Makefile
index d8f881fbd8ec..eb80e0cf5448 100644
--- a/graphics/grafx2/Makefile
+++ b/graphics/grafx2/Makefile
@@ -6,28 +6,54 @@
#
PORTNAME= grafx2
-DISTVERSION= 2.00b98.0
-DISTVERSIONSUFFIX= -svn482
-PORTREVISION= 5
+PORTVERSION= 2.3.1781
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
EXTRACT_SUFX= .tgz
MAINTAINER= ehaupt@FreeBSD.org
-COMMENT= Bitmap paint program that supports more than 60 video resolutions
+COMMENT= A pixelart-oriented bitmap painting program
+
+OPTIONS= TTF "Enable True Type font support" on \
+ LUA "Enable Lua scripting support" off
USE_GMAKE= yes
-USE_DOS2UNIX= yes
-USE_SDL= image ttf
+USE_SDL= sdl image
MAKE_JOBS_SAFE= yes
-WRKSRC= ${WRKDIR}
-MAKE_ENV+= DATADIR="${DATADIR}"
-CFLAGS+= -DHAVE_SYS_PARAM_H -DHAVE_SYS_UCRED_H -DHAVE_SYS_MOUNT_H \
- -DHAVE_STRUCT_STATFS_F_FSTYPENAME
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+CFLAGS+= -DHAVE_SYS_PARAM_H -DHAVE_SYS_UCRED_H -DHAVE_SYS_MOUNT_H
+
+LIB_DEPENDS= X11:${PORTSDIR}/x11/libX11 \
+ png:${PORTSDIR}/graphics/png
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_TTF)
+MAKE_ARGS+= NOTTF=1
+.else
+USE_SDL+= ttf
+.endif
+
+.if defined(WITH_LUA)
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
+USE_LUA= 5.1
+.else
+MAKE_ARGS+= NOLUA=1
+.endif
post-patch:
- @${REINPLACE_CMD} -e 's|macosx|FreeBSD|g' \
- ${WRKSRC}/divers.c ${WRKSRC}/mountlist.c ${WRKSRC}/aide.c ${WRKSRC}/init.c
+ @${REINPLACE_CMD} \
+ -e 's|^ prefix = .*$$| prefix = ${PREFIX}|' \
+ -e '/scripts\/libs/d' \
+ -e 's/CC = gcc/CC ?= gcc/' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} \
+ -e 's|macosx|FreeBSD|g' \
+ ${WRKSRC}/mountlist.c ${WRKSRC}/init.c
+ @${REINPLACE_CMD} \
+ -e 's|Extract_path(program_dir, argv0);|strcpy(program_dir,"${PREFIX}/bin/");|' \
+ ${WRKSRC}/setup.c
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>