aboutsummaryrefslogtreecommitdiff
path: root/graphics/grafx2
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2012-09-08 23:56:34 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2012-09-08 23:56:34 +0000
commit622346bbf4c66d94b24d66824bef04e9e32cdeeb (patch)
tree7f8bce19bdae9fdb0125ec94b76a29cfd0c846c6 /graphics/grafx2
parent9703e7f4c32340efb1772d8bf07d5165f4582d2e (diff)
downloadports-622346bbf4c66d94b24d66824bef04e9e32cdeeb.tar.gz
ports-622346bbf4c66d94b24d66824bef04e9e32cdeeb.zip
- Use OPTIONSng
- Remove deprecated header information
Notes
Notes: svn path=/head/; revision=303940
Diffstat (limited to 'graphics/grafx2')
-rw-r--r--graphics/grafx2/Makefile26
1 files changed, 11 insertions, 15 deletions
diff --git a/graphics/grafx2/Makefile b/graphics/grafx2/Makefile
index 175da9254066..9d17372103cc 100644
--- a/graphics/grafx2/Makefile
+++ b/graphics/grafx2/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: grafx2
-# Date created: 23 Feb 2009
-# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= grafx2
PORTVERSION= 2.3.1781
@@ -16,8 +11,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A pixelart-oriented bitmap painting program
-OPTIONS= TTF "Enable True Type font support" on \
- LUA "Enable Lua scripting support" off
+LIB_DEPENDS= X11:${PORTSDIR}/x11/libX11 \
+ png15:${PORTSDIR}/graphics/png
USE_GMAKE= yes
USE_SDL= sdl image
@@ -26,18 +21,19 @@ MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}/src
CFLAGS+= -DHAVE_SYS_PARAM_H -DHAVE_SYS_UCRED_H -DHAVE_SYS_MOUNT_H
-LIB_DEPENDS= X11:${PORTSDIR}/x11/libX11 \
- png15:${PORTSDIR}/graphics/png
+OPTIONS_DEFINE= TTF LUA
+TTF_DESC= True Type font support
+OPTIONS_DEFAULT=TTF
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_TTF)
-MAKE_ARGS+= NOTTF=1
-.else
+.if ${PORT_OPTIONS:MTTF}
USE_SDL+= ttf
+.else
+MAKE_ARGS+= NOTTF=1
.endif
-.if defined(WITH_LUA)
+.if ${PORT_OPTIONS:MLUA}
USE_PKGCONFIG= yes
USE_LUA= 5.1
.else
@@ -57,4 +53,4 @@ post-patch:
-e 's|Extract_path(program_dir, argv0);|strcpy(program_dir,"${PREFIX}/bin/");|' \
${WRKSRC}/setup.c
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>