aboutsummaryrefslogtreecommitdiff
path: root/graphics/grafx2
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2019-01-15 13:17:50 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2019-01-15 13:17:50 +0000
commit9ad5a41cebc5da89da37d5247d59f820333abd1e (patch)
treebd33bc7197281dff767f6d79b0dbb51983634a1b /graphics/grafx2
parentb594fd4684963c55b6961860bc2707876dba166d (diff)
downloadports-9ad5a41cebc5da89da37d5247d59f820333abd1e.tar.gz
ports-9ad5a41cebc5da89da37d5247d59f820333abd1e.zip
- Update to 2.6
- Use options helpers
Notes
Notes: svn path=/head/; revision=490372
Diffstat (limited to 'graphics/grafx2')
-rw-r--r--graphics/grafx2/Makefile51
-rw-r--r--graphics/grafx2/distinfo8
-rw-r--r--graphics/grafx2/files/patch-Makefile81
-rw-r--r--graphics/grafx2/pkg-plist122
4 files changed, 140 insertions, 122 deletions
diff --git a/graphics/grafx2/Makefile b/graphics/grafx2/Makefile
index baaeb88ff78f..8ec5d7bb274a 100644
--- a/graphics/grafx2/Makefile
+++ b/graphics/grafx2/Makefile
@@ -2,9 +2,11 @@
# $FreeBSD$
PORTNAME= grafx2
-PORTVERSION= 2.5
+PORTVERSION= 2.6
DISTVERSIONPREFIX= v
CATEGORIES= graphics
+MASTER_SITES= SF/recoil/recoil/${RECOIL_VERSION}/:recoil
+DISTFILES= recoil-${RECOIL_VERSION}${EXTRACT_SUFX}:recoil
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Pixelart-oriented bitmap painting program
@@ -12,48 +14,41 @@ COMMENT= Pixelart-oriented bitmap painting program
LICENSE= GPLv2
LIB_DEPENDS= libX11.so:x11/libX11 \
- libpng.so:graphics/png
+ libpng.so:graphics/png \
+ libtiff.so:graphics/tiff
-USES= gmake pkgconfig tar:tgz iconv:wchar_t
+USES= desktop-file-utils gmake iconv:wchar_t pkgconfig
USE_SDL= sdl image
USE_GITLAB= yes
+
GL_ACCOUNT= GrafX2
GL_PROJECT= grafX2
-GL_COMMIT= 60b5e5fd50acb01cbdc59f50e2c8f4b8786635c0
+GL_COMMIT= 5d8c61e41011a8106359343243e1050af4e7fd1f
+
+INSTALLS_ICONS= yes
+
+RECOIL_VERSION= 4.3.1
WRKSRC_SUBDIR= src
CFLAGS+= -DHAVE_SYS_PARAM_H -DHAVE_SYS_UCRED_H -DHAVE_SYS_MOUNT_H
-OPTIONS_DEFINE= TTF LUA
-TTF_DESC= True Type font support
+OPTIONS_DEFINE= LUA TTF
OPTIONS_DEFAULT=TTF
+OPTIONS_SUB= yes
+TTF_DESC= True Type font support
-TTF_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig
-
-# disable recoil support until we have a librecoil port
-MAKE_ENV+= NORECOIL=1
-
-.include <bsd.port.options.mk>
+LUA_USES= lua:51
+LUA_MAKE_ARGS_OFF= NOLUA=1
-.if ${PORT_OPTIONS:MTTF}
-USE_SDL+= ttf
-.else
-MAKE_ARGS+= NOTTF=1
-.endif
+TTF_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig
+TTF_USE= SDL=ttf
+TTF_MAKE_ARGS_OFF= NOTTF=1
-.if ${PORT_OPTIONS:MLUA}
-USES+= lua:51 pkgconfig
-.else
-MAKE_ARGS+= NOLUA=1
-.endif
+post-extract:
+ @${MV} ${WRKDIR}/recoil-${RECOIL_VERSION} ${WRKSRC}/../3rdparty/
post-patch:
@${REINPLACE_CMD} \
- -e 's|^ prefix = .*$$| prefix = ${PREFIX}|' \
- -e '/scripts\/libs/d' \
- -e 's/CC = gcc/CC ?= gcc/' \
- ${WRKSRC}/Makefile
- @${REINPLACE_CMD} \
-e 's|macosx|FreeBSD|g' \
${WRKSRC}/mountlist.c ${WRKSRC}/init.c
@${REINPLACE_CMD} \
@@ -61,6 +56,8 @@ post-patch:
${WRKSRC}/setup.c
post-install:
+ @${MV} ${STAGEDIR}${PREFIX}/bin/grafx2-sdl \
+ ${STAGEDIR}${PREFIX}/bin/grafx2
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/grafx2
.include <bsd.port.mk>
diff --git a/graphics/grafx2/distinfo b/graphics/grafx2/distinfo
index 1b8d4a2f35ea..1f8726c89879 100644
--- a/graphics/grafx2/distinfo
+++ b/graphics/grafx2/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1526283506
-SHA256 (GrafX2-grafX2-60b5e5fd50acb01cbdc59f50e2c8f4b8786635c0_GL0.tar.gz) = da62f807f34b398706f59c99056dc821031641ec88b669b281e5f5b34149797f
-SIZE (GrafX2-grafX2-60b5e5fd50acb01cbdc59f50e2c8f4b8786635c0_GL0.tar.gz) = 1746766
+TIMESTAMP = 1547548040
+SHA256 (recoil-4.3.1.tar.gz) = 8f64fd21bafa180e6cbac5853ef65453f080385b3c53600af8360e938668e574
+SIZE (recoil-4.3.1.tar.gz) = 448212
+SHA256 (GrafX2-grafX2-5d8c61e41011a8106359343243e1050af4e7fd1f_GL0.tar.gz) = a17d34c0093f73913c4fa5b721a357f3f883d27cb2a5f62d22c47fb96cf513f2
+SIZE (GrafX2-grafX2-5d8c61e41011a8106359343243e1050af4e7fd1f_GL0.tar.gz) = 1229636
diff --git a/graphics/grafx2/files/patch-Makefile b/graphics/grafx2/files/patch-Makefile
index 1996f53cf6c5..25faddb41218 100644
--- a/graphics/grafx2/files/patch-Makefile
+++ b/graphics/grafx2/files/patch-Makefile
@@ -1,36 +1,53 @@
---- Makefile.orig 2018-05-06 15:36:46 UTC
+--- Makefile.orig 2019-01-10 08:40:57 UTC
+++ Makefile
-@@ -35,7 +35,11 @@
+@@ -33,25 +33,8 @@
+ # Compile with OPTIM=0 to disable gcc optimizations, to enable debug.
+ STRIP = strip
- # Detect GIT revision
- GIT_REVISION = $(shell git rev-list --count 1af8c74f53110e349d8f0d19b14599281913f71f..)
-- GIT_BRANCH = $(shell git rev-parse --abbrev-ref HEAD)
-+ ifneq (,$(CI_COMMIT_REF_NAME))
-+ GIT_BRANCH = $(CI_COMMIT_REF_NAME)
-+ else
-+ GIT_BRANCH = $(shell git rev-parse --abbrev-ref HEAD)
-+ endif
- ifneq (master,$(GIT_BRANCH))
- GIT_REVISION := "$(GIT_REVISION)-$(GIT_BRANCH)"
- endif
-@@ -384,7 +388,9 @@ endif
- COPT += $(LUACOPT)
- LOPT += $(LUALOPT)
- OBJDIR = ../obj/win32
-+ WINDRES ?= $(shell which i686-w64-mingw32-windres || which mingw32-windres)
- PLATFORM = win32
-+ PLATFORMOBJ = winres.o
- PLATFORMFILES = bin/SDL.dll bin/SDL_image.dll $(wildcard ../bin/libpng*.dll) $(wildcard ../bin/libjpeg*.dll) bin/zlib1.dll $(TTFLIBS)
- else
- ifdef GP2XCROSS
-@@ -789,6 +795,10 @@ install : $(BIN)
- test -d $(DESTDIR)$(datadir)/grafx2/scripts/samples_2.4/libs || $(MKDIR) $(DESTDIR)$(datadir)/grafx2/scripts/samples_2.4/libs
- test -d $(DESTDIR)$(datadir)/grafx2/scripts/samples_2.4/palette || $(MKDIR) $(DESTDIR)$(datadir)/grafx2/scripts/samples_2.4/palette
- test -d $(DESTDIR)$(datadir)/grafx2/scripts/samples_2.4/picture || $(MKDIR) $(DESTDIR)$(datadir)/grafx2/scripts/samples_2.4/picture
-+ test -d $(DESTDIR)$(datadir)/grafx2/scripts/samples_2.4/picture/thomson || $(MKDIR) $(DESTDIR)$(datadir)/grafx2/scripts/samples_2.4/picture/thomson
-+ test -d $(DESTDIR)$(datadir)/grafx2/scripts/samples_2.4/picture/thomson/lib || $(MKDIR) $(DESTDIR)$(datadir)/grafx2/scripts/samples_2.4/picture/thomson/lib
-+ test -d $(DESTDIR)$(datadir)/grafx2/scripts/samples_2.4/picture/others-8bit || $(MKDIR) $(DESTDIR)$(datadir)/grafx2/scripts/samples_2.4/picture/others-8bit
-+ test -d $(DESTDIR)$(datadir)/grafx2/scripts/samples_2.4/picture/others-8bit/lib || $(MKDIR) $(DESTDIR)$(datadir)/grafx2/scripts/samples_2.4/picture/others-8bit/lib
+-# Detect GIT revision
+-ifeq (true,$(shell git rev-parse --is-inside-work-tree))
+- GIT_REVISION = $(shell git rev-list --count 1af8c74f53110e349d8f0d19b14599281913f71f..)
+- ifneq (,$(CI_COMMIT_REF_NAME))
+- GIT_BRANCH = $(CI_COMMIT_REF_NAME)
+- else
+- ifneq (,$(TRAVIS_BRANCH))
+- GIT_BRANCH = $(TRAVIS_BRANCH)
+- else
+- GIT_BRANCH = $(shell git rev-parse --abbrev-ref HEAD)
+- endif
+- endif
+- ifneq (master,$(GIT_BRANCH))
+- GIT_REVISION := $(GIT_REVISION)-$(GIT_BRANCH)
+- endif
+-else
+ # outside git repository : get version stored in version.c
+ GIT_REVISION := $(shell cat version.c | cut -f 2 -d '"')
+-endif
+
+ REVISION_CACHE = .revision.cache
+ RES := $(shell if [ ! -f $(REVISION_CACHE) ] || [ "`cat $(REVISION_CACHE)`" != "$(GIT_REVISION)" ] ; then echo "$(GIT_REVISION)" > $(REVISION_CACHE) ; fi )
+@@ -88,7 +71,7 @@ TARTRANSFORM = --strip=1 --transform 's,^,grafx2/,g'
+
+ # default to gcc compiler
+ ifeq (default,$(origin CC))
+- CC = gcc
++ CC ?= gcc
+ endif
+ PKG_CONFIG ?= pkg-config
+
+@@ -973,7 +956,6 @@ install : $(BIN)
+ test -d $(DESTDIR)$(datadir)/grafx2/fonts || $(MKDIR) $(DESTDIR)$(datadir)/grafx2/fonts
+ test -d $(DESTDIR)$(datadir)/grafx2/skins || $(MKDIR) $(DESTDIR)$(datadir)/grafx2/skins
+ test -d $(DESTDIR)$(datadir)/grafx2/scripts || $(MKDIR) $(DESTDIR)$(datadir)/grafx2/scripts
+- test -d $(DESTDIR)$(datadir)/grafx2/scripts/libs || $(MKDIR) $(DESTDIR)$(datadir)/grafx2/scripts/libs
test -d $(DESTDIR)$(datadir)/applications || $(MKDIR) $(DESTDIR)$(datadir)/applications
+ test -d $(DESTDIR)$(datadir)/metainfo || $(MKDIR) $(DESTDIR)$(datadir)/metainfo
test -d $(DESTDIR)$(pixmapdir) || $(MKDIR) $(DESTDIR)$(pixmapdir)
-
+@@ -1012,7 +994,6 @@ uninstall :
+ $(if $(wildcard $(DESTDIR)$(datadir)/grafx2/scripts/samples/demo),$(RMDIR) $(DESTDIR)$(datadir)/grafx2/scripts/samples/demo,)
+ $(if $(wildcard $(DESTDIR)$(datadir)/grafx2/scripts/samples/brush),$(RMDIR) $(DESTDIR)$(datadir)/grafx2/scripts/samples/brush,)
+ $(if $(wildcard $(DESTDIR)$(datadir)/grafx2/scripts/samples),$(RMDIR) $(DESTDIR)$(datadir)/grafx2/scripts/samples,)
+- $(if $(wildcard $(DESTDIR)$(datadir)/grafx2/scripts/libs),$(RMDIR) $(DESTDIR)$(datadir)/grafx2/scripts/libs,)
+ $(if $(wildcard $(DESTDIR)$(datadir)/grafx2/scripts),$(RMDIR) $(DESTDIR)$(datadir)/grafx2/scripts,)
+ $(if $(wildcard $(DESTDIR)$(datadir)/grafx2),$(RMDIR) $(DESTDIR)$(datadir)/grafx2,)
+ # Icon and desktop file for debian
diff --git a/graphics/grafx2/pkg-plist b/graphics/grafx2/pkg-plist
index 12a2603552a4..85331c2d45d3 100644
--- a/graphics/grafx2/pkg-plist
+++ b/graphics/grafx2/pkg-plist
@@ -22,64 +22,65 @@ share/applications/grafx2.desktop
%%DATADIR%%/fonts/colorfont.pcx
%%DATADIR%%/gfx2.gif
%%DATADIR%%/gfx2def.ini
-%%DATADIR%%/scripts/samples_2.4/brush/ApplyColor.lua
-%%DATADIR%%/scripts/samples_2.4/brush/Fisheye.lua
-%%DATADIR%%/scripts/samples_2.4/brush/GrayscaleAvg.lua
-%%DATADIR%%/scripts/samples_2.4/brush/GrayscaleDesat.lua
-%%DATADIR%%/scripts/samples_2.4/brush/Halfsmooth.lua
-%%DATADIR%%/scripts/samples_2.4/brush/Waves.lua
-%%DATADIR%%/scripts/samples_2.4/demo/3DPalette.lua
-%%DATADIR%%/scripts/samples_2.4/demo/Ellipse.lua
-%%DATADIR%%/scripts/samples_2.4/demo/FlipPicture.lua
-%%DATADIR%%/scripts/samples_2.4/demo/SierpinskyCarpet.lua
-%%DATADIR%%/scripts/samples_2.4/demo/SierpinskyTriangle.lua
-%%DATADIR%%/scripts/samples_2.4/demo/Spritesheet.lua
-%%DATADIR%%/scripts/samples_2.4/demo/brush/Amigaball.lua
-%%DATADIR%%/scripts/samples_2.4/demo/brush/ColorSphere.lua
-%%DATADIR%%/scripts/samples_2.4/demo/brush/FindAA.lua
-%%DATADIR%%/scripts/samples_2.4/demo/brush/Mandelbrot.lua
-%%DATADIR%%/scripts/samples_2.4/libs/dawnbringer_lib.lua
-%%DATADIR%%/scripts/samples_2.4/libs/memory.lua
-%%DATADIR%%/scripts/samples_2.4/palette/Desaturate.lua
-%%DATADIR%%/scripts/samples_2.4/palette/ExpandColors.lua
-%%DATADIR%%/scripts/samples_2.4/palette/FillColorCube.lua
-%%DATADIR%%/scripts/samples_2.4/palette/InvertedRGB.lua
-%%DATADIR%%/scripts/samples_2.4/palette/Set3bit.lua
-%%DATADIR%%/scripts/samples_2.4/palette/Set6bit.lua
-%%DATADIR%%/scripts/samples_2.4/palette/SetC64Palette.lua
-%%DATADIR%%/scripts/samples_2.4/palette/ShiftHue.lua
-%%DATADIR%%/scripts/samples_2.4/picture/CellColourReducer.lua
-%%DATADIR%%/scripts/samples_2.4/picture/DrawGridIsometric.lua
-%%DATADIR%%/scripts/samples_2.4/picture/DrawGridOrthogonal_RGB.lua
-%%DATADIR%%/scripts/samples_2.4/picture/DrawgridOrthogonal_Index.lua
-%%DATADIR%%/scripts/samples_2.4/picture/FontConvert.lua
-%%DATADIR%%/scripts/samples_2.4/picture/GlassGridFilter.lua
-%%DATADIR%%/scripts/samples_2.4/picture/PaletteToPicture.lua
-%%DATADIR%%/scripts/samples_2.4/picture/Pic2isometric.lua
-%%DATADIR%%/scripts/samples_2.4/picture/Rainbow-Dark2Bright.lua
-%%DATADIR%%/scripts/samples_2.4/picture/RemapImage2RGB.lua
-%%DATADIR%%/scripts/samples_2.4/picture/RemapImage2RGB_ed.lua
-%%DATADIR%%/scripts/samples_2.4/picture/RemapImageTo3bitPal.lua
-%%DATADIR%%/scripts/samples_2.4/picture/Tiler.lua
-%%DATADIR%%/scripts/samples_2.4/picture/XBitColourXpaceFromPalette.lua
-%%DATADIR%%/scripts/samples_2.4/picture/others-8bit/lib/ostro_other.lua
-%%DATADIR%%/scripts/samples_2.4/picture/others-8bit/ostro_oric.lua
-%%DATADIR%%/scripts/samples_2.4/picture/others-8bit/ostro_zx.lua
-%%DATADIR%%/scripts/samples_2.4/picture/thomson/bayer4_mo5.lua
-%%DATADIR%%/scripts/samples_2.4/picture/thomson/bayer4_to8.lua
-%%DATADIR%%/scripts/samples_2.4/picture/thomson/lib/bayer.lua
-%%DATADIR%%/scripts/samples_2.4/picture/thomson/lib/color.lua
-%%DATADIR%%/scripts/samples_2.4/picture/thomson/lib/color_reduction.lua
-%%DATADIR%%/scripts/samples_2.4/picture/thomson/lib/convex_hull.lua
-%%DATADIR%%/scripts/samples_2.4/picture/thomson/lib/ostromoukhov.lua
-%%DATADIR%%/scripts/samples_2.4/picture/thomson/lib/thomson.lua
-%%DATADIR%%/scripts/samples_2.4/picture/thomson/none_mo5.lua
-%%DATADIR%%/scripts/samples_2.4/picture/thomson/none_to8.lua
-%%DATADIR%%/scripts/samples_2.4/picture/thomson/none_to9.lua
-%%DATADIR%%/scripts/samples_2.4/picture/thomson/ostro_mo5.lua
-%%DATADIR%%/scripts/samples_2.4/picture/thomson/ostro_to7.lua
-%%DATADIR%%/scripts/samples_2.4/picture/thomson/ostro_to8.lua
-%%DATADIR%%/scripts/samples_2.4/picture/thomson/ostro_to9.lua
+%%LUA%%%%DATADIR%%/scripts/samples/brush/ApplyColor.lua
+%%LUA%%%%DATADIR%%/scripts/samples/brush/Fisheye.lua
+%%LUA%%%%DATADIR%%/scripts/samples/brush/GrayscaleAvg.lua
+%%LUA%%%%DATADIR%%/scripts/samples/brush/GrayscaleDesat.lua
+%%LUA%%%%DATADIR%%/scripts/samples/brush/Halfsmooth.lua
+%%LUA%%%%DATADIR%%/scripts/samples/brush/Waves.lua
+%%LUA%%%%DATADIR%%/scripts/samples/codenetsend.lua
+%%LUA%%%%DATADIR%%/scripts/samples/demo/3DPalette.lua
+%%LUA%%%%DATADIR%%/scripts/samples/demo/Ellipse.lua
+%%LUA%%%%DATADIR%%/scripts/samples/demo/FlipPicture.lua
+%%LUA%%%%DATADIR%%/scripts/samples/demo/SierpinskyCarpet.lua
+%%LUA%%%%DATADIR%%/scripts/samples/demo/SierpinskyTriangle.lua
+%%LUA%%%%DATADIR%%/scripts/samples/demo/Spritesheet.lua
+%%LUA%%%%DATADIR%%/scripts/samples/demo/brush/Amigaball.lua
+%%LUA%%%%DATADIR%%/scripts/samples/demo/brush/ColorSphere.lua
+%%LUA%%%%DATADIR%%/scripts/samples/demo/brush/FindAA.lua
+%%LUA%%%%DATADIR%%/scripts/samples/demo/brush/Mandelbrot.lua
+%%LUA%%%%DATADIR%%/scripts/samples/libs/dawnbringer_lib.lua
+%%LUA%%%%DATADIR%%/scripts/samples/libs/memory.lua
+%%LUA%%%%DATADIR%%/scripts/samples/palette/Desaturate.lua
+%%LUA%%%%DATADIR%%/scripts/samples/palette/ExpandColors.lua
+%%LUA%%%%DATADIR%%/scripts/samples/palette/FillColorCube.lua
+%%LUA%%%%DATADIR%%/scripts/samples/palette/InvertedRGB.lua
+%%LUA%%%%DATADIR%%/scripts/samples/palette/Set3bit.lua
+%%LUA%%%%DATADIR%%/scripts/samples/palette/Set6bit.lua
+%%LUA%%%%DATADIR%%/scripts/samples/palette/SetC64Palette.lua
+%%LUA%%%%DATADIR%%/scripts/samples/palette/ShiftHue.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/CellColourReducer.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/DrawGridIsometric.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/DrawGridOrthogonal_RGB.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/DrawgridOrthogonal_Index.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/FontConvert.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/GlassGridFilter.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/PaletteToPicture.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/Pic2isometric.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/Rainbow-Dark2Bright.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/RemapImage2RGB.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/RemapImage2RGB_ed.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/RemapImageTo3bitPal.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/Tiler.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/XBitColourXpaceFromPalette.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/others-8bit/lib/ostro_other.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/others-8bit/ostro_oric.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/others-8bit/ostro_zx.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/thomson/bayer4_mo5.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/thomson/bayer4_to8.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/thomson/lib/bayer.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/thomson/lib/color.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/thomson/lib/color_reduction.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/thomson/lib/convex_hull.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/thomson/lib/ostromoukhov.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/thomson/lib/thomson.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/thomson/none_mo5.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/thomson/none_to8.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/thomson/none_to9.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/thomson/ostro_mo5.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/thomson/ostro_to7.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/thomson/ostro_to8.lua
+%%LUA%%%%DATADIR%%/scripts/samples/picture/thomson/ostro_to9.lua
%%DATADIR%%/skins/font_Classic.png
%%DATADIR%%/skins/font_DPaint.png
%%DATADIR%%/skins/font_Fairlight.png
@@ -92,5 +93,6 @@ share/applications/grafx2.desktop
%%DATADIR%%/skins/skin_modern.png
%%DATADIR%%/skins/skin_scenish.png
%%DATADIR%%/skins/unicode_0410-044F.png
-share/icons/grafx2.svg
-share/icons/grafx2.xpm
+share/icons/hicolor/scalable/apps/grafx2.svg
+share/icons/hicolor/scalable/apps/grafx2.xpm
+share/metainfo/grafx2.appdata.xml