aboutsummaryrefslogtreecommitdiff
path: root/graphics/graphviz
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-04-14 14:11:16 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-04-14 14:11:16 +0000
commit08bb56c8149882a645b22ca27b33327de786bb3d (patch)
tree6bb7813940229df6c2657d25d41469eae023da46 /graphics/graphviz
parent6734abdea3212fd7365413153cea0fe212617220 (diff)
downloadports-08bb56c8149882a645b22ca27b33327de786bb3d.tar.gz
ports-08bb56c8149882a645b22ca27b33327de786bb3d.zip
graphics/graphviz: fix build on powerpc64 elfv2
Clang 10 SIGILL's during compilation of this port after upgrade to 2.44.0. Switch to GCC for the time being while this issue is being investigated.
Notes
Notes: svn path=/head/; revision=531693
Diffstat (limited to 'graphics/graphviz')
-rw-r--r--graphics/graphviz/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index 16ca30836ca6..321e4453bfdd 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= libltdl.so:devel/libltdl \
USES= cpe pathfix shebangfix gmake bison groff pkgconfig \
libtool:keepla autoreconf localbase:ldflags jpeg \
- compiler:c++11-lang tcl:build
+ tcl:build
GNU_CONFIGURE= yes
# sincos is broken on armv6, see ports/220591
@@ -169,6 +169,12 @@ NVTHREADS_LDFLAGS= -lpthread
.include <bsd.port.options.mk>
+.if ${ARCH} == powerpc64
+USES+= compiler:gcc-c++11-lib
+.else
+USES+= compiler:c++11-lang
+.endif
+
# allow the use localized gd ports in Makefile.local or slave ports.
GD_PORT?= graphics/gd