aboutsummaryrefslogtreecommitdiff
path: root/graphics/gstreamer1-plugins-gl
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-03-29 17:21:25 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-03-29 17:21:25 +0000
commit9504479c9fd1adf6d4fe2989b4119fca3279ddf7 (patch)
treeb1e394911efce87eb44a1e2f9eb0f80dd6e892f9 /graphics/gstreamer1-plugins-gl
parent51cf7dc1350c35e376a024fb921c2c49ae9bc5ab (diff)
downloadports-9504479c9fd1adf6d4fe2989b4119fca3279ddf7.tar.gz
ports-9504479c9fd1adf6d4fe2989b4119fca3279ddf7.zip
Fix compilation on GCC-based architectures including and similar to:
gstgldebug.h:28: error: redefinition of typedef 'GstGLAsyncDebug' I chose a different approach from the PR. The trick is that since this is a slave port, the patchdir by default is from the masterport. In my fix, I put the patches back into this port's files/ subdir and do some Makefile magic to invoke them. PR: 233788 (based on) Submitted by: Piotr Kubaj Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=497170
Diffstat (limited to 'graphics/gstreamer1-plugins-gl')
-rw-r--r--graphics/gstreamer1-plugins-gl/Makefile6
-rw-r--r--graphics/gstreamer1-plugins-gl/files/patch-gst-libs_gst_gl_gstgl__fwd.h11
-rw-r--r--graphics/gstreamer1-plugins-gl/files/patch-gst-libs_gst_gl_gstglcontext.h11
-rw-r--r--graphics/gstreamer1-plugins-gl/files/patch-gst-libs_gst_gl_gstgldebug.h11
-rw-r--r--graphics/gstreamer1-plugins-gl/files/patch-gst-libs_gst_gl_gstglfuncs.h27
5 files changed, 66 insertions, 0 deletions
diff --git a/graphics/gstreamer1-plugins-gl/Makefile b/graphics/gstreamer1-plugins-gl/Makefile
index 4e611f134ce6..96e85612a294 100644
--- a/graphics/gstreamer1-plugins-gl/Makefile
+++ b/graphics/gstreamer1-plugins-gl/Makefile
@@ -20,6 +20,12 @@ OPTIONS_SUB= yes
WAYLAND_CONFIGURE_ENABLE= wayland
WAYLAND_LIB_DEPENDS= libwayland-egl.so:graphics/wayland
+EXTRA_PATCHDIR= ${.CURDIR}/../../graphics/gstreamer1-plugins-gl/files
+EXTRA_PATCHES= ${EXTRA_PATCHDIR}/patch-gst-libs_gst_gl_gstgl__fwd.h \
+ ${EXTRA_PATCHDIR}/patch-gst-libs_gst_gl_gstglcontext.h \
+ ${EXTRA_PATCHDIR}/patch-gst-libs_gst_gl_gstgldebug.h \
+ ${EXTRA_PATCHDIR}/patch-gst-libs_gst_gl_gstglfuncs.h
+
pre-build:
.for dir in ${GL_GST_DIRS}
@(cd ${BUILD_WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} ${ALL_TARGET})
diff --git a/graphics/gstreamer1-plugins-gl/files/patch-gst-libs_gst_gl_gstgl__fwd.h b/graphics/gstreamer1-plugins-gl/files/patch-gst-libs_gst_gl_gstgl__fwd.h
new file mode 100644
index 000000000000..4e260fe78468
--- /dev/null
+++ b/graphics/gstreamer1-plugins-gl/files/patch-gst-libs_gst_gl_gstgl__fwd.h
@@ -0,0 +1,11 @@
+--- gst-libs/gst/gl/gstgl_fwd.h.orig 2018-12-05 14:04:58 UTC
++++ gst-libs/gst/gl/gstgl_fwd.h
+@@ -102,8 +102,6 @@ typedef struct _GstGLOverlayCompositorClass GstGLOverl
+
+ typedef struct _GstGLQuery GstGLQuery;
+
+-typedef struct _GstGLFuncs GstGLFuncs;
+-
+ typedef struct _GstGLAsyncDebug GstGLAsyncDebug;
+
+ #include <gst/gl/gstgl_enums.h>
diff --git a/graphics/gstreamer1-plugins-gl/files/patch-gst-libs_gst_gl_gstglcontext.h b/graphics/gstreamer1-plugins-gl/files/patch-gst-libs_gst_gl_gstglcontext.h
new file mode 100644
index 000000000000..7ef81fcac242
--- /dev/null
+++ b/graphics/gstreamer1-plugins-gl/files/patch-gst-libs_gst_gl_gstglcontext.h
@@ -0,0 +1,11 @@
+--- gst-libs/gst/gl/gstglcontext.h.orig 2018-12-05 14:06:09 UTC
++++ gst-libs/gst/gl/gstglcontext.h
+@@ -98,7 +98,7 @@ struct _GstGLContext {
+ GstGLWindow *window;
+
+ /*< public >*/
+- GstGLFuncs *gl_vtable;
++ struct _GstGLFuncs *gl_vtable;
+
+ /*< private >*/
+ GstGLContextPrivate *priv;
diff --git a/graphics/gstreamer1-plugins-gl/files/patch-gst-libs_gst_gl_gstgldebug.h b/graphics/gstreamer1-plugins-gl/files/patch-gst-libs_gst_gl_gstgldebug.h
new file mode 100644
index 000000000000..dfec96971000
--- /dev/null
+++ b/graphics/gstreamer1-plugins-gl/files/patch-gst-libs_gst_gl_gstgldebug.h
@@ -0,0 +1,11 @@
+--- gst-libs/gst/gl/gstgldebug.h.orig 2018-12-04 14:57:39 UTC
++++ gst-libs/gst/gl/gstgldebug.h
+@@ -25,8 +25,6 @@
+
+ G_BEGIN_DECLS
+
+-typedef struct _GstGLAsyncDebug GstGLAsyncDebug;
+-
+ typedef gchar * (*GstGLAsyncDebugLogGetMessage) (gpointer user_data);
+
+ /**
diff --git a/graphics/gstreamer1-plugins-gl/files/patch-gst-libs_gst_gl_gstglfuncs.h b/graphics/gstreamer1-plugins-gl/files/patch-gst-libs_gst_gl_gstglfuncs.h
new file mode 100644
index 000000000000..ace6005365a8
--- /dev/null
+++ b/graphics/gstreamer1-plugins-gl/files/patch-gst-libs_gst_gl_gstglfuncs.h
@@ -0,0 +1,27 @@
+--- gst-libs/gst/gl/gstglfuncs.h.orig 2018-03-23 20:44:42 UTC
++++ gst-libs/gst/gl/gstglfuncs.h
+@@ -23,13 +23,6 @@
+
+ #include <gst/gl/gstglconfig.h>
+
+-/* This mimic GCC behaviour with system headers files even if GL headers may
+- * not be in the system header path. */
+-#ifdef __GNUC__
+-#pragma GCC diagnostic push
+-#pragma GCC diagnostic ignored "-Wredundant-decls"
+-#endif
+-
+ /* OpenGL 2.0 for Embedded Systems */
+ #if GST_GL_HAVE_GLES2
+ # if GST_GL_HAVE_PLATFORM_EAGL
+@@ -72,10 +65,6 @@
+ # endif
+ #endif
+
+-#ifdef __GNUC__
+-#pragma GCC diagnostic pop
+-#endif
+-
+ #if defined(WINAPI)
+ #define GSTGLAPI WINAPI
+ #else