aboutsummaryrefslogtreecommitdiff
path: root/graphics/gtimelapse
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-06 15:48:51 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-06 15:48:51 +0000
commit732bf0343e5c60abaf604c30971b725250bb0381 (patch)
tree3914d42f748e17edac6fc78c81bc8044f74b72c4 /graphics/gtimelapse
parent66ece0fad5ffec0194d7343ed7afc8337a9c3b7a (diff)
downloadports-732bf0343e5c60abaf604c30971b725250bb0381.tar.gz
ports-732bf0343e5c60abaf604c30971b725250bb0381.zip
- Clarify LICENSE
- Add LICENSE_FILE - Drop unneeded WX_UNICODE - Regenerate patches with `make makepatch`
Notes
Notes: svn path=/head/; revision=400937
Diffstat (limited to 'graphics/gtimelapse')
-rw-r--r--graphics/gtimelapse/Makefile4
-rw-r--r--graphics/gtimelapse/files/patch-src__gtimelapse.cpp6
2 files changed, 5 insertions, 5 deletions
diff --git a/graphics/gtimelapse/Makefile b/graphics/gtimelapse/Makefile
index c543ef709c63..05677efde696 100644
--- a/graphics/gtimelapse/Makefile
+++ b/graphics/gtimelapse/Makefile
@@ -10,7 +10,8 @@ MASTER_SITES= SF/${PORTNAME}/Relase # yes, this is not a typo (here)
MAINTAINER= ports@FreeBSD.org
COMMENT= Application for capturing images to generate timelapse videos
-LICENSE= GPLv2
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libgphoto2.so:${PORTSDIR}/graphics/libgphoto2
@@ -20,7 +21,6 @@ GNU_CONFIGURE= yes
USES= autoreconf compiler:c++11-lib libtool pkgconfig
USE_WX= 3.0
USE_CXXSTD= c++11
-WX_UNICODE= yes
WX_CONF_ARGS= absolute
PLIST_FILES= bin/${PORTNAME}
diff --git a/graphics/gtimelapse/files/patch-src__gtimelapse.cpp b/graphics/gtimelapse/files/patch-src__gtimelapse.cpp
index 9800f69015b9..cd0caafc8e94 100644
--- a/graphics/gtimelapse/files/patch-src__gtimelapse.cpp
+++ b/graphics/gtimelapse/files/patch-src__gtimelapse.cpp
@@ -1,6 +1,6 @@
---- src/gtimelapse.cpp.orig
+--- src/gtimelapse.cpp.orig 2009-06-08 12:13:59 UTC
+++ src/gtimelapse.cpp
-@@ -155,7 +155,11 @@
+@@ -155,7 +155,11 @@ wxPanel *display_widgets (wxPanel *panel
//cout << "type: RADIO" << endl;
//cout << "current: " << current << endl;
@@ -12,7 +12,7 @@
for ( i=0; i<cnt; i++) {
const char *choice;
-@@ -165,6 +169,10 @@
+@@ -165,6 +169,10 @@ wxPanel *display_widgets (wxPanel *panel
choices[i] = mystring;
}