aboutsummaryrefslogtreecommitdiff
path: root/graphics/gtk-update-icon-cache
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-07-30 09:20:22 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-07-30 09:20:22 +0000
commit0b743289fc32232ef4026a42f720186d8ae7c899 (patch)
tree1d1222f6f025fbba9f6a7bc42cf1bd0545242e55 /graphics/gtk-update-icon-cache
parent42ee47bc6af00264547c217e6ce66acfc5aa7220 (diff)
downloadports-0b743289fc32232ef4026a42f720186d8ae7c899.tar.gz
ports-0b743289fc32232ef4026a42f720186d8ae7c899.zip
Update the glib and gtk stack to the lastest stable releases.
Add new ports for the new stable releases of gtk+-3.0. Update vala to the newest stable release 0.12.1. Thanks to pav@ for doing multiple exp-runs, and marcus@ for repo-copies. Full contributors acknowledgment will be given in the GNOME 3 import.
Notes
Notes: svn path=/head/; revision=278556
Diffstat (limited to 'graphics/gtk-update-icon-cache')
-rw-r--r--graphics/gtk-update-icon-cache/Makefile70
-rw-r--r--graphics/gtk-update-icon-cache/distinfo2
-rw-r--r--graphics/gtk-update-icon-cache/pkg-descr3
3 files changed, 75 insertions, 0 deletions
diff --git a/graphics/gtk-update-icon-cache/Makefile b/graphics/gtk-update-icon-cache/Makefile
new file mode 100644
index 000000000000..bb5c8e41c1cb
--- /dev/null
+++ b/graphics/gtk-update-icon-cache/Makefile
@@ -0,0 +1,70 @@
+# New ports collection makefile for: gtk-update-icon-cache
+# Date Created: 4 Mar 2011
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/graphics/gtk-update-icon-cache/Makefile,v 1.6 2011/06/16 17:36:39 kwm Exp $
+#
+
+PORTNAME= gtk-update-icon-cache
+PORTVERSION= 2.24.5
+PORTREVISION?= 0
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/,} \
+ ftp://ftp.gtk.org/pub/gtk/%SUBDIR%/ \
+ ftp://ftp.gimp.org/pub/%SUBDIR%/ \
+ ftp://ftp.cs.umn.edu/pub/gimp/%SUBDIR%/ \
+ http://www.ameth.org/gimp/%SUBDIR%/ \
+ ftp://ftp.mirror.ac.uk/sites/ftp.gimp.org/pub/%SUBDIR%/ \
+ ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,graphics/gimp/%SUBDIR%,}
+MASTER_SITE_SUBDIR= gtk/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+DISTNAME= gtk+-${PORTVERSION}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= gtk-update-icon-cache utility from the Gtk+ toolkit.
+
+LICENSE= LGPL20
+LICENSE_FILE= ${WRKSRC}/COPYING
+USE_XZ= yes
+
+BUILD_DEPENDS+= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
+RUN_DEPENDS+= ${LOCALBASE}/share/mime/magic:${PORTSDIR}/misc/shared-mime-info \
+ ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
+
+USE_GMAKE= yes
+USE_PERL5_BUILD=yes
+MAKE_JOBS_UNSAFE= yes
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= libtool
+USE_GNOME= gnomehack atk pango gdkpixbuf2 ltverhack
+USE_GETTEXT= yes
+USE_XORG= xext xrender x11 xinerama xi xrandr xcursor xfixes xdamage \
+ xcomposite
+PATCHDIR= ${.CURDIR}/../../x11-toolkits/gtk20/files
+CONFIGURE_ARGS= --enable-static --with-xinput=yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype2 \
+ -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+PLIST_FILES= bin/gtk-update-icon-cache
+
+MAN1= gtk-update-icon-cache.1
+
+.include <bsd.port.pre.mk>
+
+pre-configure:
+.if !exists(${LOCALBASE}/libdata/pkgconfig/cairo-xlib.pc)
+ @${ECHO_CMD} "${PKGNAME}: Needs cairo build with X11 support."
+ @${FALSE}
+.endif
+
+do-build:
+ @cd ${WRKSRC}/gtk && ${GMAKE} gtk-update-icon-cache
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/gtk/gtk-update-icon-cache \
+ ${PREFIX}/bin/
+ @${INSTALL_MAN} ${WRKSRC}/docs/reference/gtk/gtk-update-icon-cache.1 \
+ ${PREFIX}/man/man1/
+
+.include <bsd.port.post.mk>
diff --git a/graphics/gtk-update-icon-cache/distinfo b/graphics/gtk-update-icon-cache/distinfo
new file mode 100644
index 000000000000..53e9d1c878f5
--- /dev/null
+++ b/graphics/gtk-update-icon-cache/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnome2/gtk+-2.24.5.tar.xz) = d6b30889efbb9fab9aa598092d08887826a7b2a3069b3bd5155dede28d9866f3
+SIZE (gnome2/gtk+-2.24.5.tar.xz) = 13252580
diff --git a/graphics/gtk-update-icon-cache/pkg-descr b/graphics/gtk-update-icon-cache/pkg-descr
new file mode 100644
index 000000000000..ce3c00694c19
--- /dev/null
+++ b/graphics/gtk-update-icon-cache/pkg-descr
@@ -0,0 +1,3 @@
+gtk-update-icon-cache util from the Gtk+ toolkits.
+
+WWW: http://www.gtk.org/